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Read Me First 
Welcome to Take Control of PDFpen, Third Edition (version 3.0; 
covers PDFpen 13), published in May 2021 by alt concepts inc. This 
book was written by Michael E. Cohen and edited by Joe Kissell. 

This book tells you how create, edit, and enhance PDF documents on 
the Mac with Smile’s PDFpen 13 and PDFpenPro 13, and on the go 
with PDFpen for iPad & iPhone. 

Copyright © 2021, Michael E. Cohen. All rights reserved. 

Sponsored by Smile 

This book was sponsored by Smile. Special thanks for an enjoyable 
project to Philip Goward, Greg Scown, Jacob Gorban, Angel Vu, 
Jonathan Cost, and Jeff Boerner. 

Updates and More
 

You can access extras related to this ebook on the web (use the link in 
Ebook Extras, near the end). On the ebook’s Take Control Extras page, 
you can: 

•	 Download any available new version of the ebook for free, or buy 
any subsequent edition at a discount. 

•	 Download various formats, including PDF, EPUB, and Mobipocket. 
(Learn about reading on mobile devices on our Device Advice page.) 

•	 Read the ebook’s blog. You may find new tips or information, as 
well as a link to an author interview. 

If you downloaded this ebook from the Take Control website, it has 
been added to your account, where you can download it in other 
formats and access any future updates. 
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What’s New in This Book
 

This book covers version 13 of Smile’s PDFpen and PDFpenPro and 
version 6 of PDFpen for iPad & iPhone. The changes in this book from 
the second edition of Take Control of PDFpen cover the new and 
revised features in those apps. In particular, the user interface of both 
PDFpen and PDFpenPro on the Mac has been substantially revised to 
make it easier to use: most of the changes in this book reflect this 
revision (nearly all the figures, in particular, have been replaced). 
Here’s where you can learn about some of the major changes: 

•	 Need to find where your old, familiar tools have gone? Consult 
Where to Find Tools for a guide. 

•	 You no longer need to click a button to switch between markup and 
selection tools; both are always available. See The Selection Tools 
and The Markup Tools. 

•	 Where did the Font Bar go? The Text Format Tools are now always 
visible as part of the Editing Bar. 

•	 Descriptions of how The Object Property Tools work have been 
substantially revised. 

•	 How you choose and apply colors when you Highlight Text has 
changed. Similarly, the interface changes for when you Add Com-
mentary and Draw Attention reflect the new user interface. 

•	 The iOS/iPadOS app has been revised; I incorporate the various 
changes in Use PDFpen in iOS and iPadOS. 

Note: My descriptions of the Mac versions of PDFpen and PDFpenPro 
are based upon version 13, and the iOS and iPadOS section is based 
upon version 6.0.2. I suggest you update to those versions or later if 
you haven’t already done so. This book should work with any subse-
quent updates to PDFpen, but I suggest you check the blog for this 
book occasionally (a link can be found in Ebook Extras); we often 
provide information about updates there. 
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Introduction 
My office is something of a Vault of Antiquity. To the left of my desk is 
an old three-drawer metal file cabinet bursting with paper documents, 
many of them typed long before the advent of word processing technol-
ogy. Another desk has drawers full of floppy disks and data cartridges 
dating back to the dawn of personal computing. (I even have a box of 
punch cards in the closet.) 

As far as the paper files are concerned, they remain as easy to read as 
the day they were typed; their major drawback is they take up so much 
storage space for so little data. And if I did want them in digital form, 
I could easily scan and OCR them with PDFpen (in this book I explain 
how—in fact, one of those typed relics makes a guest appearance). 

The documents stored on my floppy disks and data cartridges are 
another matter. Even if I could MacGyver together some hardware 
combination to access their contents on my Mac, most of the docu-
ments stored on these artifacts of another age are in obsolete formats 
that render them almost completely indecipherable. 

There is one exception: the PDF documents on my antique storage 
media. If I could get those on my Mac, they likely would be as readable 
as the day they were created. After all, one of the main selling points 
of PDF is that the format was designed to be readable across platforms 
and almost impervious to the ravages of time. And that’s great. 

Unless, that is, you want to edit your PDFs or reuse their contents. 
PDF was not designed for that. 

And that’s where PDFpen comes in. The PDFpen family of apps can 
open and edit nearly any PDF you throw at it with ease, and can even 
export its contents into modern word processing formats. If a PDF is 
like a locked museum display case of content labeled “Look but don’t 
touch,” PDFpen is your set of lock picks. 

The following pages explain how to use them. 
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PDFpen Quick Start 
No matter what you want to do with a PDF, PDFpen or PDFpenPro can 
probably make it happen if it’s possible to do at all. Use this Quick 
Start to find the help you need quickly. 

Get familiar with PDFs and PDFpen: 
•	 Start off by learning how to Get Your Hands on PDFpen, including 

the differences between Standard or Pro and what the differences 
are between obtaining the app from PDFpen Store or the Mac App 
Store; if you have an iPhone or iPad, see how to get PDFpen for iPad 
& iPhone. 

•	 Next, Learn about PDF Files with A Short History of the PDF 
Format, take A Peek at What Is Inside of PDFs, and consider advice 
On Having Realistic Expectations when you work with them. 

•	 After that, Understand the Tools PDFpen offers and learn the 
myriad ways you can Navigate a PDF Document. 

Make and modify PDFs: 
•	 Turn to Create a PDF to see how to Make PDFs from Scratch or 

from a variety of sources, and find out how to Use OCR on Scans 
and Graphic Files to make editable and searchable text when you 
build a new PDF from other sources. 

•	 When you need to Edit a PDF, see how you can Add, Edit, and Re-
move Text as well as Add and Alter Pictures, Rearrange, Rotate, and 
Crop Pages, Create Links to different parts of a PDF or to web 
pages, and Add Headers, Footers, and Page Numbers to gussy up a 
PDF. 

•	 Consult Make an Interactive PDF Form (Pro Feature) to see how 
you can Build a Form and Polish the Layout. 

•	 When you need to work with PDFs on a mobile device, turn to Use 
PDFpen in iOS and iPadOS for guidance on the mobile app’s capa-
bilities. 
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Review PDFs: 
•	 There are often times you want to Take Notes on a PDF; this chap-

ter explores the ways you can Highlight Text, Add Commentary, 
Draw Attention to your notes with PDFpen’s drawing tools, and 
even View, Extract, and Add Attachments. 

•	 When you work with others to Copyedit and Review a PDF, this 
chapter helps you both Learn About Copyediting conventions and 
Learn About Review Practices. 

Export, save, print PDFs, and more: 
•	 Turn to Publish Your PDFs to get up to speed on the different ways 

you can Save or Export Your PDFs and Print Your PDFs. 

•	 Not everything you do with PDFpen need be done by hand; consult 
Appendix A: The PDFpen AppleScripts for ways to automate a 
number of PDFpen’s capabilities. 
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Get Your Hands on PDFpen 
PDFpen 13 comes in two varieties for the Mac—a standard version and 
a pro version—and is available from two different sources: the Mac 
App Store and Smile’s PDFpen website. What’s more, there is also a 
version of PDFpen for iOS and iPadOS from Apple’s App Store. 

If you haven’t yet purchased PDFpen, use this short chapter to learn 
the differences between each version so you can choose the right one 
for your needs. And even if you’ve already bought PDFpen, you can use 
this chapter to learn more about the flavor you chose. 

Standard or Pro
 

Both the standard and pro versions of PDFpen for the Mac are great 
for a vast number of tasks. You can use either to create PDFs, edit 
PDFs, combine PDFs, split PDFs, perform OCR on PDFs, manipulate 
images in PDFs, export PDFs, mark them up many ways, and more. 

What sets PDFpenPro apart are the following additional features: 

•	 Import webpages: You can make a PDF from a single webpage or 
an entire site, complete with clickable links. See Make PDFs from 
HTML (Pro Feature). 

•	 Export to Excel, PowerPoint, and PDF/A archive formats: 
See Save or Export Your PDFs. 

•	 Correct OCRed text: After you OCR a document, you can correct 
any recognition errors; see Edit the OCR Layer in PDFpenPro. 

•	 Multiple file OCR: You can perform OCR on multiple documents 
at once; see Use OCR on Multiple Documents (Pro Feature). 

•	 Make forms: PDFpenPro provides tools to construct and edit 
interactive forms in a PDF, including interactive signature fields 
that users can sign using a trackpad; it also can automatically create 

10
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interactive form fields from a non-interactive PDF form. Make an 
Interactive PDF Form (Pro Feature) describes what you can do with 
forms in PDFpenPro. 

•	 Build a table of contents: You can construct a clickable table 
of contents that automatically includes page numbers and organize 
it as you like; see Make a PDF Table of Contents (Pro Feature). 

•	 Edit bookmark names: You can bookmark pages in both PDF-
pen and PDFpenPro, but only PDFpenPro provides the capability of 
renaming bookmarks; see Bookmarking Pages. 

•	 Automatically create URL links: when a PDF contains URLs in 
its text, PDFpenPro can automatically create clickable links for 
them; see Make Links Automatically (Pro Feature). 

•	 Apply security provisions: With PDFpenPro you can enable or 
disable the standard security features that PDFs provide, such as 
restricting printing and preventing marking up or copying content. 
Protect Your PDFs (Pro Feature) tells you what you can lock down 
in your PDFs and how to do it. 

•	 Attach files: You can attach complete files, such as word process-
ing documents or spreadsheet tables, to a PDF with PDFpenPro, 
and you can delete attachments. Files can be attached to the PDF 
as a whole or as annotations. See Add and Delete File Attachments 
(Pro Feature) 

•	 Create portfolios: PDFpenPro can Create Portfolios (Pro Fea-
ture)—that is, groups of documents collected into a single file, such 
as for delivery to a client or for archival purposes. Portfolios can 
contain multiple PDFs as well as graphic and word processing 
documents. 

•	 Use DocuSign digital signature services: PDFpenPro inte-
grates access to DocuSign so you can securely upload PDFs and 
have the service distribute those PDFs to colleagues, clients, and 
associates for digital signatures; see Use the DocuSign Service (Pro 
Feature). 

If you need any of the above features, you should buy PDFpenPro. 
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Note: In this book, everything I write about PDFpen also applies 
to PDFpenPro; when I do describe features that are exclusive to 
PDFpenPro, however, I make that clear. 

PDFpen Store or the Mac App Store
 

You can purchase PDFpen or PDFpenPro either directly from Smile’s 
PDFpen Store or from Apple’s Mac App Store. 

There are slight differences between versions of PDFpen and 
PDFpenPro purchased from the PDFpen store and those purchased 
through Apple. Those differences fall into two categories: 

•	 Updates: When Smile fixes bugs and makes improvements to 
PDFpen, you can download those updates immediately in copies 
purchased directly from Smile—choose PDFpen (or PDFpenPro) > 
Check for Update. 

This menu choice is not available in copies from the App Store. 
Instead, the update must first be approved by Apple (a process 
that can take days or even weeks), after which it appears in the 
App Store app on your Mac: choose  > App Store and then click 
Updates to check if the approved update is ready to be installed. 

•	 Upgrades: Apple policy doesn’t allow Smile to offer upgrade 
pricing through the App Store. If, for example, you previously 
purchased PDFpen 12 from the App Store, you can’t pay a reduced 
upgrade price in the App Store to upgrade to PDFpen 13: you have 
to pay full price in the App Store for PDFpen 13, whether you have 
a previous version or not. 

Fortunately, the Smile Store recognizes PDFpen 12 and PDFpenPro 
12 licenses from versions that have been obtained via the App Store, 
so you can upgrade at a reduced price directly from Smile. 

Aside from the upgrade and update limitations that Apple imposes, the 
there is no particular disadvantage to buying your copy of PDFpen 
from the App Store, but unless you have a specific reason for getting it 
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there (say, someone gave you an Apple gift certificate), I’d suggest you 
buy your copy directly from Smile’s PDFpen Store. 

Tip: If you are so eager to start using the app that you skip the 
PDFpen Welcome screen, which provides animated examples of 
various PDFpen features, don’t worry: you can always view it later by 
choosing Help > Welcome to PDFpen. 

To purchase from Smile: 
1.	 Go to the PDFpen Store to purchase either PDFpen or PDFpenPro. 

2.	 On the page that appears, do one of the following: 

‣	 Click the Download button for either PDFpen or PDFpenPro to 
get a version you can try out. You can purchase the non-trial 
version from within the trial version. 

‣	 Click the Buy Now button for the version you want and follow the 
instructions that appear. 

Tip: If you’ve purchased PDFpen directly from Smile and discover
 

that you need PDFpenPro, choose PDFpen > Upgrade to PDFpenPro
 

and you’ll have the upgrade in a matter of moments. (Sadly, Apple
 

policy prohibits Smile from offering this feature in PDFpen from the
 

Mac App Store; you can, however, upgrade to PDFpenPro directly
 

from Smile if you have an App Store version of PDFpen.)
 

To purchase from the Mac App Store: 
You can purchase from the Mac App Store by choosing  > App Store 
and then navigating in the App Store to PDFpen or PDFpenPro. 
However, you can go directly to the right place in the App Store from 
a link on Smile’s site: 

1.	 Go to the appropriate page on Smile’s PDFpen site for PDFpen or 
PDFpenPro. 

2.	 Scroll to the bottom of the page that appears in your browser and 
then click Download on the App Store. 
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The product page from the App Store appears first in your browser, 
and then automatically opens the App Store app itself and shows the 
product’s page. 

Note: If you’re wondering what the SetApp button on the PDFpen 
product page is about, it’s because PDFpen is also included among 
the apps that a subscription to the Setapp suite provides. 

PDFpen for iPad & iPhone
 

In addition to PDFpen and PDFpenPro for the Mac, Smile also pro-
duces a version of PDFpen for iOS and iPadOS devices. This app, 
which runs on the iPhone, iPad, and iPod touch, is compatible with the 
Mac versions and features the bulk of the powerful PDF editing capa-
bilities provided by its Mac siblings. Although this book is primarily 
about the Mac versions of PDFpen, I do provide an overview of the iOS 
and iPadOS version in Use PDFpen in iOS and iPadOS. 

PDFpen for iPad & iPhone is available only from the iOS/iPadOS App 
Store. 
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Learn about PDF Files 
It seems like PDF files have been around for a long time—in fact, if 
you’re young enough, they may have been around for your entire life. 
Nonetheless, PDFs are younger than the Mac platform, and, in their 
short time on this planet, they have (just like you) gone through more 
than a few changes. 

You don’t need to know most of the information in this chapter to 
use PDFpen productively. If you are eager to get going, feel free to 
jump ahead to the next chapter, Understand the Tools. But if you like 
to understand why as well as how, this brief chapter gives you back-
ground on how the PDF file format evolved, what it can contain, and 
what you can reasonably expect to be able do with it. 

A Short History of the PDF Format
 

Interestingly, HTML and PDF both originated from similar dreams at 
roughly the same time: the late 1980s. In the case of HTML’s creator, 
Tim Berners-Lee, the dream was to make the scientific papers being 
developed at the CERN particle physics lab in Switzerland available 
to all the CERN scientists using the lab’s computer network, regardless 
of the type of computer attached to the network. In the case of John 
Warnock, PDF’s creator and one of the founders of Adobe Systems, it 
was the dream of “being able to send full text and graphics documents 
(newspapers, magazine articles, technical manuals, etc.) over electron-
ic mail distribution networks,” regardless of the type of computer 
receiving them. 

Adobe had already achieved major success with its invention of 
PostScript, a computer language designed to describe the contents and 
layout of document pages in such a way that a printer (most notably, 
the first Apple LaserWriter printer) could print those documents 
faithfully at any resolution. PostScript, a device-independent language, 
became one of the foundations of PDF. 
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What Does PDF Stand For? 
PDF stands for Portable Document Format. Therefore, saying “PDF 
format” is as redundant as saying “the La Brea Tar Pits” or the “NBC 
broadcasting company.” However, human nature being delightfully 
perverse, the description of the file format has become synonymous 
with files that use the format so that now the terms “PDF,” “PDF 
document,” and “PDF file” all refer to the same thing. 

In 1991, the same year that HTML 1.0 was unleashed upon the world, 
Adobe introduced something at the Seybold conference that it called 
Interchange PostScript, or IPS—the first public mention of what would 
become PDF. IPS became known as PDF 1.0 at Comdex in late 1992. 
By the middle of the following year, Adobe released the first tool for 
editing and viewing PDF documents: Acrobat 1.0 (which Adobe origi-
nally called Carousel). 

Until quite recently, the nature and capabilities of PDF have been 
inextricably linked to the current version of Acrobat. Almost every 
major release of Acrobat has been tied to a major revision of the PDF 
specification. A Wikipedia article summarizes the high points. 

Note: Although PDF version 1.7 became an official ISO standard (ISO 
32000-1:2008) in January 2008, it included some proprietary Adobe 
specifications. 2017’s PDF version 2.0 (ISO 32000-2: 2017) standard-
ized those specifications. 
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A Peek at What Is Inside
 

I said that PostScript became one of the foundations of the portable 
document format. That’s true, as far as it goes; however, a PDF file 
doesn’t contain actual PostScript code. Instead, it contains page-
drawing instructions that are like PostScript instructions but simpli-
fied and designed for efficient processing. PDF instructions manipulate 
the objects displayed on a page, which roughly fall into three types: 

•	 Graphic path objects: These objects contain information about 
the lines, rectangles, and curves on a page, and how they are to be 
placed, drawn, and filled. 

•	 PDF image objects: You can also think of these objects as raster 
images—a stream of pixels, in specific colors, at a specific 
resolution, presented in a specific rectangular area (the display on 
your Mac screen is a raster image, even if the items depicted there 
started out as something else). The PDF image object is unique unto 
the PDF specification. When you make a PDF file by, say, saving a 
webpage to PDF in Safari, the images on that webpage are 
converted into PDF image objects. 

•	 Text objects: These objects contain the text, font, and location 
information (and several other textual attributes) needed to repre-
sent text on a PDF page. The running text you see on a PDF page 
may consist of a lot of different text objects assembled together 
for viewing. These are just a stream of drawing instructions: Text 
objects don’t include the concept of words, paragraphs, and so on; 
they contain only information about how they are supposed to look, 
where they are to be placed, and the characters that are to be drawn. 
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Objects and Imprints 
Text, image, and graphic objects modified by or added to a PDF with
 

PDFpen are called imprints, and they contain additional information
 

which PDFpen employs to facilitate editing and positioning. The PDF
 

specification allows PDFs to contain this program-specific extra
 

information, which is, by convention, ignored by other PDF viewing 

and printing programs.
 

Holding it all together is a great big tree structure from which hang the 
individual pages (each containing a bunch of objects) and all the other 
information that is necessary to print or display the PDF document. It 
is up to the PDF rendering program (such as Preview, Acrobat Reader, 
Safari, or PDFpen) to work its way down the tree, assemble the objects 
and related information that belong to each page, and draw those 
objects on some device, such as a screen or a printer. 

This is a simplified view, to be sure; there are all sorts of other objects, 
such as form elements and annotations, that a PDF can contain as well. 
Such objects can (and often do) contain one or more of the three basic 
objects described here: a form object for a checkbox, for example, 
includes graphic path objects that describe its appearance. 

On Having Realistic Expectations
 

As a quick look at the history of PDF and its internal structure reveals, 
PDF is not an editing format. PDF was designed to be a delivery format 
intended, ultimately, for the eyes of human readers. 

Although the format has over time developed features that make 
machine parsing, analysis, and even editing more practical, PDF files 
are primarily intended to maintain their look across a wide range of 
devices: they are meant to be exact visual representations of printed 
pages, and almost everything about them is designed to make that 
representation more exact and efficient. Any information within the 
PDF specification that enhances editing was added as an afterthought 
and was not one of the original goals of the format’s developers. 
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Here’s a quick guide to some of the edits you can make within the 
limits of the format: 

•	 Touch up text: You can make small text revisions, such as fixing 
typos. However, don’t expect to add whole paragraphs within an 
existing text block (other than in PDFpen-created text imprints), or 
to move paragraphs seamlessly from one text block to another: the 
PDF specification doesn’t include a definition for paragraphs. Also, 
keep in mind that a PDF may use fonts that you don’t have on your 
devices; this may affect the appearance of edited text. See Add, Edit, 
and Remove Text for more details. 

•	 Adjust images: You can’t edit the details of an existing image 
(which is stored in a special PDF image format), but you can move 
it around, crop it, and delete it. You can also adjust its colors, make 
portions of it transparent (great for scans of signatures), and 
straighten it. See Add and Alter Pictures for more. 

Line Art Is Special 
PDFpen cannot edit any line art in a PDF that is a native graphic path 
object. A graphic path object consists of sets of drawing instructions 
that your PDF viewer uses to display the object, and these instruc-
tions do not lend themselves to casual modification. Graphic path 
objects differ from the things you can draw in a PDF using PDFpen’s 
drawing tools: the objects you draw in PDFpen are drawing imprints 
that contain extra information to support editing (similar to how 
PDFpen handles text imprints). 

Nonetheless, with PDFpen’s Precision Edit tool you can select, move, 
scale, and delete native graphic path objects. See Fine-Tune with the 
Precision Edit Tool for more about this tool. 

•	 Add new text imprints and images: Although editing existing 
text within a PDF can be tricky, adding an entirely new, editable text 
imprint is far easier. Same goes for images: you can always plop a 
new one down on a page. See Add, Edit, and Remove Text and Add 
and Alter Pictures for more. 
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•	 Annotate: You can add notes, comments, and various graphic 
objects to mark up a PDF document. You can also add sound anno-
tations and even attach whole document files as annotations. You 
can mark up the text with colors, underscores, strikethroughs, and 
squiggles. See Take Notes on a PDF and Copyedit and Review a 
PDF. 

•	 Move pages around: You can modify the order in which pages 
appear, as well as add or remove them. See Create a PDF and 
Rearrange, Rotate, and Crop Pages for more details. 

From the foregoing you might think that PDF editing resembles Dr. 
Johnson’s description of a dog walking on two legs: “It is not done 
well; but you are surprised to find it done at all.” That’s not really true: 
with a tool like PDFpen the dog can walk much more gracefully than 
you might expect: it might even dance for you. 
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Understand the Tools 
PDFpen provides a rich assortment of tools for modifying PDF docu-
ments. Learning the tools you have at your command is one of the first 
steps of taking control of PDFpen. You can access many of these tools 
in a variety of ways: from a toolbar, from menus, and from the key-
board. Which method you use may depend on what is most convenient 
for you, or it may be a matter of personal preference. 

The tools at your beck and call fall into these general categories: 

• The Selection Tools 

• The Markup Tools 

• The Text Format Tools 

• The Draw Tools 

• The Form Tools (Pro Feature) 

• The Object Property Tools 

In addition to these tools, PDFpen provides an Inspector that you use 
to modify objects in a PDF, and a Library, where you can store graph-
ics and text for reuse. 

The following sections describe where you can find the tools, The 
Inspector, and The Library; they also briefly explain some of the 
circumstances in which you might want to find them. 

Tip: You can find a number of commands at your fingertips with 
a Control-click, which produces a contextual menu offering various 
navigation and editing commands applicable to whatever you clicked. 
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Where to Find Tools
 

Atop each PDFpen document window you’ll find a toolbar and an 
Editing Bar. All the PDFpen tools—the viewing, selection, formatting, 
drawing, markup, and form tools—are available on these two bars 
(Figure 1). 

Figure 1: The toolbar and Editing Bar on top of each PDFpen docu-
ment window provide the viewing, markup, and editing tools you 
use. (Don’t worry if you can’t make out the details; you’ll see them 
in subsequent figures.) 

The toolbar has tools for adjusting your view of the document, adding 
items like highlights and text notes, and accessing useful windows like 
The Inspector and Find windows. 

Tip: As with many Mac apps, you can specify which items appear on 
the toolbar and where they appear: Choose View > Customize Tool-
bar. (Naturally, this book describes the toolbar’s default layout.) 

Beneath the toolbar is the Editing bar, with the tools you use to select 
and manipulate a PDF’s contents and to adjust the appearance of what 
you have selected. You can show or hide the Editing bar with View > 
Hide/Show Editing Bar (⌘-Shift-E). 

Tip: Hover your pointer over any item on the toolbar and Editing Bar 
to see a tip about what the tool is for. 

The tools on these two bars are also available on PDFpen’s Tools and 
Format menus. 
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Notice the Keyboard Shortcuts 
Even if you prefer to use the toolbar and Editing Bar, note the ⌘-key 
equivalents of some of the items on the Tools and Format menus and 
submenus; these can come in handy. 

For those tools that don’t have ⌘-key equivalents, you can create 
your own shortcuts in System Preferences: go to  > System Prefer-
ences > Keyboard > Shortcuts > App Shortcuts and click the Add 
button. 

The Selection Tools
 

You can find PDFpen’s selection tools at the left end of the Editing Bar 
(below the toolbar)—for brevity’s sake, I’m calling them “selection 
tools,” even though, as you’ll see, not all of them select objects within a 
PDF (Figure 2). 

Figure 2: The selection tools appear at the left end of the Editing 
Bar. 

Here’s what each tool in this group does: 

• Select Text : Use this tool to select runs of text within existing 
text blocks for correction or copying (such text blocks are to be 
distinguished from text imprints created within PDFpen, as 
described in Objects and Imprints). In some cases—such as when 
you have the Edit tool selected—PDFpen switches to the Select 
Text tool automatically when you click text within a PDF. 

Note: The Select Text tool does not make the selected text editable 
by itself; you must explicitly choose to correct the selected text in 
order to make changes (see Add, Edit, and Remove Text). 

• Edit : Use this tool to select images, text imprints, or other 
objects you want to move, resize, or delete. Keep in mind that not 
all objects on a page can be selected with this tool. Generally, text 
objects and graphic path objects created by another program cannot 
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be selected and moved by it: you can select only those text and 
graphic imprints that you have added with PDFpen’s own text and 
drawing tools (see, however, the next tool in this list). Note that 
with the Edit tool, you can select, move, resize, and delete most PDF 
image objects within a PDF, whether or not you added them with 
PDFpen’s tools. 

•	 Precision Edit : This is the tool you use when you need to select, 
move, scale, and delete native PDF text objects and graphic path 
objects. See Fine-Tune with the Precision Edit Tool for more about 
using this tool. 

• Select Rectangle : Use this tool to select a rectangular area on 
the currently displayed page. You can then copy the selected area 
and paste it on a page (as a graphic object), or you can crop the 
current page to the selected area. 

•	 Measurement : This tool, while grouped with the selection 
tools, doesn’t select anything. Instead, you use this tool when you 
need to measure something within a PDF. See The Measurement 
Tool sidebar for details. 

•	 Hand : Again, this isn’t a selection tool, though it’s grouped with 
them. You use it to reposition the visible portion of the PDF within 
the window and to zoom in or out. See Adjust the View by Hand. 
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The Measurement Tool 
When you drag it on a PDF, the Measurement tool, found just to 
the right of the selection tools on the Editing Bar, draws a measure-
ment ruler to show the distance between objects on a page. Its sole 
purpose is to provide you with quick measurements. 

The units that the ruler displays depend on the document; by default, 
the ruler uses the measurement units set in PDFpen > Preferences > 
Editing, but if any region in a document contains scale information, 
such as in an architectural document, the ruler shows the units 
specified by that scale (Figure 3). 

Figure 3: The Measurement tool displays the units specified in 
PDFpen’s Preferences by default (left), but it can also use the units 
within scaled regions, such as in architectural documents (right). 

The ruler is temporary, vanishing when you move on to some other 
activity, and you can have only one ruler displayed at a time. 

The Markup Tools
 

Among the most common things people do with PDFs (other than read 
them or print them, of course) is to mark them up with notes, com-
ments, drawings, and additional text blocks. To that end, PDFpen 
provides a variety of tools on the toolbar (Figure 4). 

Figure 4: The markup tools live on the PDFpen window’s toolbar. 
This figure includes the Form tools, available in PDFpenPro. 
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Single-Use Tools 
The Markup tools, with the exception of the Highlight tool, are single-
use by default. That is, if you select one and use it, PDFpen then 
reverts to the Edit tool. For example, if you choose the Text 

annotation tool (see below) and click somewhere on a page, a new
 

text box is created where you clicked and the tool is deselected on
 

the toolbar so the next click uses the Edit 
 tool. 

You can change this default behavior via PDFpen > Preferences > 
Editing by checking “Keep tools selected after use.” This keeps the 
tool selected for repeated use when you click it. If you only occasion-
ally want to lock a tool, leave the Editing preference unchecked and 
double-click the tool to lock it. 

Each of the toolbar markup tool buttons provides a pop-up menu from 
which you can select related but alternative tools. We’ll take a look at 
how to mark up a PDF later, in Take Notes on a PDF and in Copyedit 
and Review a PDF, but, for now, I describe the tools you use for mark-
ing up a PDF that you can choose from each toolbar button’s pop-up 
menu. These tools consist of The Highlight Tool, The Annotate Tools, 
The Form Tools (Pro Feature), and The Draw Tools. 

Note: The icons on the markup tool buttons change to show the 
currently selected tool. When referring to the various toolbar markup 
tool buttons in this book, I use the default icon for the button, which 
is the top icon on each button’s pop-up menu. 

The Highlight Tool 
The toolbar’s Highlight  tool (⌘-3) gives you the capability of 
selecting text and highlighting it, using the current highlight color, 
which is available on the tool’s pop-up menu (Figure 5). 
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Figure 5: The Highlight tool’s pop-up menu offers colors and alter-
native marks. 

In addition to the offered highlight colors, you can use the pop-up 
menu’s Edit Custom Colors command to specify custom highlight 
colors (the rightmost three colors in the menu). The pop-up menu also 
offers the capability of marking text with one of several alternative 
highlight marks and a tool to remove existing highlights. See Take 
Notes on a PDF for more on using this tool. 

Tip: When the Highlight tool’s highlighter marker item is chosen, 
you can drag over non-text portion’s of a PDF’s page to draw free-
form highlight marks with the Highlight pointer. 

The Annotate Tools 
Use the tools available on the Annotate button’s pop-up menu to 
add different types of annotations to a PDF (Figure 6). 
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Figure 6: You can add different types of annotations to a PDF with 
items on the Annotation tools pop-up menu. 

Most of the annotations you can add consist of text that is framed or 
positioned in a specific manner; see Take Notes on a PDF for more 
details. Here’s a list of the types of annotations you can add: 

• Text (⌘-5): This tool creates a text box wherever you click on 
the page. PDFpen refers to these boxes as imprints. You can resize 
the box, adjust the appearance of both the text in the box and the 
background color of the box, and move the box where you like. Text 
imprints are always visible in the PDF, no matter what program you 
view them in, and they are always editable in PDFpen. 

• Note  (⌘-8): This tool adds a note icon to the page along with 
an associated note window in which you can add text. You can 
position both the note icon and its window where you want. If you 
close the note window, you can click the note icon to reopen the 
window. Most PDF viewing programs, such as Preview, allow you to 
show or hide note icons and their windows, although they may look 
somewhat different than they do in PDFpen. 

• Comment (⌘-7): Use this tool to make a comment text box. 
Comment boxes are visually indistinguishable from text imprints. 
Unlike text imprints, however, comment boxes don’t contain rich 
text: they’re restricted to a single font, size, and style. Comment 
boxes, also unlike text imprints, can be given borders, and they have 
borders by default (that’s why I call them comment boxes). Many 
PDF viewing programs allow you to hide or show comment boxes 
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and move them around; text imprints, on the other hand, can’t be 
hidden. 

• Cloud : An alternative to the Comment annotation tool’s text 
box, this tool surrounds the comment box with a cloud shape, 
making it more visually identifiable as a comment. 

• Callout : Drag from a point of interest in a PDF to create a 
callout text box. See Draw Callouts. 

• Link (⌘-9): You use this tool to create transparent rectangular 
link objects that, when clicked, go to a web location, to another page 
within the PDF, or to a PDF stored elsewhere (see Create Links). 
You can position and resize these objects. By default, link objects 
have no borders, though you can add them—and choose their colors 
and thickness—with The Object Property Tools at the right end of 
the Editing Bar. 

Tip: It is a kindness to your PDF’s readers to provide some sort of
 
visual clue that a link is present, so consider providing your links 

with borders or some other indicator, such as colored text (like on
 

webpages) or a button-like icon.
 

• Attachment (Pro only): Attach any file as an annotation with 
this tool. For example, if the PDF you receive from a colleague 
contains a spreadsheet table, you could attach a revised spreadsheet 
document that the colleague might want to use instead. I recom-
mend that you also add a text comment beside the attachment 
explaining what the file contains and including the file’s name. 

• Sound : Record a sound annotation, or attach a pre-recorded 
audio file, with this tool. Those who read the PDF can click the 
annotation to hear the recording. 

Note: PDF apps that don’t support file or audio attachments (includ-
ing Apple’s own Preview app) strip out these attachments if you save 
the PDF with those apps. 
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The Form Tools (Pro Feature) 
You use the Form creation tools (Figure 7), which appear among 
PDFpenPro’s markup tools on the toolbar, to add interactive form 
elements to a PDF. Make an Interactive PDF Form (Pro Feature) 
describes how to set the elements’ names, values, behaviors, and other 
characteristics (and you might also want to check out Fill Out PDF 
Forms). 

Figure 7: Use PDFpenPro’s Form creation tools, available on the 
Form button’s pop-up menu on the toolbar, to make an interac-
tive PDF form. 

Select a Form creation tool and then click on the page to create a form 
element at its default size; drag to create an element of custom size. 
You can also resize elements after you create them. 

Form Elements and Compatibility 
When viewed in PDF apps other than PDFpen and PDFpenPro, the 
appearance of the form elements will vary, and some PDF apps may 
not support all of the form elements that PDFpenPro can add. The 
PDF form specification leaves the appearance of form elements and 
support for them up to each PDF app’s developer. 

Here are the Form creation tools that PDFpenPro provides: 

• Text Field : Use this to create a field into which the user can 
enter text. The default field has a 1-point border; you can set border 
width, style, and stroke color with The Object Property Tools. 
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• Checkbox : You can add a checkbox and an associated label text 
imprint with this tool. The size and placement of both the box and 
its label are separately adjustable. 

• Radio Button : Use this to make a radio button with an associ-
ated label text imprint. Radio buttons are never solitary, since they 
present a set of mutually exclusive choices, so if you add one, you 
should add at least one more. All the buttons in a radio button 
group should share the same name but have different values, which 
you can set on the Form Element Properties tab of The Inspector. 

• Dropdown : Use this to create a dropdown menu form element 
with multiple menu choices. This element can look significantly 
different in apps other than PDFpen and on platforms other than 
the Mac. 

• List : This tool inserts a list box, which contains a list of text 
items from which the user can choose. Depending on how you set 
the list’s properties, a user can be restricted to a single choice, or 
can choose multiple items. 

• Signature : Insert an interactive signature field with this tool. 
Users tap the field on a trackpad or touchscreen and then write their 
signatures by fingertip; they can optionally accompany the signa-
ture graphic with digital signature certificates (see Sign Forms 
Digitally). The image of the signature is included with the form 
when it is submitted. 

• Button : Use this to create a Submit button, which, when
 
clicked, submits form data either via email or to a web app.
 

The Draw Tools 
As I pointed out earlier in Line Art Is Special, modifying standard 
PDF graphic path objects is limited using PDFpen’s capabilities. 
However, you can use PDFpen’s Draw tools to add new graphic 
objects to a PDF. PDFpen’s graphic objects contain additional editing 
information so you can modify them in PDFpen, even though they 
appear and behave as regular graphic path objects in other PDF 
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viewers. You can use the Edit tool to select, move, and resize graphic 
objects created by the drawing tools (see The Selection Tools). 

PDFpen’s drawing tools, available on the toolbar’s Draw  tools pop-
up menu (Figure 8), are similar to those in many other programs, and 
probably look familiar to you. You can also choose any drawing tool 
from the Tools menu. 

Figure 8: The PDFpen Draw tools pop-up menu. 

Here are the kinds of graphic objects you can create in PDFpen: 

• Scribble  (⌘-6): As you drag with this freehand drawing tool, it 
draws a line that follows the dragged path. You can select, resize, 
and move these scribbles with the Edit tool (see The Selection 
Tools). 

• Polygon : Use this to create simple or complex objects made 
of connected line segments. Each click adds a line segment to the 
polygon (Figure 9); click the endpoint of a line segment to close 
the polygon. 

Figure 9: A polygon being drawn, segment by segment. 

• Rectangle , Oval , and Rounded-Edged Rectangle : 
Click or drag with these tools to insert the respective shaped objects. 

• Line : Drag with this tool to draw a line object. 
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Tip: You can adjust the line thickness, line color, line style, and fill 
color of any object made with the drawing tools (see The Object 
Property Tools). You can also specify the endpoint style of line ob-
jects; for example, you can place arrowheads at either end. 

The Text Format Tools
 

Whether you’re adding text to a PDF with one of The Markup Tools or 
have chosen to Use the Correct Text Command to change the text 
already in a PDF, you may also want to have some control over how 
that text looks. That’s a golden opportunity to use PDFpen’s text 
format tools that appear on the Editing Bar to the right of the selection 
tools (Figure 10). (If the Editing Bar isn’t visible, choose View > Show 
Editing Bar.) 

Figure 10: The text format tools on the Editing Bar provide quick 
access to common text formatting commands. 

When you select editable text, you can use the text format tools to 
change the selection’s typeface, type size, type style, type color, and 
type alignment quickly. 

Note: You are, of course, not limited to the text formatting capabili-
ties of the Editing Bar tools; PDFpen provides additional commands 
you can use to Change the Appearance of Text. 

The text format tools also come in handy even when you select non-
editable text in a PDF. Ever seen a typeface in a PDF and wonder what 
it was? Select the text with the Select Text tool, and the text format 
tools tell you (Figure 11). 
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Figure 11: The text format tools reveal the typeface used in a text 
selection, editable or not, such as this text in the Georgia typeface. 

The Object Property Tools
 

The object property tools are the rightmost items on the Editing Bar 
(Figure 12). 

Figure 12: The object property tools are four pop-up menus from 
which you can control the visual appearance of objects in a PDF. 

From left to right, the object property tools affect the following aspects 
of an object’s appearance: 

•	 Stroke Color : Use this pop-up menu to choose the stroke 
color of a selected object (that is, the color of the lines that make up 
or enclose an object). The current stroke color is displayed below 
the pop-up menu’s icon. 

•	 Fill Color : This pop-up offers colors with which you can fill the 
interior region of a graphic object; the current fill color for a select-
ed object, if any, appears under the tool’s icon. 

•	 Stroke style: Use this tool to specify how the lines that make up or 
surround an object appear. For example, you can specify dotted or 
dashed lines for boxes and elliptical shapes, or the kinds of end-
points that appear on lines, such as arrowheads. 

•	 Stroke width: Click this tool to choose the width of the lines that 
make up or surround a selected object. 

See Draw Attention for more about using the object property tools. 
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PDFpenPro note: You can use the object property tools to control 
the appearance of form elements. However, different PDF viewing 
apps will often render your form elements differently than you speci-
fy, or completely ignore your customization choices. 

The Inspector
 

The Inspector’s name understates its power: with it, you can do more 
than merely inspect things in a document—you can also change things. 

To display the Inspector, choose Window > Inspector (⌘-Option-I) or 
click the Inspector icon on the document window’s toolbar. You can 
also display any desired tab in the Inspector by choosing the tab’s 
name from the Window menu—or pressing a keyboard shortcut, as 
shown on the menu. 

The PDFpen Inspector contains the following tabs, from left to right: 

• Alignment (⌘-Option-1): When two or more objects are 
selected, use this tab to align them horizontally or vertically, by 
their edges or by their centers. When three or more objects are 
selected, you can also distribute the distance between them evenly, 
both horizontally and vertically. 

• Form Element Properties (PDFpenPro feature; ⌘-
Option-2): You can set the name, value, appearance, and behavior 
of a selected form element here. The active controls that appear on 
the tab vary depending on the form elements chosen. 

• Document Information (⌘-Option-3): Use this tab to apply 
metadata to the document and to view additional data. You can 
specify the document’s title (which is distinct from its filename), 
author, subject, and one or more keywords that apply to its content 
or purpose. You can see, but not change, the date and time the 
document was created, the date and time it was last modified, and 
the file and page size. You can also see both the name of the app and 
the producer of the PDF document (these are explained in the 
sidebar just ahead). 
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• Document Permissions (PDFpenPro feature; ⌘-
Option-4): You can specify a document password and enable or 
disable various document permissions on this tab. See Protect Your 
PDFs (Pro Feature) for more about document permissions. 

Application? Producer? What?! 
The distinction between Application and Producer on the Inspector’s 

Document Information tab can be confusing, so here’s an example.
 

Suppose you export a Pages document to PDF. When you view the 
PDF in PDFpen, the Inspector’s Document Information tab shows 
the Application as “Pages” and the Producer as something like 
“macOS Version 11.2.3 (Build 20D91) Quartz PDFContext” (this is the 
name of the underlying system software that generates PDFs from 
the Print dialog). 

You can use this information to figure out the source of a PDF, which 
might be useful especially if the PDF has problems or visual oddities 
(“Dan, I see that you created the PDF you sent me with Acrobat 6 in 
Windows—maybe you should upgrade!”). 

By the way: Apple’s Preview has an Inspector as well, and it uses the 
terms Content Creator and PDF Producer instead of Application and 
Producer. To-may-to, to-mah-to… 

The Library
 

PDFpen’s Library is like the junk drawer that all of us have somewhere 
in our homes. (What? You don’t? What kind of person are you, any-
way?) Like a junk drawer, the Library contains useful items that you 
may need from time to time. 

To open the Library, choose Window > Library (⌘-Y), or click Library 
on the toolbar. 

The Library comes with some items already in it, but you can add 
your own, including graphic images, objects you draw with PDFpen’s 
drawing tools, text imprints, and, in PDFpenPro, text fields from 
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forms. Unlike the typically chaotic junk drawer, however, the Library 
has separate collections for each type of object it contains (Figure 13). 

Figure 13: The Library window has separate collections for each 
kind of item: Built-ins, Custom, Proofreading Marks, and Stamps. 

You access each of the collections by clicking its tab at the top of the 
Library window. Here’s what each collection contains: 

• Built-ins : This collection has the four standard drawing shapes 
you can create with the drawing tools. You cannot add items to this 
collection (if you could, they wouldn’t be built-in, now would they?). 
Why use the built-ins? Sometimes, dragging an object from the 
Library to the PDF is faster than switching tools to draw it. 

• Custom : This collection is for objects that you might want to 
place on a page in the future: text imprints, graphic objects made 
with the drawing tools, comments, images, and text fields created 
with The Form Tools (Pro Feature). Anything you add to the Library 
goes into this collection. 

• Proofreading Marks : This collection contains a large variety 
of proofreading marks. You cannot add items to this collection. 

• Stamps : This collection contains various types of stamps and 
stickers used for business purposes. You can choose from three sets 
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of predefined stamps with the pop-up menu that appears below the 
collection, and you can add your own stamps: 

‣	 Standard Business: These include stamps like “Confidential” and 
“Draft.” 

‣	 Sign Here: Use these to indicate where someone should sign or 
initial the PDF. 

‣	 Dynamic: These are similar to the Standard Business stamps,
 
but they include your name, date, and time.
 

‣	 User Defined: These are stamps you have created. To add a User 
Defined stamp, choose Add Custom Stamp (⌘-Option-Shift-9) 
from the Add pop-up menu and then, in the dialog that 
appears, define the stamp’s contents and appearance. 

Note: You can set the name used in Dynamic stamps by editing the 
Name field in PDFpen > Preferences > Editing. 

To see the Library window and its contents at a larger size, click the 
Library Size button; to reduce the window’s size, click it again. 

To use a Library item, drag it from the Library window to the page. 

To add items to the Custom collection, do the following: 

1. With the Edit tool, select one or more items on a page in the PDF. 

2. From the Add pop-up menu at the lower left of the Library 
window, choose Add Selected Imprint. 

PDFpen automatically puts the selected item in the Custom collection. 

Note: If you have more than one item selected when you choose Add 
Selected Imprint, PDFpen adds all the selected items to the Library as 
a single unit. 
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Tip: The Library’s Add pop-up menu contains another item: Add 
File. You can use this to select any graphic file on your Mac to add it 
to the Custom collection. 

You can also remove any item you have added to the Custom 
collection: select it in the Library and click the Remove  button. 

Note: If you are signed in to iCloud and have given PDFpen access to 
iCloud Drive, your Library contents sync to your other Macs and iOS/ 
iPadOS devices that are also signed in and have the same access. 
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Navigate a PDF Document 
Some PDFs you encounter consist of just one page, such as an 
advertising flyer. Navigating those kinds of PDFs is simple, because 
there’s really nowhere to navigate to. 

But a PDF of, say, a software manual or a yearly financial report is 
another matter. PDFpen provides several ways to navigate a large 
document. This chapter shows you how to get around quickly so you 
can get on with your work. 

Display Pages
 

For decades, the World Wide Web has made us comfortable with the 
idea of single pages that contain endlessly flowing text. On the web we 
expect everything to exist on a single page, and we become annoyed 
when, for example, we read a news story that is “continued on page 2,” 
forcing us to click and wait for a page to load. How primitive! How 
20th century! 

But, unlike HTML, PDF was designed to replicate the physical, pagi-
nated world of books, magazines, pamphlets, and reports. Fundamen-
tal to the PDF specification (see Learn about PDF Files) is the concept 
that PDFs are composed of pages: rectangular areas on which text, 
images, and graphic objects are placed. 

PDFpen provides several ways to arrange and view the pages in a PDF 
to suit your needs and personal proclivities. 

Facing Pages 
Although we tend to read one page at a time, it can be very helpful to 
see pages spread out, side by side (or “two-up”), the way they appear 
in books, such as in Figure 14. This is especially true with today’s 
wide-screen, high-resolution monitors where there’s room to see two 
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pages at a time clearly. It’s also useful when you want to get a better 
idea of how a page design works in the context of other pages. 

Figure 14: A PDF is displayed in a facing pages view. 

There are two ways you can switch from single page view to facing 
pages view: 

• Choose View > Facing Pages. 

• On the toolbar, click the Sidebar button’s pop-up menu and 
then choose Facing Pages. 

Facing Pages Preference and Start with Cover 
A setting in PDFpen > Preferences > General is associated with facing 
pages: “Default view,” which you can either set to Single Page or to 
Facing Pages. 

Whether you set Facing Pages or not as a default, when you enable
 

Facing Pages you might also want to choose the View > Start with
 

Cover command, which when chosen shows the PDF’s first page on
 

its own as in a printed book.
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Tip: If you have a PDF in a language that ordinarily presents pages 
in right-to-left order, such as Japanese or Arabic, you can choose 
View > Pages Right-to-Left. 

Magnifying Pages 
Sometimes, such as when you want to select text set in very small type, 
it’s useful to see a page in a magnified view. Other times, such as when 
you want a general overview of a page layout, you may want to zoom 
out so you can view an entire page, or even several pages, at once. 

You can use the following commands on the View menu to set the 
magnification of the page view: 

•	 Actual Size (⌘-0 [Zero]): PDFpen obtains the pixel density of 
the Mac’s display from macOS and uses that information to scale 
the document to its full size on screen. 

•	 Zoom In (⌘-+): This magnifies the view of the page by a small 
percentage, which varies depending on the current magnification. 
For example, at 100% magnification (actual size), this command 
increases the magnification to 110%. At 110% magnification, howev-
er, the same command increases it to 121%. In other words, the 
higher the current magnification, the larger the percentage of 
increased magnification the command delivers. 

•	 Zoom Out (⌘--): This reduces the magnification by a percentage 
relative to the current magnification, much like the way that Zoom 
In works. 

•	 Zoom to Fit (⌘-Option-0 [Zero]): This adjusts the 
magnification so an entire page fits within the viewing area of the 
window. If you have facing pages displayed, the command adjusts 
the magnification so two pages fit in the viewing area. 

•	 Zoom to Width (⌘-Option-9): To view the complete width of 
the current page regardless of the viewing area’s height, choose this 
command. 
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Tip: With a trackpad, you can change the magnification using the 
pinch-in and pinch-out gestures. 

A Matter of Scale 
PDFpen > Preferences > General, you can choose what 100% scale 
(actual size) means (Figure 15). 

Figure 15: You can choose how PDFpen interprets “100% scale.” 

The first choice makes PDFpen pretend that the screen has a resolu-
tion of 72 DPI: on a high resolution screen, the PDF will look smaller 
at 100% scale than on a lower resolution screen. The second choice 
makes PDFpen take the screen resolution into account, so that 
something that is, say, one inch tall on the screen when magnified 
to 100% scale, will be one inch tall when printed. 

Use the Magnifier Window 
As you have just seen in the previous topic, you can zoom in or out of 
your view of a PDF. There are times, though, when you may not want 
to zoom in on the entire document but just want to see a magnified 
portion of it. For example, you may have a map of a wilderness hike 
and want to see both the full map but also take a close look at a trail 
junction on it, or perhaps you have a PDF containing a study of 
Etruscan pottery and you want to be able to read the text while getting 
a close look at the figure showing an important shard, or maybe you 
want to examine the exquisite line art printed on a PDF scanned from 
an old government document (Figure 16). Those are the sorts of tasks 
the floating Magnifier window is designed to help you accomplish. 
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Figure 16: Use the Magnifier window to examine fine details within 
a PDF, such as the exquisite line art found in a mid-20th century 
government report. 

To bring up the Magnifier window, choose Window > Magnifier (⌘-
Option-M); choose the command again to dismiss the window. 

To see a magnified portion of a PDF, point at the document: the 
window magnifies whatever part of the PDF your pointer is over. 

Note: You can use any Editing bar tools when the Magnifier is open; 
whether your pointer is an arrow pointer or some drawing tool
 
makes no difference.
 

You can adjust how much the window magnifies using the slider at the 
bottom of the window or by clicking the plus + or minus – buttons at 
the ends of the slider. 

Split the View 
Have you ever read a book with endnotes? Did flipping back and forth 
between the main text and the notes irritate you? If the book were in 
PDF form, and you were reading it in PDFpen, that irritation would 
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evaporate with the morning dew, courtesy of the Split command. This 
command offers the capability of displaying two parts of the same 
document at once (Figure 17). 

Figure 17: Both the main text of this essay about the creation of the 
first ebooks and the endnotes for the essay appear at the same time 
in PDFpen’s Split view. 

To split a PDFpen window, choose Window > Split > Horizontally (as 
in Figure 17 just above) or Window > Split > Vertically (for a side-by-
side layout). 

To remove the split view, choose Window > Split > Remove Split. 

When you split a PDFpen window, you can scroll each view separately: 
click within the view you want to scroll to focus PDFpen’s attention on 
it, and then scroll as you ordinarily would. The toolbar’s Page indicator 
shows the number of the selected view’s page. 

Tip: Customize the toolbar (View > Customize Toolbar) to add Page
 

Up 
 and Page Down buttons to it so you can then use them to
 

move from page to page within the selected view (see Navigate
 

Pages for more about moving between pages).
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Similarly, you can zoom into or out of each view independently using 
the toolbar’s Zoom In  and Zoom Out buttons or with the menu 
commands described in Magnifying Pages just previously: click the 
view you want to zoom and then use any of the zooming methods. The 
toolbar’s Scale indicator reflects the magnification of the currently 
selected view. 

Not All Split Views are Equal 
When you use a split view, PDFpen treats the left view (for vertical
 
splits) or top view (for horizontal splits) as the main view. The other
 

view is designed to allow you to compare its contents with the main
 

view and is read-only. Thus, you may Edit a PDF’s contents or Take
 

Notes on a PDF only in the main view.
 

Similarly, when you Navigate with the Sidebar while using a split 
view, PDFpen uses the active view for navigation purposes by default 
regardless of which view you have selected. You can, however, 
navigate the other view with the sidebar by Option-clicking sidebar 
entries. 

Adjust the View by Hand 
For those times when you are zoomed in to the PDF very closely, or, for 
that matter, zoomed really far out, you could make use of the scroll 
bars to move your view (depending on your Show Scroll Bars setting in 
System Preferences > General and the type of pointing device you 
have), but an alternate, and often easier, way to pan around your PDF 
is with the Editing Bar’s Hand  tool. 

To pan around the page, simply drag with the tool. 

When the Hand tool is selected, you can use it to zoom the view in 
and out: 

•	 Zoom in: Option-click the page to zoom the view in the same man-
ner as View > Zoom In (⌘-+). 

•	 Zoom out: ⌘-Option-click the page to adjust the view in the same 
way as View > Zoom Out (⌘--). 
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• Zoom in an arbitrary amount: Option-drag the Hand tool in 
any direction. The shorter the drag, the greater the magnification, 
up to PDFpen’s maximum of 1600%. 

Continuous vs. Non-Continuous Page Display 
PDFpen can display pages in a continuous stream, or restrict the 
viewing area to display just the current page (or set of facing pages) 
by itself. What’s the difference? Mostly a matter of personal choice 
and how you want to focus your attention. 

If you are reading a book in PDF form, you may not want to see a 
continuous page display so you can focus on just the current page. If 
you are browsing through the same book, though, the continuous view 
makes it easier to see where you are among the pages that make up 
the document. Figure 18 shows a continuous page display. 

Figure 18: Continuous page display gives you an overview of where 
you are in the document. 
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You can enable or disable continuous page display by choosing View > 
Continuous; you can also choose Continuous from the Sidebar 
pop-up menu at the left of the toolbar. 

Note: When you have a split view (see Split the View), the View
 

commands for Continuous, Single Page, and Facing Pages apply to
 

the currently selected split view.
 

Navigate Pages
 

PDFpen gives you several different ways to move through a PDF 
document. How they work sometimes depends on whether you have 
enabled continuous page display (see the previous section). 

Here are the ways to move from page to page: 

• Page Up / Page Down buttons: Though not available by 
default, you can customize the toolbar (View > Customize Toolbar) 
to add these buttons; use them to scroll up and down either by the 
height of the document display area or by a complete page, depend-
ing on whether you are viewing the document with continuous page 
display enabled or not. 

•	 Page field: To go to a specific page, select the page number dis-
played in the toolbar’s Page field and enter a new page number. 
PDFpen doesn’t let you enter page numbers that don’t exist in a 
document. 

• Go menu: You have a number of navigation commands here: 

‣	 Next Page and Previous Page: These work the same as the
 
toolbar’s Page Up 
 and Page Down buttons, described just 
above. 

‣	 First Page and Last Page: These go, respectively, to the first 
page and last page in the document. 
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‣	 Go to Page (⌘-Option-G): Similar to the toolbar’s Page field, 
this command presents a dialog where you enter the page num-
ber to which you want to go. 

‣	 Back and Forward: You can choose Go > Back (⌘-[) to retrace 
your most recent navigation moves, and Go > Forward (⌘-]) to 
un-retrace them, much like the Back and Forward commands in 
a web browser. (The keyboard shortcuts work exactly the same 
way in Apple’s Preview app.) This feature is especially handy 
when you navigate using page links within a document (page 
links are described in Create Links). 

•	 Gestures or scrollbar: If continuous page display is turned on, 
you can use trackpad or mouse gestures to scroll quickly through 
a document; if you have scrollbars displayed on your Mac (set this 
in System Preferences > General), you can also use the scrollbar 
on the right to move through the document. 

Note: If continuous page display is turned off and the page is too 
large to fit in the document viewing area, gestures or the scrollbar 
only adjust the position of the current page in the document viewing 
area. 

•	 Keyboard: Press the Page Up or Page Down key to move up or 
down by screen or page, depending on the continuous page display 
setting and whether the complete page fits within the document 
display area. On keyboards that lack these keys, such as laptop 
keyboards and the Apple wireless keyboard, Page Up is Fn-Up 
arrow and Page Down is Fn-Down arrow. You can also use Shift-
Space and Space as alternates on any keyboard (as long as you are 
not editing text, of course). Use the Home or End key to go to the 
first or last page. 

Tip: Although PDFpen shows the current page number in the win-
dow’s title bar, you can choose View > Page Numbers to display a 
non-printing page number at the bottom right of each page. This can 
help when you have multiple pages visible in the window (as in 
Figure 18, a page or so back). 

49
 



   

          
             

 

          
        
           

        
 

            
             

            
           

              
  

            

          
        

             
            

        

Navigate with the Sidebar
 

One of PDFpen’s most valuable navigation tools is the sidebar, which 
you can display at the side of the document window, as shown in 
Figure 19. 

Figure 19: The sidebar, on the left side of the window, can show 
page thumbnails, annotations, attachments, search results, or the 
table of contents; in PDFpenPro it can also show form fields. At the 
bottom of the Thumbnails sidebar shown here is the thumbnail 
magnification slider. 

You can make the sidebar visible by choosing View > Show Sidebar 
(⌘-Shift-D), or you can use the Sidebar pop-up menu on the 
toolbar and choose a sidebar display option. The width of the sidebar is 
adjustable: position your pointer on the border between the sidebar 
and the document so that it becomes a resize pointer, and then drag 
left or right. 

Tip: Click the Sidebar icon in the toolbar to toggle the sidebar’s 
visibility. 

The sidebar display options available on the toolbar’s Sidebar 
pop-up menu include page thumbnails, annotations, attachments, and 
the document’s table of contents (if it has one); in PDFpenPro it can 
also show form fields (see Set the Tab Order). Note that these com-
mands also appear on the menu bar’s View menu. 

50
 



        
          

   

  
          

             
          

           
        

            
           

    

           
      

  
             

           
              

          
         

       

Tip: Option-click a page thumbnail, annotation, attachment, form 
field (in PDFpenPro) or table of contents entry to view that item in 
Split View (see Split the View). 

Navigate with Thumbnails 
Thumbnails provide miniature views of the pages in the PDF docu-
ment. You can control the size of thumbnails to see more detail in 
them with the thumbnail magnification slider at the bottom of the 
sidebar. PDFpen can display multiple thumbnails side by side if the 
sidebar is wide enough and the thumbnails are small enough. 

To use the thumbnails for navigation, click a thumbnail in the sidebar: 
the page that the thumbnail represents is displayed in the document 
viewing area of the window. 

Tip: When a thumbnail is selected in the sidebar, you can use the
 

keyboard’s arrow keys to move from page to page.
 

Navigate with Annotations 
You saw the tools you use to add notes, comments, text imprints, and 
other sorts of annotations to a document in The Markup Tools. Once 
you have annotated a PDF, PDFpen makes it easy for you to find your 
annotations in the Annotations sidebar. It can list every note, com-
ment, text imprint, link, sound note, attachment, scribble, and high-
light you’ve added to the document (Figure 20). 
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Figure 20: The Annotations sidebar with a note displayed. 

Click any entry in the Annotations sidebar to navigate to the page that 
contains the corresponding item. When you do, PDFpen also selects 
the item so you can immediately work on it. For example, if you click a 
note entry, PDFpen displays the page that contains the note icon, and 
also opens the associated note window. 

You can limit the kinds of annotations displayed in the sidebar by 
clicking the Show pop-up menu at the bottom of the Annotations 
sidebar and choosing a type of annotation to show or hide. 

Tip: Need to copy the contents of an annotation or delete one easily? 
Use the Annotations sidebar to Select, Copy, and Delete Annotations. 

Navigate with a Table of Contents 
Not all PDF documents contain a table of contents, but, for those that 
do (like all Take Control ebooks!), PDFpen’s sidebar can display them. 
You can see part of the Table of Contents sidebar in Figure 21. The 
table of contents shown in the figure has several main entries that 
contain sub-entries; these appear indented below their main entry. 
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Figure 21: A table of contents in the sidebar can display
 
sub-entries.
 

Note: The pale blue bar that appears on the left of the sidebar 
indicates the content items currently visible in the document window. 

Click any entry or sub-entry to navigate to the associated page. 

If, as in Figure 21, a table of contents entry has sub-entries, you can 
hide or reveal them in the list by clicking the disclosure icon beside 
the main entry. 

Tip: You can select one or more table of contents entries and use 
Edit > Copy as Text to copy those entries for subsequent pasting into 
a text editor, word processor, or email message. 

PDFpenPro Note: You can also use the sidebar to create and modify 
a document’s table of contents, as described later in Make a PDF 
Table of Contents (Pro Feature). 
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Bookmarking Pages 
Even when a PDF contains no Table of Contents, it still provides 
access to the Table of Contents sidebar. Why? So you can navigate 
to bookmarks. You can bookmark any page in a PDF with PDFpen’s 
Edit > Bookmark > Add Bookmark command. When you bookmark a 
page, it’s listed under Bookmarks in the Table of Contents sidebar 
(Figure 22). 

Figure 22: Bookmarks appear at the top of the Table of Contents 
sidebar. 

To navigate to a bookmarked page, click its entry in the Table of 
Contents sidebar’s Bookmarks list. 

When you create a bookmark, it’s named after the page number of 
marked page. If you have PDFpenPro, you can rename a bookmark to 
make its name more informative: click the bookmark entry to select 
it and then click a second time to make the name editable. 

Should you become a bookmarks fan, you can place an Add Book-
mark button on the toolbar by choosing View > Customize Toolbar. 

To remove a bookmark, click its sidebar entry to select it and then 
choose Edit > Bookmarks > Remove Entry. 

Navigate with Search Results
 

In PDFpen, you perform text searches with the Find window. Click 
the Find button on the toolbar or choose Edit > Find > Find (⌘-F) 
to display the Find window (Figure 23). 
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Figure 23: PDFpen has a separate Find window. 

As soon as you begin typing in the window’s search field, PDFpen 
begins searching and displays the first match beyond your current 
position in the document. Click the Show Results button to list each 
match with some surrounding context, arranged by page. Click any 
line in the list of results to display the page that contains the search 
term with the term selected (Figure 24). 

Figure 24: Click a search result to see the search term selected 
on the document page. 

Once PDFpen has produced some search results (whether you choose 
to display them or not), you can navigate through the document using 
the next and previous buttons in the Find window. You can 
also use commands on the Edit > Find submenu as follows: 

•	 Find Next (⌘-G): Choose this to jump forward to the next search 
result. 

•	 Find Previous (⌘-Shift-G): Jump back to the preceding search 
result. 

•	 Jump to Selection (⌘-J): This command displays the currently 
selected text within the PDF document, whether or not it is a search 
result, and it can be useful if you have been browsing through the 
document and want to get back to the page containing your most 
recent selection. 
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Tip: You can use these commands whether or not the Find window is 
currently displayed. For example, if you hide the Find window to give 
yourself more screen space in which to work, you don’t have to open 
it to navigate to other search results. 

Another Tip: Another Find command, Find and Highlight (⌘-Shift-
Option-F), comes in handy for annotating text; see Find and Highlight 
in Take Notes on a PDF. 

Yet another tip: Ordinarily, when you have Split the View and you 
click a search result, PDFpen navigates to it in the main pane (see 
Not All Split Views are Equal). Option-click a search result to see it in 
the other split view pane. 

Search Based on the Selection 
There is one more way to initiate a search: select some text in the 
PDF document, and then choose Edit > Find > Use Selection for Find 
(⌘-E). This command also places the selected text in the Find win-
dow’s search field and lists the results when the Find window is open. 

Navigate Portfolios
 

Portfolios are special types of PDF documents that contain more than 
one document—and they don’t all have to be PDFs, either. Portfolios 
come in handy when you have a group of PDFs and related files that 
all belong to one project and you want to keep them all together. You 
must have PDFpenPro to create portfolios (see Create Portfolios (Pro 
Feature), but you don’t need it to open and use them: PDFpen works 
fine for that. 

Note: Not all PDF readers can open PDF portfolios. For example,
 
Apple’s own Preview can’t.
 

56
 



             
            

             
      

      

              
           

        

          
      

             
            

      

          
            

You open a PDF portfolio like any other PDF: choose File > Open (⌘-
O) in PDFpen, or double-click the portfolio in the Finder, or drop the 
portfolio icon on PDFpen in the Dock. No matter how you open it, 
PDFpen displays the portfolio window (Figure 25). 

Figure 25: A PDF portfolio opens in a Finder-like window. 

To preview one of the documents in a portfolio, click to select it and 
then click the portfolio window’s preview button. This opens a 
preview window similar to those displayed by the Finder. 

Tip: You can select a document and then press the Space bar to view 
its preview just as you can in a Finder window. 

Also just as in a Finder window, you can use the multi-segment file 
view button to display the portfolio’s contents as icons, in a 
list, or in a column hierarchy. 

Portfolios can contain folders: double-click a folder to display its 
contents in the portfolio window. You can use the forward and back 
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buttons to retrace your steps like you can in a Finder win-
dow, or use the hierarchy pop-up menu at the top of the window to 
move up the portfolio’s folder hierarchy. 

Of course, portfolios would be almost useless if you couldn’t do any-
thing with their contents. You can do three things with the items in a 
portfolio: 

•	 Extract: Select a document and click Extract As, and then use the 
file saving dialog that appears to save a copy of the extracted docu-
ment on your Mac, optionally renaming the copy. 

•	 Open as a new document: For PDF documents in the portfolio, 
you can select the document and click Open as a New Document to 
edit an untitled copy of the document in PDFpen, which you can 
then save as you would any other PDF. 

•	 Delete: Select one or more items in the portfolio and click the 
delete button at the window’s bottom. 

Tip: You can double-click a PDF in a portfolio to immediately edit it as 
a new document in PDFpen. 

Finally, even though you need PDFpenPro to make a portfolio, you can 
add items to an existing portfolio with PDFpen. See Create Portfolios 
(Pro Feature) to see how to add items to an existing portfolio. 
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Create a PDF 
Chances are good that you have a bunch of PDFs scattered around 
your Mac’s drive right now—and you can use PDFpen with any 
of them. 

But real chefs cook up their own PDFs: 

•	 If you’re a complete do-it-yourselfer, you can make a PDF entirely 
from scratch (see below). 

•	 If you prefer to work with prepared ingredients, you can make a 
PDF from anything your Mac can print. See Print to PDF. 

•	 If you like imported delicacies, you can Import from Scans and 
Graphic Files to make a new PDF, and even perform optical charac-
ter recognition (OCR) on them. 

•	 If you like to work with leftovers, you can make a new PDF from 
the bits and pieces of other PDFs you have hanging around. Read 
Combine Existing PDFs. 

•	 If you need to serve up multi-course banquets, you can gather 
multiple PDFs and the documents you used to create them and 
Create Portfolios (Pro Feature). 

•	 Or, if you like to order take-out, you can go online and convert web-
pages into PDFs. See Make PDFs from HTML (Pro Feature). 

And, when you’re done cooking, you can write up the menu…er… Make 
a PDF Table of Contents (Pro Feature). 

Make PDFs from Scratch
 

It’s easy enough to make a completely empty PDF with no pages. This 
isn’t as daft as it sounds. You want to do this when you need to specify 
the page dimensions and orientation of a new PDF and build it out 
yourself. 
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Create a Blank PDF 
Here are the steps for making a pageless PDF and then adding a blank 
page with the dimensions you desire: 

1.	 Choose File > New > Blank Document. 

PDFpen creates a completely empty PDF. 

2. Choose File > Page Setup (⌘-Shift-P) and then, in the Page Setup 
dialog, specify the page dimensions and orientation that you want 
your PDF to have. 

3.	 Choose Edit > Insert Blank Page (⌘-Option-B). 

4.	 In the dialog that appears (Figure 26), click to select a page back-
ground design and orientation, and then click Choose. 

Figure 26: You have lots of colorful stationery choices from which to 
choose. 

The new blank page matches your Page Setup settings. 
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Tip: If PDFpen’s default Page Setup settings are fine for you, you can 
quickly create a new document using stationery: choose File > New > 
From Stationery (⌘-N), click in the dialog to select the page back-
ground and orientation, and then click Choose. 

With blank page in hand (virtually), you can now populate your PDF 
with text imprints, drawings, and images. The Markup Tools and The 
Draw Tools explain how to add text imprints and drawings, but you 
can also drag text, drawings, and images from most other programs 
directly onto a PDFpen page. 

Alternative Ways to Create Pages 
Here are two ways to create blank pages in an existing document: 

✦	 You can select a thumbnail in the Sidebar (see Navigate with the 
Sidebar) and then choose Edit > Insert Blank Page (⌘-Option-B) 
to create a blank page with the same dimensions and orientation 
as the selected thumbnail’s page. 

✦ Use the Edit > Insert Blank Page Again (⌘-Option-Shift-B) com-
mand to insert either the previously selected stationery or a blank 
white page. 

Note: PDFpen may convert text dragged from some programs, such 
as from ancient versions of Microsoft Word, into a graphic image 
when you drop it on a PDFpen page. 

Create a PDF from Another PDF 
There’s yet another way to create a PDF from scratch—well, almost 
from scratch: use a page from an existing PDF as your model: 

1.	 Open a PDF that has a page you want to use as the model for your 
new PDF. 

2.	 Select that page in the Thumbnails sidebar (if you need help, read 
Navigate with Thumbnails), and then choose File > New > From 
Selection (⌘-Shift-N). 
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PDFpen creates a new, untitled PDF with the selected page as its only 
page. Now customize it to your heart’s content. 

Note: You can, instead, choose File > New Blank Document to create 
a document with no pages and then drag pages from other PDFs into 
the blank document as you like. 

Tip: You can also drag one or more selected page thumbnails to the 
Finder from an existing PDF to create a new PDF containing those 
pages. 

One More Thing... 
There’s a variation on the method of creating a PDF from an existing 
page: you can make a PDF from part of a page: 

1. With the Select Rectangle tool, drag to create a rectangle 
around the area that you want to use as your model. 

2. Choose File > New > From Selection (⌘-Shift-N). 

Voilà! A new PDF appears with a single appropriately sized page 
containing the contents of the rectangle you selected. 

Print to PDF
 

It’s no secret that you can save a document as a PDF in the standard 
Print dialog. It’s an easy way to create a PDF on which you can then 
work in PDFpen. Use this technique to turn a document created in 
another program, such as a report or manuscript, into a PDF. 

Here’s how to create a PDF from almost any application on your Mac: 

1.	 Choose File > Print. 

2.	 In the lower-left corner of the Print dialog, click PDF, and then 
choose Save as PDF from the pop-up menu (Figure 27). 
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Figure 27: You can create a PDF document with the Print dialog’s 
PDF pop-up menu. 

3.	 In the Save dialog, give the document a name, choose where to save 
it, optionally specify PDF metadata and security options, and then 
click Save. 

Note: The PDF metadata includes the document name, the author, 
the document’s subject, and keywords associated with the document 
(read about the Document Information tab in The Inspector to learn 
about these metadata items). 

Once you have the PDF, it’s easy enough to open it with PDFpen and 
make any changes and enhancements you require. But what if you 
want to save a document as a PDF and work on it immediately in PDF-
pen? Simple: Smile provides two PDF workflows—Open with PDFpen 
and Open with PDFpenPro—that you can download and install in the 
Print dialog’s PDF menu. Once that’s done, you can choose the appro-
priate workflow from the PDF menu to save the document as a PDF 
and open it in PDFpen or PDFpenPro. 

Import from Scans and Graphic Files 

PDFpen can scan documents and create PDFs from the scans. It can 
also create PDFs from graphic files. If you have printed copy or graphic 
files that you need to make into PDFs, use the techniques in this 
section. 

You don’t have to forgo PDFpen’s text editing capabilities just because 
the PDFs you make with these techniques start out as graphic images: 
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PDFpen can recognize text in the images and perform optical character 
recognition (OCR) to make the text editable. 

Use a Scanner to Make a PDF 
PDFpen supports any scanner that your Mac’s Image Capture software 
recognizes. (To learn about working with documents you’ve already 
scanned, see Use OCR on Scans and Graphic Files.) 

When you scan a document with PDFpen, the program creates a new 
PDF document. You can save the resulting document as a separate 
PDF, or add its pages to an existing PDF—or do both. 

You use PDFpen’s scanning capabilities as follows: 

1. Choose File > Import from Scanner. 

A Scan window appears (Figure 28). 

Figure 28: The Scan window has several scanner-specific options. 
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2.	 Near the top-right of the Scan window, click the Kind pop-up menu 
and choose the kind of scan: 

‣	 Text: This choice scans the document in 1-bit black and white, 
which is suitable for text-only documents. 

‣	 Black & White: Sometimes known as grayscale, this choice, 
depending on the scanner, may offer several grayscale options 
with various levels of gray. This choice is suitable for documents 
that combine text with black-and-white photos or diagrams. 

‣	 Color: This is best for documents that contain color images. 
There can be several color choices available, depending on your 
scanner’s capabilities. 

3.	 Choose a resolution from the Resolution pop-up menu. 

The higher the resolution, the more detail the scan contains, but 
the larger the file is. The resolution you choose depends on how the 
PDF is to be used; for viewing online, 150 to 300 dpi is more than 
adequate, but if the PDF is to be printed the scan resolution should 
match the printer’s resolution. 

4.	 Choose a scan format from the Format pop-up menu. 

This format determines the image encoding in the PDF, and it 
affects the file size: for text-only documents, TIFF is a good choice; 
for photos, JPEG provides good results; otherwise, choose PDF. 

5.	 Set any other scan options you require, and then click Scan. 

A new PDFpen document opens containing the scanned page. The 
Scan window remains open so you can perform additional scans to 
add to the document. 

6.	 When you have finished scanning, close the Scan window. 

Tip: If your scan isn’t quite on the level, you can use the Edit >
 

Deskew Page command to straighten things out.
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More Help with the Scan Options 
The PDFpen online help has an excellent summary of the scanning 

options and their uses in its Creating PDFs from Scans topic.
 

Open Graphic Files as PDFs 
You can also create new PDFs directly from graphic files, such as 
JPEG, TIFF, PNG, or GIF files. Turning a graphic file into a PDF file is 
simple: 

1. Choose File > Open to display the Open dialog. 

2. Select a graphic file and click Open. 

PDFpen creates a new PDF document with a single page that contains 
the graphic. 

Use Continuity Camera 
Would you like to scan a document into a PDF but don’t have a scan-
ner? Or do you want to insert a photo into a PDF of something you 
have right there in front of you? If you have a recent iOS/iPadOS 
device running iOS 12 or later (or iPadOS 13 or later) nearby, and your 
Mac is running Mojave or later, you can do either, courtesy of the 
Continuity Camera feature that iOS, iPadOS, and macOS provide. This 
feature turns your iPhone or your iPad into a camera that other apps 
can use. 

Apple describes what this feature requires in its support article, Use 
Continuity Camera on your Mac. The article also describes the process 
of taking pictures and making scans with your iOS/iPadOS device. 

Note: Because Continuity Camera is a feature of both macOS and 
iOS/iPadOS, which are regularly updated, its behavior and capabilities 
are particularly vulnerable to change. Consult the Apple support 
article for the latest Continuity Camera features. 

You can find the Continuity Camera-related Import from Device(s) 
menu command on PDFpen’s File menu (Figure 29); the exact name 
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of the menu item, and whether it even appears, depends on the pres-
ence of suitable iOS/iPadOS devices near your Mac. 

Figure 29: Nearby iOS devices show up as Import sources courtesy 
of Continuity Camera. 

PDFpen provides as many as three commands for each device that 
your Mac detects, depending on the device’s capabilities: 

•	 Take Photo: Choose this to take a single photo. PDFpen inserts 
the photo into the current document on the current page, or, if there 
is no current document, PDFpen creates a new PDF with a page that 
contains the photo. 

•	 Scan Documents: Choose this to take multiple photos of one or 
more documents and combine them as a scan. The iOS/iPadOS 
device provides the ability to select the portion of each image that 
will constitute a page of the scan. PDFpen inserts the scanned pages 
into the frontmost PDF document by adding pages after the cur-
rently selected page; if no PDF is open, PDFpen creates a new 
scanned document to contain the pages. 
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•	 Add Sketch: Choose this to use the drawing capabilities of your 
device to make a drawing that PDFpen will then import as a new 
page. 

Use OCR on Scans and Graphic Files 
When PDFpen creates a scanned document, or when it opens a graphic 
file as a PDF, it can perform OCR on it to make the text editable. It’s 
useful to make text editable even if you don’t intend to edit it. Editable 
text can be searched (see Navigate with Search Results), and it can be 
highlighted (see Highlight Text). 

Both PDFpen and PDFpenPro can perform OCR on individual docu-
ments. In addition, PDFpenPro provides the capability of performing 
OCR on multiple documents at a time (see Use OCR on Multiple 
Documents (Pro Feature)). 

Note: The English OCR dictionaries automatically include both legal
 
and medical terms.
 

Use OCR on a Single Page or Document 
To instruct PDFpen to perform OCR on any page in a scanned docu-
ment, choose Edit > OCR Page. 

You can set PDFpen to perform OCR automatically upon opening a 
scanned document, or when you make a selection on a scanned page 
that appears to contain text. Go to PDFpen > Preferences > OCR to 
turn on these settings (Figure 30). 
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Figure 30: Set how and when PDFpen performs OCR with
 
PDFpen’s OCR preferences.
 

Tip: If your scans tend to be skewed (which can often happen with 
scanners) check Deskew Pages Automatically When Performing OCR 
to have PDFpen automatically straighten the scan. 

Another Tip: If file size is an issue, use the MRC compression level 
pop-up menu; you can choose a compromise between file size and 
image quality of the scanned document. 

If Your OCR Page Menu Item Is Disabled 
If PDFpen doesn’t detect a full-page graphic on the page, it disables 
the Edit > OCR Page menu item. That said, if a page has an image 
that contains text, you can hold down Command when you choose 
the Edit menu to enable the OCR Page menu item. 

Bonus tip: Hold down both Command and Option to display an OCR 
Document command on the Edit menu. 
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When you create a PDF from a graphic file and you’ve set PDFpen’s 
preferences to prompt for OCR when opening a scanned document, 
the program presents a dialog asking if you want OCR performed 
(Figure 31). 

Figure 31: When PDFpen detects a full-page image, it may 
display this dialog, depending upon the OCR preference settings. 

Tip: You can attach a PDFpen folder action script to a folder to have 
PDFpen automatically OCR any PDF you drop into it; Joe Kissell’s 
Take Control of Your Paperless Office has this and other useful PDF-
related workflow tips. 

Use OCR on Multiple Documents (Pro Feature) 
If you happen to have multiple PDFs on hand that don’t contain 
selectable text, you can perform OCR on them in a batch with 
PDFpenPro. 
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Here’s what you do: 

1.	 Choose File > OCR Files. An OCR Files window appears (Figure 
32). 

Figure 32: Add files upon which you want to perform OCR to this 
window. 

2.	 Do either of the following: 

‣	 Drag PDFs from the Finder into this window. 

‣	 Click Add PDFs and choose the PDFs you on which you want to 
perform OCR from a standard file dialog. 

3.	 Click Perform OCR. 

As OCR processing completes for each PDF, a green circle appears 
beside its name in the list; when all PDFs in the list are processed you 
hear a soft tone. After recognition is complete, you can add additional 
PDFs to the window and perform OCR on them. PDFpenPro skips over 
PDFs that have been previously processed. 
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To remove a PDF from the list, click it in the list to select it, and then 
click Remove. You can remove both unprocessed PDFs and PDFs that 
have been previously processed. 

About OCR Accuracy and the OCR Layer 
In my experience, PDFpen provides very good character recognition, 
even from documents that appear problematic. Nonetheless, you 
should check the results. Even 99.9% accuracy means there could 
be one mistake every 1,000 characters, which, if you think about it, 
means that mistakes are likely. When OCR has been completed, the 
PDF’s appearance doesn’t change. You can view the OCR results by 
choosing View > OCR Layer (⌘-Shift-O), as in Figure 33. 

Figure 33: The first image above shows the scanned text as 
it appears in the PDF; below it is the OCR layer. 

You can correct OCRed text with the Correct Text tool; such correc-
tions alter the scan’s appearance by creating a text imprint (see Add, 
Edit, and Remove Text, later). PDFpenPro, however, can make 
corrections in the OCR layer without creating an imprint and changing 
the scan’s appearance (see Edit the OCR Layer in PDFpenPro). 

Combine Existing PDFs
 

Combining pages from multiple PDFs is a matter of drag and drop 
between documents. If you have separate PDF files that contain pages 
you want to use in another PDF, this technique is what you want. 

Here’s how to create a new PDF from one or more existing PDFs: 

1. Create a new, empty PDF document (see Make PDFs from Scratch). 
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2.	 Choose File > Open or File > Open Recent to open one or more 
existing PDF documents. 

3.	 Show the Thumbnails sidebar in all open document windows (de-
scribed in Navigate with the Sidebar). 

4.	 Drag one or more thumbnails from the sidebar of an open docu-
ment to the empty document area of the blank document. 

You don’t have to start with a blank PDF file as shown in the steps 
above, of course: you can drag pages from any PDF into the Thumb-
nails sidebar of any other PDF with PDFpen (Figure 34). 

Figure 34: Add pages by dropping their thumbnails in a document’s 
Thumbnails sidebar. The dragged thumbnails have a red badge 
that indicates how many pages are being added; a black bar in the 
sidebar shows the page after which the added pages will be placed. 

You needn’t drag pages one by one: you can Shift-click or ⌘-click to 
select multiple page thumbnails from the sidebar and then drag them 
all at once. Or you can add a PDF’s entire contents to a document by 
dragging that PDF into the Thumbnails sidebar from the Finder. You 

73
 



              
      

   

        
          
           

            
 

     

          
          

            
          

              
             

   

      
     

            
             
            

        

also can use of one or more of the supplied AppleScripts to combine 
PDFs (see Appendix A: The PDFpen AppleScripts). 

Create Portfolios (Pro Feature)
 

With PDFpenPro you can create PDF portfolio documents. As de-
scribed in Navigate Portfolios, portfolios are often used to collect 
related PDFs, as well as their source or supporting documents, into 
a single file that can be shared with colleagues or collaborators on 
a project. 

Here’s what you can do with portfolios: 

•	 Create a new portfolio: Choose File > New > Portfolio Docu-
ment. An empty untitled portfolio window opens, ready to be popu-
lated. 

•	 Add files: Click the add pop-up menu at the bottom of the 
portfolio window and choose Add Files (Figure 35). Then choose 
the files you want to add from the file dialog that appears (you can 
Shift-click or ⌘-click in the dialog’s file list to choose more than one 
file to be added). 

Figure 35: Add files and folders to a portfolio with the Add button 
at the bottom of the portfolio window. 

•	 Create folders: To group files into a folder in the portfolio, create 
the folder before you add the files; choose New Folder from the add 

pop-up menu. You can click the folder’s name to select and 
rename it, and you can create folders within folders. 
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•	 Remove files and folders: Select them (Shift-click or ⌘-click to 
select multiple items) and then click the delete  button. 

Tip: Choose Edit > Undo (⌘-Z) to undo an unintended deletion. 

When you finish working with the new portfolio, simply close the 
window: PDFpenPro prompts you to name the portfolio and choose 
where to save it. 

To save the portfolio but continue to work with it, click Save at the 
bottom of the window: the portfolio is saved with the name you give 
it and in the location you specify, but the window remains open. 

Make PDFs from HTML (Pro Feature) 

If there is a website that you want to save in PDF form, you can always 
use the Print to PDF technique described earlier. However, that re-
quires you to print each page on the site separately, which will quickly 
become tedious. PDFpenPro, on the other hand, can follow the links 
on a webpage and add the linked pages to a PDF: 

1.	 Choose File > New > From HTML. 

The New From HTML dialog appears (Figure 36). 

Figure 36: You can create a PDF from one or more webpages. 
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2.	 Do one of the following, depending on whether the website is 
located on the Internet or stored locally: 

‣	 On the Internet: Enter the URL of the webpage that is the 
starting point for the PDF. 

‣	 Stored locally: Click Select Index File and then, from the 
standard file dialog that appears, navigate to the starting page. 

3.	 In the Levels field, enter how many levels of links to include. 

A setting of 1 produces a PDF from the page that you’ve specified 
but doesn’t follow any links to produce more pages. A setting of 2 
follows each link on the first webpage and produces PDF pages from 
those linked webpages. A setting of 3, as you might expect, follows 
links on the linked webpages to produce more PDF pages, and so 
on. In theory, you could include almost every page linked on the 
Internet in a single PDF by choosing a high enough level number—if 
your Mac didn’t run out of memory or melt first. 

4.	 Choose an item from the Follow Links To pop-up menu: 

‣	 Subtree: This choice restricts the followed links to those 
that lead to pages within the same directory hierarchy as the 
webpage’s URL. 

For example, if the starting URL is https://www.example.com/ 
dir1/index.html, then the linked pages https://www.example.com/ 
dir1/somepage.html and https://www.example.com/dir1/dir2/ 
apage.html would be included in the PDF, but a linked page 
found at https://www.example.com/dir3/apage.html would not, 
because it’s not in the same directory as the starting URL. 

‣	 Server: This choice restricts the followed links to those that lead 
to pages on the same server as the webpage’s URL. For example, 
if https://www.example.com/dir1/index.html is the URL for the 
first page in the PDF, the linked page https://www.example.com/ 
dir2/apage.html would be included in the PDF, but a linked page 
at https://www.smilesoftware.com/ would not. 
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‣	 Any: This choice allows PDFpenPro to follow links to any
 
directory or site and include those pages in the PDF.
 

5.	 Optionally, specify the maximum number of pages to include in the 
PDF. This is useful for preventing your Mac from being tied up for 
hours when you accidentally ask PDFpenPro to turn the entire 
Google index into a PDF. 

6.	 Optionally, set the margins for the pages that will be created. 

7.	 Optionally, click Open Page Setup, and set the dimensions and 
orientation of the pages to be created. 

8. Click Create, and stand back as PDFpenPro does its magic. 

Before you know it (depending on the speed of your Internet connec-
tion and the complexity of the pages involved), you’ll have a PDF 
version of a website. 

Make a PDF Table of Contents 
(Pro Feature) 

Not every PDF needs a table of contents, but if you have a PDF that is 
more than a few pages long, providing a table of contents is a courtesy 
to your readers. In PDFpen and PDFpenPro, as with Apple’s Preview, 
you view a PDF’s table of contents in the document window’s sidebar 
(see Navigate with the Sidebar). 

In PDFpenPro, you can also edit a PDF’s table of contents. With the 
table of contents displayed (choose View > Table of Contents or select 
it from the Sidebar pop-up menu), use the action menu at the 
bottom of the sidebar (Figure 37) to fine-tune the entries. 
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Figure 37: Use PDFpenPro’s Table of Contents action menu
 
to edit a document’s table of contents.
 

Tip: The same menu items also appear both on the Edit > Table of 
Contents submenu in PDFpenPro and in a contextual menu when you 
Control-click the Table of Contents sidebar. 

To add a table of contents entry, do the following: 

1. Choose View > Table of Contents. 

This command has the virtue of both displaying the sidebar if it is 
hidden and showing the table of contents in one step. 

2.	 Go to a page that has a heading or content that you want to include 
in the table of contents, and then, with the Edit tool, click any-
where on that page. 

3. From the Table of Contents action menu, choose Add Entry. 

PDFpenPro puts the new entry in the table of contents, and names 
the entry Page # where # is the number of the currently displayed page. 
The entry name is selected so you can easily change it. 

You can also add entries hierarchically: Add Aunt adds an entry one 
level above the current level (unless you are at the top level already); 
Add Child adds an entry nested within the current one. 
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Tip: If you select text on the page with the Select Text tool before 
you choose Add Entry, the selected text becomes the entry name. 

Here’s how to rename a table of contents entry: 

1.	 In the sidebar, double-click the entry. 

2.	 Type the new name and then press Return. 

As you work on a PDF, you may find yourself rearranging the order 
of the pages (see Rearrange Pages). In such cases, you may find it 
necessary to reorganize the Table of Contents. You can change the 
order in which entries appear, remove entries, and nest entries hierar-
chically. This last capability is useful for structured documents that 
have headings and subheadings (much like this book, in fact); see 
Navigate with a Table of Contents for an example of nested entries. 

Here are the ways to organize a table of contents: 

•	 Change where an entry appears: Drag the entry up or down 
the table of contents to the desired position. 

As you drag, a translucent image of the entry follows your pointer, 
and a line appears to show you where the entry will be placed when 
you release the mouse (Figure 38). 

Figure 38: Drag to reposition a table of contents entry. 
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•	 Delete an entry: Click the entry to select it and then press Delete. 
You can also click it and then choose Remove Entry from the Table 
of Contents action menu. 

•	 Nest or un-nest an entry: While dragging an entry you can 
control whether it is nested under another entry—pay attention to 
the location of the blue line and drag directly onto another item to 
nest the entry under it. Or you can do one of the following: 

‣	 To nest an entry beneath the entry above it, click the entry and 
then choose Demote from the Table of Contents action menu. 

‣	 To un-nest an entry, click the entry and then choose Promote 
from the Table of Contents action menu. 

Tip: With PDFpenPro you can select multiple Table of Contents 
entries to reorganize multiple entries at a time. Use Shift-click to 
select a range of entries, and ⌘-click to select discontiguous entries. 
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Take Notes on a PDF 
People (especially students) love to write in books, scribble in the 
margins, put sticky notes on pages to flag them, use highlighter pens 
to call attention to important passages, draw circles and arrows to 
connect margin notes to text, and generally make a glorious mess as 
they attempt to comprehend the contents of their books. 

As you already saw in The Markup Tools, PDFpen has an assortment of 
tools you can use to perform similar actions on the contents of a PDF. 

In this chapter, you’ll see how to take notes for a research paper by 
using these tools to mark up PDFs, as well as how to Record Sound 
Annotations. 

This chapter also explains how to Print Notes and Comments and how 
to use the sidebar to Select, Copy, and Delete Annotations. 

You can even include related materials that comprise entire docu-
ments, as View, Extract, and Add Attachments explains. 

Note: If your goal is to edit or review a PDF, don’t stop with the tools 
discussed in this chapter. The next chapter, Copyedit and Review a 
PDF, is also for you. 

Highlight Text
 

It is a rare student who doesn’t use a highlighter pen to mark up text. 
Highlights draw attention without obscuring the text. In fact, many 
students color-code their highlights: a student might use yellow for 
important facts, blue for quotable passages, and so on. 

PDFpen has four standard colors for highlighting, as well as three 
customizable colors. You can also highlight text with three kinds 
of lines. 

81
 



 
           

          
          

     

     

     

            
   

     
    

   

     

           
           
 

             
             
           

         
       

Highlight in Color 
As you learned in The Markup Tools, you use the Highlight  tool to 
select text and simultaneously apply the current highlight color. The 
current highlight color is both displayed in, and selectable from, the 
Highlight pop-up menu on the toolbar. 

Here’s one way to highlight text: 

1. Choose Tools > Highlight Text Tool. 

2. On the toolbar, from the Highlight tool pop-up menu, choose a 
highlight color (Figure 39). 

Figure 39: Select a highlight color from the Highlight tool’s pop-
up menu. Note the keyboard shortcut that appears as a help tag 
when you point at a color. 

3. Select some text in the PDF. 

The selected text takes on the chosen highlight color. Every additional 
selection you make with the Highlight tool active applies the chosen 
highlight color. 

However, you don’t need to use the Highlight tool to highlight text. 
Instead, you can use a keyboard shortcut. This is how I prefer to 
highlight text, because I don’t have to switch to the Highlight  tool. 
To apply a highlight color to selected text, type ⌘-Option-Shift-a 
number from 1 to 5, which correspond to the four standard highlight 
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colors and the first custom color. You can see the highlight color 
keyboard shortcuts when you point at a color on the Highlight 
tool’s pop-up menu, as shown just above in Figure 39. 

Remove a Highlight 
Obviously, being able to remove highlights is important. Aside from 
aesthetic considerations, when a page has too many highlights it’s hard 
to know which highlights are really important. Besides, even the best 
of us make mistakes and highlight a passage in error. 

Here’s how to remove a highlight: 

1. With the Select Text tool, select any portion of the highlighted text 
you want to remove. You don’t have to select the entire highlighted 
passage; any portion will do. 

2. From the Highlight tool’s pop-up menu on the toolbar, choose 
Remove. 

The entire highlight is removed. 

Tip: I prefer to remove highlights with a keyboard shortcut: I select 

a bit of the highlighted text with the Select Text 
 tool and then
 

type ⌘-Option-Shift-0 (zero). (The Remove command with that 

shortcut appears on the Format > Highlight submenu and on the
 

Highlight 
 tool’s pop-up menu.) 

Set a Custom Highlight Color 
If the four standard highlight colors don’t appeal to you, you can 
specify as many as three custom highlight colors. These colors are set 
in PDFpen > Preferences > Editing and, once set, are available in all 
documents you subsequently open. As with any other highlight color, 
when you set a custom highlight color it remains the default highlight 
color until you select a different highlight color. 

Note: If you change a custom highlight color, any text highlights that 
use the former custom color retain that color. 
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Here’s how to set a custom highlight color: 

1. Do either of the following: 

‣ Choose PDFpen > Preferences > Editing. 

‣ Choose Edit Custom Colors from the Highlight tool’s pop-up 
menu on the toolbar. 

2.	 Near the bottom of the Editing pane, click one of the Custom High-
light Color swatches. 

3. In the Colors panel that appears, select a color. 

PDFpen applies a 40% opacity to the chosen color, regardless of the 
Opacity slider setting in the Colors panel. 

Tip: Changes to a Custom Highlight Color take immediate effect,
 
so you can try various settings without closing the Preferences 

window.
 

Find and Highlight 
PDFpen provides the Edit > Find > Find and Highlight command (⌘-
Option-Shift-F) for those cases where what you want to highlight can 
be boiled down to an exact word or phrase (Figure 40). 

Figure 40: The Find and Highlight command gives you both search 
and highlighting capabilities in the Highlight window. 

With this command, you can highlight individual occurrences of found 
text, highlight all occurrences of that text, or just find the text without 
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highlighting. You can choose the highlight color from the four standard 
and three custom colors in the Highlight search window. 

Note: The highlight color you choose in the Highlight window does 

not affect the highlight color currently assigned in the PDFpen win-
dow’s toolbar.
 

Underline Passages 
If the seven different highlight colors aren’t enough to suit your needs, 
you can also mark text with various kinds of lines, although these are 
usually used for copy-edit purposes (read Copyedit and Review a PDF). 

Like highlight colors, the line highlights are available on the toolbar’s 
Highlight tool’s pop-up menu. The three types of highlight lines 
are shown in Figure 41. 

Figure 41: You can use three kinds of lines to highlight text. 

Here are the three kinds of line highlights available to you: 

•	 Underline: This is a simple text underline. If the PDF already 
contains underlined text (using underlines to indicate italics is a 
standard manuscript convention), you probably want to avoid using 
it. Otherwise, an underline serves as a subtle highlight that’s not as 
obvious as a colored highlight. You can underline selected text by 
typing ⌘-Option-Shift-6. 

•	 Strikethrough: This draws a line through, rather than under, the 
text. Strikethroughs are often used to mark passages for deletion, 
and are, therefore, not a very good choice for highlighting text. You 
can type ⌘-Option-Shift-7 to strike through selected text. 

•	 Squiggle: This draws a wavy line under the selected text, and is 
useful for highlighting purposes, although the squiggle underline 
is often used to indicate passages that should be set in bold type. ⌘-

85
 



         
   

             
            

            
           

     

 

          
             
            

     

           
            

           
            

     

          
         

     

  
             

             
            

             
 

             
             
 

Option-Shift-8 is the keyboard shortcut for applying a squiggle 
underline to selected text. 

You can set the line highlight color by selecting the line highlight style 
you want from the toolbar’s Highlight tool’s pop-up menu and then 
choosing a stroke color from the Editing Bar, as described in The 
Object Property Tools. The color you choose remains the default line 
highlight color until you change it. 

Add Commentary
 

When you think about it, highlights provide a secret coded commen-
tary to a PDF: you may know what the different highlight colors you’ve 
used mean, but everyone else has to guess. You can, however, add 
textual commentary that anyone can understand. 

PDFpen has three different tools for adding textual commentary to a 
PDF: the Note tool the Comment tool, and the Comment tool’s variant, 
the Cloud tool). You can also attach sound annotations. You can access 
any of these from the Annotation tools pop-up menu on the 
toolbar or from the Tools menu. 

Tip: Remember that you can quickly review all the comments, notes, 
and text imprints you’ve added to the PDF, and go to each one, by 
using the Annotations sidebar (see Navigate with Annotations). 

Add Pop-Up Notes 
Notes are useful for when you have a large amount of commentary to 
add: the note window can be closed to remove clutter, and opened by 
double-clicking the note icon with the Edit tool. When you reopen a 
note window, it retains the shape and position it had when you last 
closed it. 

A note comes in two parts: a small, balloon-shaped icon that you can 
position on the page, and a note window with the contents of the note 
(Figure 42). 
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Figure 42: A note consists of an icon and its associated window. 

Notes are also useful when more than one person is commenting 
on the PDF. As you can see in Figure 42, above, the note window 
contains the name of the person who added it, and the date that 
the note was added. You can choose whether or not to show a name, 
and specify the name to use, in PDFpen > Preferences > Editing. 

Tip: You can change the color of the note icon and its border by 
selecting the note and changing the fill and stroke colors with The 
Object Property Tools. 

To add a note to a page, do the following: 

1. On the toolbar, choose the Note tool from the Annotation
 
tools pop-up menu.
 

2.	 Click on the page where you want the icon to go. 

You can drag the icon wherever you like with the Edit  tool. 

3.	 In the note window, type your note (or paste it from the clipboard), 
and adjust the window’s size and location as desired. 

4.	 Optionally, close the note window; if you need to reopen it, double-
click the note icon. 

To delete a note, click the trash icon on the right side of the note’s 
title bar (the trash icon appears when you hover your pointer over it), 
or click the Note icon in the document body to select it and then 
press Delete. 
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Tip: Consider placing the note icons near the left or right margins 
of text objects instead of over the text itself. This makes them more 
visible, and avoids obstructing the text. Also, try to position the note 
windows so they don’t obstruct the information to which they refer. 

Add Comment Boxes and Clouds 
When you need to add short commentary that always remains visible 
on the page, add a comment box (Figure 43). 

Figure 43: A comment box always appears on the page. 

Comment boxes use the default font (set in PDFpen > Preferences > 
Editing), and use the text color, stroke color, fill color, stroke style, and 
stroke width set in the Editing Bar’s object property tools (see The 
Object Property Tools). 

To add a comment to a PDF page, do the following: 

1. On the toolbar, choose the Comment annotation tool from the 
Annotation tools pop-up menu. 

2.	 Click in the document body to add a comment box at the default 
size, or click and drag to create a comment box with a custom size 
and shape. 

3.	 Select the text within the box (the default text is “Text”), and type 
your comment. 

4. Optionally, choose the Edit tool, and reposition or resize the com-
ment. 

PDFpen provides an alternative shape for the comment frame: a cloud. 

The steps for making a cloud comment are almost exactly the same 
as those for a comment box. The only difference is that you choose the 
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Cloud annotation tool instead of the Comment annotation tool 
in the steps listed above. 

Cloud comments can have custom stroke widths, border colors, and 
fills just like comment boxes (Figure 44). 

Figure 44: If you need a more distinctive comment box,
 
put your comment in a cloud.
 

Tip: Having the Cloud annotation tool as an alternative to the 
Comment annotation tool is convenient if you have two classes of 
comments (such as queries and suggestions) and want an easy way 
to make them visually distinct. 

Record Sound Annotations 
Perhaps you’re more of a verbal person and can say what you think 
better than you can write it. Or maybe you want to provide a recording 
of transcribed text in a PDF. Whatever your reason, you can provide 
listenable annotations with the Sound annotation tool in PDFpen. 

Note: Not all PDF viewers, including Preview in macOS 11 (Big Sur), 
can play sound annotations. In addition, sound annotations are 
stripped out if you modify and save the PDF using such an app. 

To add a sound annotation to a PDF, do the following: 

1. On the toolbar, choose the Sound annotation tool from the 
Annotation tools pop-up menu. 

2. Click where you want to place the sound annotation. 

3. In the dialog that appears (Figure 45), click the record  button 
to begin recording your annotation. 
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Figure 45: This dialog appears when you place a sound annotation. 

4. Click the stop button to conclude the recording. 

5. Optionally, click the play button to review your recording. 

6. Click OK to save the annotation in the document. 

As an alternative, you can click Select File in the recording dialog to 
attach a pre-recorded file as a sound annotation. 

Note: PDFpen can import uncompressed AIFF files, either stereo or 
monaural, at 8-, 16-, or 24-bit resolution (24-bit files will be convert-
ed to 16 bits). 

To play back a sound annotation, click the annotation marker in the 
PDF, and then click the play button that appears (Figure 46). 

Figure 46: Playback controls appear when you click a
 
sound annotation.
 

Tip: You can change the color of a sound annotation marker with the 
Editing Bar’s object property tools (see The Object Property Tools). 
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Print Notes and Comments 
When you print a PDF, you have control over whether the notes and 
comments print. Figure 47 shows the relevant portion of PDFpen’s 
Print dialog; you may have to choose PDFpen from the dialog’s lower 
pop-up menu to see it. 

Figure 47: You can control whether notes or comments print using 
these options on the Print dialog. 

Here’s what the options do; they are both unchecked by default: 

•	 Print Comments: Select this to have the comments print in the 
exact location where you placed them on the page. 

•	 Print Notes: Select this to have the note window contents print 
at the bottom of the page as numbered footnotes. PDFpen reduces 
the page size so that the notes fit, and it adds a note number to each 
note icon on the page. 

Note: When you print, any other markup you’ve added to a PDF—
 

squiggles, highlights, underlines, text imprints, and so on—does 

print, no matter what.
 

Select, Copy, and Delete Annotations 
As described in Navigate with Annotations, you can use the sidebar to 
see and move among a PDF’s annotations. You can also use the sidebar 
to select annotations: click to select a single annotation, Shift-click to 
select a contiguous range of annotations, and ⌘-click to select discon-
tiguous annotations. 
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Once you have one or more annotations selected you can do the follow-
ing: 

•	 Delete: Choose Edit > Delete, or just press Delete, to remove the 
selected annotations from the PDF. Deleting multiple annotations 
at once is an easy way to clean up a previously marked-up PDF 
when the annotations it contains are no longer relevant to you. You 
might also use this capability when you make a duplicate of a 
marked-up PDF, such as one you have annotated for your own 
purposes, so that you can give that clean copy to someone else for 
review. 

•	 Copy as text: Choose Edit > Copy As Text (⌘-C) to copy the text 
contained in the selected notes and comments, as well as the text of 
selected highlights, to the clipboard. Copying the text of multiple 
annotations is useful when one or more notes or comments contain 
substantive material that you may want to use elsewhere. For 
example, you can copy a reviewer’s comments and queries from the 
PDF so you can paste them into an email response to that reviewer. 
You could also highlight important passages in a PDF document 
and then copy the highlighted text to obtain a quick summary of the 
document’s main points. 

Note: Remember that the text you see in a PDF can be stored as 
multiple text objects that might not be arranged in the same order as 
you see on the page (see A Peek at What Is Inside). Thus, text 
passages copied from highlights may appear somewhat garbled or 
out of order and require editing. 

Draw Attention
 

Sometimes you need to call attention to an item. For example, you 
can draw an arrow from a comment box to point at a particular part 
of a graphic, or call out part of an image or line of text with one of the 
drawing shapes (see The Draw Tools) or the toolbar’s Highlight 
tool. 
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Draw on the Page 
You can easily create elaborate eye-catching graphics with PDFpen’s 
drawing and object property tools. For example, Figure 48 shows a 
portion of a musical score that I’ve highlighted by superimposing a 
rounded rectangle, which has a custom fill color (yellow at 25% opaci-
ty) and a custom stroke (green, with a 2-point width). 

Figure 48: Draw attention to important information with the 
drawing and object property tools. The drawn object shown 
here is selected, showing its bounding box with control points 
at the corners. 

And since I’ve been nattering on about the object property tools, 
Figure 49 shows them on the Editing Bar: 

Figure 49: The object property tools control how an object’s 
fill and stroke appear; from left to right they control stroke and 
fill colors, line attributes, and stroke width. 

Each tool is a pop-up menu that changes appearance to show its 
current setting, as described earlier in The Object Property Tools. 

Note: Each drawing tool retains the object property settings you 
made the last time you used that tool. 

With the Edit tool you can select and drag drawn objects around, 
and resize and reshape them by dragging the edges of their bounding 
boxes or their control points. 

Should you want to use a drawn object again, you can copy and paste 
it, and add it to your Library (see The Library). 
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Another way to draw attention is with the Highlight tool. Though 
the tool is normally used to highlight text, as described earlier in The 
Selection Tools, when you position the tool over a non-text portion 
of the page, you can draw freeform highlights in the current highlight 
color (Figure 50). Note, however, that freeform highlights are locked 
in place when you draw them; to unlock them so you can move, select, 
and delete them, choose Arrange > Unlock All. 

Figure 50: You can draw freeform highlights. 

Note: You don’t need to unlock freeform highlights to select and 
delete them with the Annotations sidebar; see Select, Copy, and 
Delete Annotations. 

Draw Callouts 
A “callout” is a short bit of text, usually bordered, connected by a line 
or similar indicator to a passage of text or to some part of a diagram or 
illustration (Figure 51). 

Figure 51: A callout associates a text box comment with a PDF’s 
content via an attached line. 
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Although callouts are easy enough to create from scratch with the 
comment box and line tools (see Draw on the Page and Add Comment 
Boxes and Clouds), you don’t have to build them from parts: PDFpen’s 
Callout annotation tool make them for you, completely assembled. 

To make a callout: 

1. Choose Tools > Callout, or choose the Callout annotation tool 
from the toolbar’s Annotation tools pop-up menu. 

2.	 Click the PDF where you want the callout’s line to point and then 
drag to where you want the callout’s text box to appear. 

You can edit the text in the callout’s text box and adjust the text’s 
appearance with The Text Format Tools. Similarly, you can use The 
Object Property Tools to adjust how the box and its attached line look, 
including the box’s background color, the stroke width and style of the 
box border and its line, and what kind of symbol (such as an arrow-
head) appears at the end of the line. 

The callout’s text box has control points at each corner that you can 
drag to adjust the box’s size and shape. 

Note: The callout’s text box automatically expands to fit the text you 
type in it, but you can use the corner control points to reshape the 
box as you see fit. 

The callout’s line includes a control point that you can drag to change 
the angle at which the line bends and how far from the box it bends; 
you can drag the point around the box to change the side of the box 
from which it originates. 

View, Extract, and Add Attachments 

With PDFpen you can view and extract whole files that have been 
attached to a PDF, and with PDFpenPro you can add and delete such 
attachments. For example, when sending a PDF letter to shareholders 
that includes a section on the quarterly results, you might include the 
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company’s most recent EDGAR filing with the Securities and Exchange 
Commission as an attachment. Files can be attached to a PDF as a 
whole, or attached to a specific place in the PDF as an annotation. 

View and Extract File Attachments 
When a file attachment is placed as an annotation, it appears as a 
paperclip icon in the PDF (Figure 52). The person who produced the 
PDF may also pair the attachment annotation with a comment explain-
ing what the attachment contains: that is considered a good practice, 
but is not mandatory. File annotations appear in the Annotations 
sidebar like any other annotation (View > Annotations); they also 
appear in PDFpen’s Attachments sidebar (View > Attachments). 

Figure 52: A file attachment annotation appears as a paperclip 
symbol in the PDF; as a courtesy, a separate comment annotation 
has been added at right to explain what the attachment contains. 

When a PDF has file attachments that are not linked to a visible 
annotation, such attachments don’t appear in the Annotations sidebar 
but do appear in the Attachments sidebar (Figure 53). These attach-
ments lack the paperclip icon. 

Figure 53: Two attachments appear in this picture of the Attach-
ments sidebar. The attachment at the top is not an annotation and 
thus lacks an Attachment icon to its left. The second attachment, 
which is an annotation, has an icon. 
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To work with attachments, whether annotations or not, display the
 
Attachments sidebar (View > Annotations), then Control-click the
 
attachment and choose from the menu that appears (Figure 54).
 

Figure 54: Use this contextual menu to work with attachments. 
Note that the last two menu items are PDFpenPro features and not 
available in PDFpen. 

You can also access these menu commands by selecting the attachment 
in the sidebar and clicking the action pop-up menu at the bottom 
of the sidebar. In either case, these are your choices in PDFpen: 

• Preview: See what the attachment contains. 

• Open: Open the attachment in the appropriate app on your Mac. 

• Extract: Save the attachment as a separate file on your Mac. 

Add and Delete File Attachments (Pro Feature) 
With PDFpenPro, you can also add and delete file attachments. 

To add a file attachment as an annotation, choose the Attachment 
annotation tool from the toolbar’s Annotation tools pop-up menu, 
and then click on the document page. A file dialog appears from which 
you can choose the file to attach. 

Tip: When you make a file attachment annotation, it is considered a 
good practice to also add a comment box (⌘-8) near it that describes 
what the attachment contains. 
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To add a file attachment without displaying it as an annotation, choose 
Edit > Attachments > Add Attachment, and then select the file from 
the dialog that appears. 

To delete a file attachment, Control-click it in the Attachments sidebar 
and then choose Delete Attachments; alternatively, you can select it in 
the sidebar and then choose Edit > Attachments > Remove. 

Note: You can choose Edit > Undo to undo the deletion of an attach-
ment. 
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Copyedit and Review a PDF 
When you take notes on a PDF, the notes are usually intended for 
you and you alone. Copyedit notes and review notes, by contrast, are 
intended to be read by someone else: usually a writer, collaborator, 
or editor. 

That’s not to say that the techniques used to copyedit and review 
a PDF are different from those you use when you take notes. In fact, 
many of the techniques are the same: what differs are the audience 
for the notes and the purpose of the notes. 

So, take note: before you read the following brief section, I urge you 
to read Take Notes on a PDF. 

Learn About Copyediting
 

In today’s modern society today (as a poorly written student paper 
I once received said), writers and editors seldom exchange printed 
copy marked up with handwritten notes and queries. Instead, they 
often exchange PDFs. 

The advantages of speed and cost are obvious: shipping a 500-page 
set of galley proofs (an unbound preliminary printed version) can 
take days and cost many dollars compared to the few minutes and 
few pennies that emailing a PDF of the same material might involve. 

There are disadvantages to the digital method, of course: it’s more 
pleasant to sit in a comfy lawn chair on a mild summer day with a 
red pencil and a stack of galleys and mark things up than it is to hun-
ker down at a desk in a stuffy office, wrestling with mouse and key-
board. But those digitally imposed discomforts have begun to dwindle 
as technology advances: with a lightweight laptop or a tablet, a copy 
of PDFpen, and maybe a Long Island Iced Tea, the act of digital copy-
editing can be almost as enjoyable as the traditional manual method. 
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What Is Copyediting? 
Copyediting is the act of marking up a text to make suggestions 
for improving its style, format, and accuracy. Although it’s often 
separate from a proofreading pass over the text, where typographical 
errors are corrected, it is just as often combined with proofreading 
(although, in those cases, a second proofreading pass usually occurs 
following the initial copyedit/proofing pass). 

In this section, I treat the proofreading and copyedit stages of 
manuscript preparation as combined. 

Use the Proofing Marks 
Most copyeditors use a standard set of proofing marks, and follow 
certain conventions in their use. The goals are these: 

•	 Indicate where there are problems in the document. 

•	 Indicate the type of each problem. 

•	 Indicate what to do to fix each problem. 

•	 Make those indications as visible as possible. 

•	 Take up as little of the page’s limited space as possible when doing 
all of these things. 

Each textual problem usually has two marks associated with it: a small 
mark that is placed within the text and an associated mark that is 
placed next to the line in the margin. 

The purpose of the margin marks is to alert you to the problem, its 
general location, and its type. The purpose of the mark in the text is 
to show exactly where the problem is and to help indicate the solution. 
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Figure 55 shows a copyedited page with proofreading marks; notice
 
how much easier it is to spot the margin marks than those in the text.
 

Figure 55: Proofreading marks indicate insertions, deletions, and 
format changes. 

Tip: You can see an extensive list of proofreading marks with exam-
ples of their use in context on this page at EditFast. 

PDFpen’s Library has a rich assortment of proofreading marks. You 
can use these marks when you edit a text. 

To access PDFpen’s proofreading marks, do the following: 

1. Choose Window > Library or click Library on the toolbar. 

2. In the Library window, click the Proofreading icon (Figure 56). 
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Figure 56: The Library has an extensive collection of proofreading 
marks; the names of some are available when you hover the pointer 
over them. 

When you want to add a mark to a page, drag it from the Library to the 
page with the Edit tool. When it’s on the page, you can adjust its size 
if necessary by dragging the mark’s handles with the Edit  tool. 

Most of the proofreading marks in the Library have three forms, as you 
can see in Figure 56, above. From left to right the forms are: 

•	 Editing marks: You place these in the text itself when you 
copyedit a draft document. Drafts are commonly double-spaced (as 
in Figure 55, a page or so back) and have more room for markup. 
Therefore, editing marks tend to be slightly larger than 
proofreading marks (described next). 

•	 Proofreading marks: You place these in the text itself during a 
final proofreading pass. These marks tend to require less space than 
editing marks, and space is at a premium for material that is typeset 
in (nearly) final form. 

•	 Margin marks: You place these in the margin to call attention to 
the editing or proofreading marks that you’ve placed in text. Not all 
editing or proofreading marks have margin mark equivalents. 

Note: Generally, you should use either the editing marks or the 
proofreading marks in a document and not mix the two—although the 
proofreading police won’t arrest you if you do. 
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Learn the Copyediting Best Practices 
While I’m not about to teach you all of the fine points of copyediting 
(folks, there are whole books about this stuff!), here’s a short list of 
best practices that cover some basics: 

•	 Use the editing/proofreading marks within the text to indicate 
requested changes and corrections, and place the associated margin 
marks in the margin. 

•	 When adding text, place a comment box containing the text above 
an insertion mark in the margin, and use an insertion mark within 
the text to mark the new text’s location (Figure 55, a few pages 
back, shows several examples). 

•	 Use a deletion mark in the margin to indicate deletions, and use the 
Strikethrough line highlight (available on the Highlight  tool’s 
pop-up menu; see Underline Passages) in the text to indicate dele-
tions of more than one character; for a single character deletion, use 
a deletion mark in the text instead of a strikethrough line. 

•	 Use the Underline highlight to indicate italics within the text, and a 
margin mark to indicate it in the margin. 

•	 Use the Squiggle line highlight to indicate bold within the text, and 
a margin mark to indicate it in the margin. 

•	 Use comment boxes in the margin (see Add Comment Boxes and 
Clouds) to indicate brief suggestions, but make them a different 
color than any comment boxes used for inserted text. 

•	 Place note icons (see Add Pop-Up Notes) in the margin for queries 
to the writer or the editor; write the query in the note window, and 
make sure to close the window when you finish writing to avoid 
clutter. 
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Learn About Review Practices
 

PDFs are commonly used when circulating a document for review. 
Reviews can have a number of purposes: 

•	 To solicit opinions and suggestions from colleagues (for example, 
a draft document on a proposed business method) 

•	 To evaluate whether a document should be published (for example, 
peer review of papers submitted to academic journals) 

•	 To verify a document’s accuracy (for example, recipes in a cookbook 
or procedures in software documentation) 

There are no special tools designed specifically for document reviews. 
Rather, the tools and techniques described in Take Notes on a PDF— 
highlights, notes, comments, and drawings—can be, and often are, all 
used in reviews. What differs, as I’ve said, is the audience for and the 
purpose of the notes. 

Choose How to Circulate a Document 
How you circulate a document for review depends on the number of 
people involved, the need for confidentiality, and the schedule. There 
are two common circulation methods: 

•	 Star review: Copies of the document are sent from the editor to 
all reviewers at once (like the rays emanating from a star). Each 
reviewer supplies her own notes and returns the copy to the editor. 
This method is quick, and ensures that each reviewer’s notes are 
confidential, since only the reviewer and editor see them. However, 
a star review requires more work on the editor’s part to integrate 
the notes and suggestions, and can result in many redundant notes. 

Tip: The ability to copy the contents of multiple annotations, as 
described in Select, Copy, and Delete Annotations, becomes particu-
larly useful when you need to collect the notes and suggestions from 
multiple reviewers. 
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•	 Round-robin review: The document is sent to each reviewer in 
sequence, accruing notes as it circulates. This allows later reviewers 
to see the notes of previous reviewers and can eliminate redundant 
notes. However, a round-robin review takes more time than the star 
method, since only one reviewer at a time works on the document. 
It might also lead to instances of “false consensus” if later reviewers 
are influenced or intimidated by notes from earlier reviews. 

Follow Best Review Practices 
Finally, here are some best practices to follow when participating in a 
review: 

•	 Be polite: Even if the review is confidential, there is no guarantee 
that the author might not see your notes, even if your name isn’t on 
them. Rants and derogatory terms are never appropriate. 

•	 Question or suggest, don’t dictate: This goes along with being 
polite—unless you are the editor, you don’t have final say (and most 
good editors tend to question or suggest rather than wield the 
Awesome Hammer of Authority). 

•	 Be brief: Even if a scrolling note window gives you ample room to 
expand upon your thoughts, be succinct. The editor and the writer 
both must deal with comments from many reviewers, and, as a 
manuscript nears completion, time is a precious commodity. 

•	 Stay on topic: Don’t get sidetracked by copyediting or proofread-
ing issues; that’s usually not what a review is for. Focus on the 
issues on which the editor or author has asked you to comment. 

Which leads to this last best practice…. 

•	 (For the review organizer) Give clear instructions: Let 
the reviewers know what they should be concentrating on and what 
they can ignore as they review the document. If you have specific 
requirements for the form of the comments (for example, use notes 
rather than comment boxes, recommended highlight colors), state 
them explicitly. Make sure that all reviewers know the date by which 
the review must be completed. 
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Fill Out PDF Forms 
You live in a world of forms. Forms for filing taxes. Forms for ordering 
goods. Forms for applying for jobs. Forms for supplying medical 
information. Forms for ordering more forms. 

Often, forms come to you as PDFs, whether downloaded from the web 
or arriving as email attachments. And, if you’re really Old School, you 
can print those forms out and then fill them in by hand. 

But you don’t have to be Old School: with PDFpen, filling out a PDF 
form is a piece of cake, no printing required. You can even add a digital 
scan of your signature directly to the PDF. 

So whether you have an interactive PDF form that lets you fill it out on 
screen, or a PDF containing a digital image of a classic printed form, 
PDFpen has the tools that you need to make quick work of it. 

Fill Out an Interactive Form
 

Since version 1.2 of the PDF standard back in the last century, PDFs 
have been able to include interactive form elements. Filling out such 
a form is so easy to do with PDFpen that it’s hardly worth mentioning 
(but, of course, I will—I’m here for you). 

Most interactive PDF forms look indistinguishable from their non-
interactive counterparts. This raises the question: how can you tell 
if a PDF form is interactive? 

Here’s how: With the Select Text tool, click a form element, such as a 
text entry area or a checkbox. When you click an interactive text area, 
PDFpen outlines it with a blue box and places your text cursor in the 
box so you can type your information directly into the form (Figure 
57). If you click a checkbox on an interactive form, PDFpen places a 
check mark in the box for you; click it again to remove the check mark. 
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Figure 57: You can fill out an interactive form with PDFpen. 

As I said, easy. 

You may be allowed to return a form by email as a normal attachment. 
Other interactive forms might need to be printed when you finish 
filling them out, and then physically sent to the recipient by mail, fax, 
or some other method. 

Tip: Many interactive forms include instructions for how to fill them 
out and submit them. You can save yourself some time and trouble if 
you first look for, and read, any such instructions before you attempt 
to fill it out. 

You may encounter interactive forms that take advantage of an Inter-
net connection, and that can submit the form information directly over 
the Internet (you can design such forms with PDFpenPro; see Make an 
Interactive PDF Form (Pro Feature)). Forms that send their informa-
tion over the Internet normally have a Submit button, or a button with 
a similar label, that you click when you’ve completed the form. 

The form may also have a Clear or Reset button that you can click to 
clear all of your entries if you need to start over. If it doesn’t, you can 
choose Edit > Reset Form. 

Note: Not all PDF apps support sending form information over the
 

Internet. For example, PDFpen does; Apple’s Preview app doesn’t.
 

Note: If the interactive form includes a signature field, skip ahead to 
Sign Forms Digitally to see how to use a digital signing certificate. 
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Fill Out a Non-Interactive Form
 

Filling out non-interactive PDF forms is more work than interactive 
forms—but not much more. With few exceptions, non-interactive 
forms only have two kinds of form element with which you need to 
deal: checkboxes and text entries. 

Fill Out a Text Entry 
The key to filling out a text entry on a non-interactive PDF is to put 
a text imprint over the text entry area (Figure 58). 

Figure 58: Place a text imprint over a text entry area in a non-
interactive PDF form. 

It only takes a couple of steps to create a text imprint and fill it out: 

1. With the Text annotation tool, drag out a text imprint that fits 
over a text entry area on the PDF. 

The default text in the imprint is selected automatically when you 
create the imprint. 

Tip: Click to create an imprint if the text entry area is a single line.
 
See Set Wrapping in a Text Imprint. Also, If Snap to Guides is en-
abled, and you create the imprint near an underlined area on the
 

form, your imprint will snap into place on the line; see Use Guides.
 

2. Type your entry.
 

Your text appears in PDFpen’s default font.
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Tip: If PDFpen switches to another tool after you create an imprint, 
you can double-click the Text annotation tool to keep it selected 
so you can quickly create additional text imprints on the form. 

Unless you have changed it, the default font in PDFpen is 12-point 
Helvetica. If this font is impractical (for example, the text area on the 
form is too small to accommodate a 12-point font), you can change the 
imprint’s font and font size: 

1.	 If the Fonts panel is not already visible, choose Format > Font > 
Show Fonts (⌘-T). 

2. With the Edit tool, select the text imprint. 

3.	 In the Fonts panel, click a font in the Family column, and then click 
a size in the Size column. 

The text imprint takes on the font, style, and size you have chosen. 

Tip: You can use the Fonts panel’s search field to find a font quickly, 
and you can type a font size directly into the Size field at the top of 
the Size column. 

The above steps for changing the font are fine if you have only a few 
text areas to fill out, but they can quickly become cumbersome if the 
form has a lot of text entries. In that case, you can change PDFpen’s 
default font, as follows: 

1.	 Choose PDFpen > Preferences > Editing. 

2.	 Near the top right of the Editing preference pane, click Select to 
display the Fonts panel (Figure 59). 
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Figure 59: Set PDFpen’s default font on the Editing preference 
pane. 

3. In the Fonts panel, select a new default Family and Size. 

If you want, you can select a new default Typeface style as well. 

4. (Optional) Close the Fonts panel and the Preferences window. 

Preference changes take effect immediately, so you don’t have to close 
the Preferences window. You may want to leave the window open so 
you can reset the default font when you finish filling out the form. 

Tip: If you’d rather not change the default font in PDFpen, you can 
also create a text imprint, customize its font, and then Option-drag 
it to place an identically formatted copy elsewhere on the form. Or 
consider adding a properly formatted text imprint to your Library (see 
The Library). 
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Fill Out a Checkbox 
There are several ways to fill out a checkbox in a non-interactive form. 
For example, you could put a small text imprint over the checkbox and 
type an X or √ (Option-V in many fonts), use the Scribble  draw tool 
to hand-draw a check mark, or use the Polygon  draw tool to make a 
check mark. Remember that once you’ve placed a check mark, you can 
Option-drag it to a new location to create a copy there. 

Personally, I like to use the Library, because it comes with a ready-
made check mark in the Proofreading Marks collection (Figure 60). 

Figure 60: Steal a check mark from the Library’s Proofreading 
Marks collection to check off boxes in a form. 

Follow these steps to use the Library to fill out checkboxes: 

1. Choose Window > Library or click Library on the toolbar, and 
then, in the Library window, click the Proofreading Marks icon. 

2.	 Scroll down to find the check mark. It’s about two-thirds of the way 
down in the collection. 

3.	 For each checkbox that you want to check, drag the check mark 
from the Library window to the checkbox on the form. Adjust its 
thickness and color with The Object Property Tools if necessary. 
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Add a Scanned Signature
 

Ordinarily, when a non-interactive PDF form requires a signature, you 
can fill out the form with PDFpen, print it, and sign the printed copy. 
Sometimes, though, the party that sent you the form may allow you to 
send a PDF of a signed form back via email. If so, you can add a signa-
ture imprint (Figure 61) to a PDF form within PDFpen and avoid the 
printing step. 

Figure 61: Sign a PDF form with a signature image. 

Warning! A signature image, like any other image in a PDF, can 
easily be copied and reused. Make sure you send PDFs containing 
images of your signature only to trusted parties. Of course, a 
scoundrel receiving your signature on paper could scan it too, so 
it’s not as though avoiding a digital format is a guarantee of safety. 

The general steps are these: 

1.	 Obtain an image of your signature. This can be from a scan, a digital 
photo, or from some other source like a drawing program. 

2.	 Place the image on the form in PDFpen (see Add and Alter 
Pictures). 

3.	 Crop and resize the image to fit (see Resize and Crop an Image). 

4.	 Make the image transparent so only the pen strokes are visible (read 
Make a Transparent Image). This makes your signature sit on top of 
a horizontal line, making it look like you wrote over the line. 

5.	 Optionally, save the transparent signature in The Library so you can 
reuse it in other forms. 
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Tip: The PDFpen Help also has extensive instructions for all these 
steps; see “Adding a Signature” in PDFpen’s online help. 

Tip: If you need to print your form entries on a pre-printed form, use 
the Print Imprints Only option in the Print dialog; see Print Your PDFs. 

Sign Forms Digitally
 

Some interactive PDF forms (such as those made by PDFpenPro or 
Adobe Acrobat) can include interactive signature fields. These allow 
you to write your signature with a trackpad or stylus right on the form 
and, optionally, affix a digital signing certificate that verifies the 
document has not been altered after signing and that it verifiably came 
from the party who signed it. 

Tip: Smile has a blog post that describes in detail what constitutes 

a digital signing certificate and the levels of trust such certificates 

provide.
 

Write Your Signature 
When you open a form with an interactive signature field in PDFpen, 
the field indicates where you click to sign (Figure 62). 

Figure 62: PDFpen uses a “Sign Here” stamp to show where to sign. 

Click the field and a signature dialog appears. To sign with a trackpad, 
click once in the dialog’s signing area and then scribble your signature 
with your fingertip or with a stylus if your trackpad supports it 
(Figure 63). To finish signing, double-click in the dialog’s signature 
area. 
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Figure 63: Scribble in the dialog with your fingertip to sign a 
document. Use the controls at the bottom left to set the line-width 
and color of your signature. 

The signature area roughly represents the surface of your trackpad: 
for example, you have to begin writing at the left side of the trackpad 
for your signature to start at the left side of the on-screen signature 
area. Note that you can avoid scrawling a finger-painted signature 
if you have a scanned signature in your Library (see Add a Scanned 
Signature): just drag the signature to the dialog’s signature area. 

Apply a Signing Certificate 
When you write your signature on an interactive form, you have the 
option of applying a digital signing certificate by clicking Apply Digital 
Signature in the signature dialog. The resulting dialog displays a pop-
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up menu from which you can choose among the digital certificates in
 
your Mac’s keychain to serve as your “signing identity” (Figure 64).
 

Figure 64: Choose who you want to be with the digital signing 
identity dialog. 

Note: You must draw or drag a signature into the signing area to 
enable the Apply Digital Signature button. 

It’s likely that you have a number of possible identities in your key-
chain. However, most of them are probably of little use as digital 
signatures. In fact, Adobe Acrobat and Adobe Reader only “trust” 
digital signing certificates generated by an authority on the Adobe 
Approved Trust List (AATL). 

Tip: In its blog, Smile describes in detail the steps you need to
 

perform to purchase and install an AATL signing certificate.
 

Using an AATL signing certificate verifies that the PDF does come 
from the person it says it came from, and that it has not been altered 
in any way after the certificate was applied (see Using and Trusting 
Signing Certificates ahead). 

If, however, you don’t want to go to the trouble and expense of pur-
chasing an AATL signing certificate, you can create what’s known as 
a “self-signing” certificate. The recipient of the PDF can see who the 
certificate purports to be from, but it is not necessarily trusted. 

To create a self-signing certificate, click Create a New Identity in the 
digital signing identity dialog, and then, in the dialog that appears, 
provide a name (preferably yours or your organization’s) and an email 
address. Those items will be available to the PDF’s recipient. 
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Once you have created a self-signing certificate, it is placed in your 
keychain so you can use it again. 

Note: As soon as you apply a signing certificate, PDFpen locks the 
PDF so you can no longer alter it. 

Warning! Apple’s Preview does not respect signing certificates and 
allows you to modify signed PDFs. Once a PDF has been modified, 
PDFpen no longer “sees” its signing certificate. 

Using and Trusting Signing Certificates 
When you apply a signing certificate to a PDF, or receive one that has 
been signed, a badge appears on the PDF to indicate the level of trust 
the certificate ensures: yellow means signed but not necessarily trust-
ed; green means signed and trusted (Figure 65). 

Figure 65: A green badge (left) means trusted; a yellow badge 
(right) means signed but not trusted. 

Note: Documents signed with a self-signing certificate that you have 
created will always show up as being trusted when you open them in 
the same user account in which you created the certificate. However, 
the certificate won’t appear as being trusted for anyone else. 

Because a digitally signed document purports to be unchanged follow-
ing its signing, you cannot edit a signed document in PDFpen: when 
you open one, PDFpen informs you of this (Figure 66). 
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Figure 66: Digitally signed documents are not to be altered. 

You can examine the certificate of a digitally signed document by 
clicking its badge: a dialog appears to inform you of the certificate’s 
authenticity. For trusted documents, you see a preview of the certifi-
cate’s contents. 

For untrusted documents, on the other hand, the dialog simply tells 
you that the certificate is untrusted but gives you the option to examine 
the certificate by clicking Show Certificate. When you click that button, 
PDFpen adds an Always Trust checkbox to the dialog in addition to 
supplying details about the certificate. If, after examining the certifi-
cate, you feel it is trustworthy, you can check that checkbox, and, from 
then on, any PDFs you receive that use the same certificate will be 
trusted by PDFpen. 

Signing Your Own PDFs 
How about the case where you want to send someone a digitally 
signed PDF that you created so the recipient can verify that it came 
from you? Because you can only use a self-signing certificate with 
a document that contains an interactive signature field, you cannot 
create such a document with PDFpen. For that, you need PDFpenPro. 

To create a signed document with PDFpenPro, add an interactive
 

signature field to the document (see Make an Interactive Signature), 

sign the document, and then apply the certificate. Remember, how-
ever, that once you apply the certificate, the document is locked.
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Use the DocuSign Service (Pro Feature) 
If the whole business of obtaining and using a signing certificate (see 
Apply a Signing Certificate) seems more work and trouble than you 
like, don’t worry: with PDFpenPro you can easily use the DocuSign 
service to handle the gnarly details for you. The service is integrated 
into PDFpenPro, making it easy for you to use the service to upload 
and distribute PDFs securely to business associates, colleagues, clients, 
or anyone else from whom you want to obtain a trusted digital signa-
ture. 

To start, you first need to obtain an account with DocuSign, but that’s 
easy enough: choose File > DocuSign > Log In to DocuSign. 
PDFpenPro opens your web browser and takes you to the DocuSign 
login page, on which you can create a new account. 

To create an account you need to supply a name, a company name, an 
email address (important: this is the address DocuSign uses to send 
you signed copies of your PDFs), a password, and some other informa-
tion. Although DocuSign accounts are not free, you can try out the 
service for 30 days at no cost: in fact, the new account creation process 
doesn’t even ask for a credit card number or other method of payment. 

Important Tip: Record the email address and password you supply
 

to DocuSign just in case you need to enter that information again in
 

the future—although PDFpenPro saves your login credentials and 

supplies them when you use the service, better safe than sorry.
 

Once you have an account, it shows up on the File > DocuSign menu in 
PDFpenPro (Figure 67). 

Figure 67: PDFpenPro knows your DocuSign account credentials and 
shows you the account to which you are logged in. 
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After you are logged in, sending a PDF to DocuSign is as simple as 
choosing Upload from the File > DocuSign menu. PDFpenPro uploads 
the PDF currently open in your PDFpenPro window. 

A few pointers and notes: 

•	 You can send any PDF to DocuSign; it does not have to be a form, 
nor does it have to have any signature lines in it. You specify where 
recipients sign on the uploaded PDF, using the tools provided on 
DocuSign webpage. 

•	 You can send a PDF to several recipients if you need signatures 
from each of them: you provide the email addresses and DocuSign 
sends the PDF to those addresses with instructions on how to fill 
them out. 

•	 DocuSign’s online tools provide other form elements, such as a 
signing date item, that you can also add to an uploaded PDF. 

•	 Form fields you create with PDFpenPro convert to DocuSign fields 
when you upload your PDF, giving you the ability to assign specific 
fields to specific users using DocuSign’s online tools. 

•	 The default values for PDFpenPro-created form fields pre-fill 
automatically when you upload a PDF. 

•	 Keep your original PDFs. Although DocuSign returns the signed 
copies to you, you may want to edit a PDF and use it again at some 
other time—remember, digitally signed PDFs are not editable. 

Tip: It is well worth your while to visit the DocuSign Support pages 
for the most current information about the various services DocuSign 
offers and how to use them. 
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Edit a PDF 
The conventional wisdom is that PDF documents are great to share 
because, unlike word processing files, PDFs are in final form and can’t 
be modified. 

Yeah, right. If you’ve read any part of this book, you know that PDFs 
are far from unmodifiable. Nonetheless, it is true that PDFs are not 
easily modifiable—that is, not unless you have a tool like PDFpen. 
Armed with PDFpen, you can make all sorts of changes, such as: 

• Fix typos in a magazine article. 

• Update an old flyer, even if you don’t have the original. 

• Sharpen and stylize pictures on the page. 

• Redact sensitive or confidential material. 

• Crop pages or rotate them. 

• Add a watermark to one or more pages. 

• Add headers, footers, and page numbers to a PDF. 

• Create links to other pages in the PDF or to webpages. 

In this chapter, you’ll learn how to do all of these things and more. 

Warning! When you edit a PDF, never edit the original. Make a copy 
and edit that. Trust me, you’ll thank me for saying this. 

Add, Edit, and Remove Text
 

You’ve already seen how to add a text imprint to a PDF in Fill Out a 
Text Entry: select the Text annotation tool and click or drag on a 
page in the PDF. Each time you create an imprint, it contains the 
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sample text “Text,” which is selected so you can quickly replace it by 
typing. 

Tip: To duplicate an imprint, Option-drag it with the Edit tool. 

Set Wrapping in a Text Imprint 
Whether text wraps in an imprint depends initially on whether you 
created the imprint by clicking or by dragging: 

• Clicking: When you click with the Text annotation tool to 
make an imprint, the text box expands horizontally as you type. The 
text doesn’t wrap, so you may find yourself typing a long line of text 
that extends beyond the edge of the page. Similarly, if you paste 
a lengthy chunk of text into the imprint, the text ends up on a single 
line. 

You can change this behavior by enabling text wrapping before the 
text imprint becomes too wide. When text wrapping is enabled, 
typed text wraps when it reaches the right border of the box. To turn 
on text wrapping, do the following: 

1.	 Place the cursor within the imprint, or select the imprint with the 
Edit  tool. 

2. Choose Edit > Wrap Text. 

•	 Dragging: When you drag to create an imprint, the text that you 
subsequently type wraps automatically to the width of the imprint, 
and the imprint expands vertically once the text reaches the bottom. 
This is because the Wrap Text command is already enabled for 
imprints that you create by dragging. If you choose Edit > Wrap 
Text on such an imprint, you disable Wrap Text, and the text im-
print behaves like one that was created by clicking. 

Whether the text wraps or not, you can adjust the size of a text imprint: 

1. Choose the Edit tool and click the imprint. 

2. Drag a handle at a corner of the imprint to resize and reshape it. 
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When Non-Wrapping Imprints Wrap 
When you resize a non-wrapping imprint, the text does wrap, but 
as soon as you attempt to add text to the imprint, it unwraps again, 
and can leave you with a short, wide, and possibly unwieldy imprint. 
Always remember to turn on wrapping as soon as you resize a non-
wrapping imprint to avoid an unpleasant surprise. 

Tip: Click to create an imprint when you know its text needs to be on 
a single line. Drag to create an imprint if you know the text has to fit 
within a specific horizontal space. 

Change the Appearance of Text 
When you create a new text imprint, it uses PDFpen’s current default 
font (described in Fill Out a Text Entry). But the text imprint doesn’t 
have to remain in that font. In fact, you can mix fonts and text colors 
within an imprint, and you can set the font, text color, and background 
color for the imprint as a whole. 

Note: By “font” I mean the font family, typeface, and size, as chosen 
in the Fonts panel. 

By default, imprints are transparent, but you can give them a back-
ground color. You can make an imprint’s background color completely 
opaque, or you can adjust the color’s opacity so that objects behind the 
imprint can be seen. 

Here’s how you change the background color of an imprint: 

1. With the Edit tool, click to select the imprint. 

2. Click the Fill Color icon. 

3.	 On the menu, click the background color that you want. If the menu 
does not contain your desired color, click the Custom Color icon 
at the bottom of the menu, and then use the Colors panel that 
appears to choose the color you want. 
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Note: You cannot give a range of selected text a background color; 
the background color always affects the entire imprint. 

You can format a range of selected text in an imprint or the imprint as 
a whole. Here are the text formatting settings you can make: 

•	 Text styles and relative sizes: Choose Format > Font and an 
appropriate submenu item. The submenu items include Bold, Italic, 
Underline, Smaller, Larger, Kern, Ligature, and Baseline. Note that 
you can set kerning, ligature, and baseline only for text selections, 
not for a selected imprint. 

•	 Text alignment: Choose Format > Text, and then choose either 
Align Left, Center, Justify, or Align Right. 

•	 A specific font (family, typeface, and size): Choose Format > 
Font > Show Fonts, and then specify a font with the Fonts panel. 

•	 Text color: Choose Format > Show Colors, and then choose a color 
in the Colors panel. 

Two Tips: See The Text Format Tools for a quick way to make 
common text format settings. Also see the sidebar A Wise and Benev-
olent Ruler (a few pages ahead) for another way to perform text 
layout tasks. Some of these tasks, such as setting line spacing and 
paragraph indents, are available only from the ruler. 

Here are explanations of the less common formatting terms: 

•	 Kern: The commands on this submenu control the amount of 
space between individual characters. Here are your choices: 

‣	 Tighten and Loosen: These two commands, respectively, bring 
the characters closer together or send them farther apart. Place 
the cursor between two characters to adjust the kerning between 
them, or select a range of text to adjust the entire selection. 

‣	 Use Default: Select this to use the kerning pairs built into the 
font. The available kerning pairs vary from font to font. 
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‣	 Use None: Choose this to ignore the default kerning pairs and 
space the characters equally. 

Ordinarily, Use Default is the best choice unless you have specific 
typography needs. 

•	 Ligature: Some fonts have special characters that are designed 
to replace specific character combinations. For example, “ff” and 
“fl” are frequently replaced with ligatures that combine the two 
characters to make them fit together more attractively. Moreover, 
some decorative fonts include less common ligatures, such as 
ligatures for “ct” and “st.” Which character combinations PDFpen 
replaces by ligatures depends on the ligatures available in the 
selected text’s fonts. 

Here are the Ligature submenu choices: 

‣	 Use Default: This command substitutes the common ligatures 
for matching character combinations in the selected text. 

‣	 Use All: This command substitutes any available ligature, com-
mon or not, for matching character combinations in a selection. 

‣	 Use None: This command does not do any ligature substitution, 
and removes ligatures placed by the other two commands. 

Use Default is ordinarily the best choice. 

Note: Even if ligatures are substituted, you can still easily edit the 
text: for example, you can place your text cursor between the “f” and 
the “l” in the “fl” ligature just as if the two characters have not been 
replaced by a ligature. 

•	 Baseline: The commands on this submenu affect the amount of 
vertical spacing between selected characters and the baseline: 

‣	 Superscript and Subscript: These commands raise or lower the 
selected characters a bit more than half the character height each 
time you apply them. You might use these when typing formulas. 
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‣	 Raise and Lower: These commands raise or lower the selected 
characters a small amount (about 1 point) from the rest of the 
characters on the line each time you apply them. Use these 
commands to make fine adjustments, such as when you correct 
text on a page. 

‣	 Use Default: This puts the characters back where they belong. 

A Wise and Benevolent Ruler 
For heavy duty text formatting, PDFpen supplies a ruler (Figure 68). 
Choose Format > Text > Show Ruler (⌘-Control-R) to see it. 

Figure 68: The ruler can set indents, tabs, alignment, and more. 

The ruler spans the top of the document window, and the settings 

it displays are those for the currently selected text. If you have ever
 

used Apple’s TextEdit, you have seen this ruler.
 

The ruler provides most of the text layout controls you would find 

in a word processing application, and is the only tool in PDFpen with
 

which you can easily do things like create numbered or bulleted lists 

or set specific amounts of line spacing.
 

You can copy and paste ruler settings from one text imprint to anoth-
er or between text selections in an imprint with the Format > Text > 
Copy Ruler (⌘-Control-C) and Format > Text > Paste Ruler (⌘-
Control-V) commands. 

Correct or Remove Items on a Page 
It’s easy enough to edit text imprints that you put on the page, but 
what about the native text or graphic objects that a PDF may already 
contain? PDFpen provides several tools and commands that give you 
some mastery over a PDF’s native objects. 

Use the Correct Text Command 
The Correct Text command gives you the ability to modify the contents 
of a PDF’s native text objects. Here’s how to use it: 
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1. With the Select Text tool, select the text you want to change. 

2. On the toolbar, click Correct Text, or choose Format > Correct Text. 

Depending on the underlying structure of the text object in the PDF, 
the text you’ve selected and a varying amount of surrounding text 
appear within a text imprint (Figure 69). 

Figure 69: PDFpen puts your selection and surrounding text into an 
imprint when you use the Correct Text command. 

3.	 Type your changes, or use a formatting or editing command, such as 
Format > Font > Bold, or Edit > Cut. 

Your changes take effect. What’s more, you can now move the imprint 
around, resize it, and do all the other stuff that you can do with the text 
imprints that you make. Zounds! 

Here’s how text correction works: PDFpen analyzes the various PDF 
text objects that contain your text selection, removes the text from 
those objects, and puts the text into a similarly sized imprint, matching 
the original objects’ layout and formatting as best as it can. “As best as 
it can” is key here—your Mac, for example, might not have the same 
fonts installed that were used to create the document. Or maybe the 
text was created from OCR (see Use OCR on Scans and Graphic Files). 
In those cases, PDFpen has to “fake it” when it makes the imprint. 

There are two kinds of “faking it” (these are gross oversimplifications— 
the processes belong in the realm of You Really Don’t Want to Know): 

•	 The font is not on your Mac: PDFpen examines whatever layout 
information it can scrounge up about the font and looks for the 
closest fit it can find on your Mac. The imprint will look similar, but 
not identical, to the original text. You may have to manipulate the 
imprint slightly to smooth out the differences. 
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•	 The text object is the result of OCR analysis: PDFpen looks 
for a font that lays out with roughly the same dimensions as the 
scanned text, but doesn’t try to match the original font’s look in the 
imprint that it creates (Figure 70). You may have to work hard to 
make the imprint come close to matching the original’s appearance. 

Figure 70: This text imprint was derived from an OCR analysis of 
a low-resolution JPEG image that was scanned from a decades-old 
typed letter. Note the default font, Helvetica 12, was used in the 
imprint, and that the imprint does not quite align with the underlying 
text image, which was scanned at a slight angle. 

Fortunately, to make the corrected text imprint look as much like the 
original as possible, you have access to PDFpen’s full range of text for-
matting capabilities: fonts, colors, sizes, baseline adjustments, kerning 
adjustments, line spacing, and so on. Learn them, and use them (see 
The Text Format Tools and Change the Appearance of Text). 

Tip: Don’t try to correct huge amounts of text at once. The best use 
of the Correct Text command is for minor touch-up work and careful, 
incremental changes. 
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Edit the OCR Layer in PDFpenPro 
As described in About OCR Accuracy and the OCR Layer, you can 
view the hidden text created when you perform OCR. In PDFpenPro, 
you can also correct text directly on the OCR layer instead of with the 
Correct Text feature (which creates a text imprint, as described just 
previously). 

To correct text in the OCR layer, choose View > OCR Layer, and then, 
using the Select Text tool, click a word that you want to correct, or 
drag to select several words to correct. A Correct OCR Text panel 
appears (Figure 71). 

Figure 71: Use this panel to correct text in the OCR layer. 

Enter your correction and click Apply. OCR layer corrections don’t 
appear in the PDF: the underlying text image remains. However, text 
searches of the PDF will search the OCR layer, including corrections. 

Redact Text 
There’s another kind of text correction you can make that doesn’t 
require as much work: you can remove text completely. That is, in 
PDFpen terminology, you can redact it. 

If there are confidential passages in your document, here’s how you 
can remove each one with PDFpen’s redaction capabilities: 

1. With the Select Text tool, select the text you want to remove. 

2. Do one of the following: 

‣ Choose Format > Redact Text – Block. 
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‣	 Choose Format > Redact Text – Erase. 

Here is how the two commands differ: 

•	 Redact Text – Block: This command removes the text from the 
underlying text object, and places a black rectangle where the text 
was (Figure 72). In the case of scanned text, it also deletes the part 
of the image from which the scan was derived. 

Figure 72: Two names in this manuscript have been redacted 

to protect the innocent.
 

The black redaction rectangles are separate objects that you can 
move, fill with a different color, or resize—just on the off-chance you 
want to make your redactions a cheerful rainbow. 

•	 Redact Text – Erase: This command removes the text from the 
underlying text object, and, in the case of scanned text, it deletes the 
part of the image from which the scan was derived. 

Tip: You can also select a rectangular area of the page with the
 

Select Rectangle tool and then choose Format > Redact Text – Block
 

or Format > Redact Text – Erase to redact everything within the
 

selection.
 

No Redaction for Imprints 
If you select text in a text imprint, the Redact Text menu items are 
disabled. Similarly, if a rectangular selection includes an imprint, 
redacting the selection leaves the imprint untouched. You can redact 
only text that is in a PDF text object embedded in a page. On the 
other hand, you can easily edit text in a text imprint manually to 
remove sensitive information. 

Fine-Tune with the Precision Edit Tool 
As you learned in The Selection Tools, to the right of the Edit  tool on 
the Editing bar you have a Precision Edit tool. With this tool you can 
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select and then move, scale, or remove native PDF text and graphic 
objects. 

Here’s how to use it: 

1. On the Editing Bar, click the Precision Edit tool; your pointer 
changes to the precision pointer. 

2.	 Click the item you want to manipulate, either text or graphic. This 
selects the item, indicated by a bounding box with control handles 
at its corners (Figure 73). 

Figure 73: The Precision Edit tool can select either native text 
objects (left) or graphic objects (right). 

3. Do any of the following: 

‣	 Place your pointer over the object so your pointer becomes a 
move pointer, then drag to move the object. 

‣	 Place your pointer over one of the object’s control handles so 
your pointer becomes a resize pointer, and then drag to scale 
the object. 

‣ Press Delete to remove the object from the PDF. 

Note: The Precision Edit tool does not select imprints or objects you 
have drawn using PDFpen’s drawing tools; use the regular Edit tool 
for those. (See A Peek at What Is Inside for more about the native 
text and graphic objects that the Precision Edit tool can select.) 
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Search and Replace or Redact Text 
In addition to the correction capabilities described in Correct or 
Remove Items on a Page, above, there’s yet another avenue to 
modifying a PDF’s native contents: the Find feature. 

If you’ve been reading this book from front to back, you’ll have read 
that you can navigate in a PDF with PDFpen’s Find feature (see 
Navigate with Search Results if you are of the non-linear reading 
persuasion). Find, though, is only one-third of that feature: it’s really 
Find, Find and Replace, and Find and Redact. 

You can search and replace text like this: 

1.	 Choose Edit > Find > Find and Replace (⌘-Option-F). 

The Replace window opens if it is not already visible, with the 
cursor positioned in the Find field. 

2.	 Enter some text in the Find field. As you type, matching results 
appear in the window (Figure 74). 

Figure 74: Use the window to perform Find and Replace operations. 

3.	 Enter some text in the Replacement field. 

4.	 Do one of the following: 

‣	 Click a result in the Replace window and then click Replace— 
no, not the first Replace menu button to the left of the Find field 
(shown in the figure above), but the second one, between the 
Replacement field and the Replace All button. 

‣	 Click Replace All. 
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When you choose Replace, the following actions happen so quickly 
that you may not notice all the steps. First, the document displays the 
result that you clicked and selects the matched text. Then, that text is 
replaced with the contents of the Replacement field, after which the 
search result that you clicked vanishes from the window. Finally, the 
window selects the next search entry, if any. The end result is that 
everything is set up so that you can click Replace again to replace the 
new currently selected search entry. Lather, rinse, repeat. 

On the other hand, when you choose Replace All, PDFpen replaces 
every occurrence of the text that matches the Find field with the 
Replacement field’s contents. Depending on the size and complexity 
of the PDF document, this can take a few seconds. When the process 
finishes, no search results remain in the window, and the document 
shows the final replacement selected. 

Here are some important points to keep in mind when you perform 
a Search and Replace: 

•	 The search is both case-insensitive and word-boundary insensitive. 
If, for example, you search for the name Alf and replace it with 
Sigurd, not only will all occurrences of the name be replaced, but 
words containing the search term receive the replacement as well: 
halfway, for example, becomes hSigurdway. 

•	 If the found text is not already in a text imprint (that is, if it is in 
a PDF text object embedded in the page), the act of replacing it 
creates a text imprint, just as though you had selected the text and 
chosen Format > Correct Text (read Use the Correct Text Com-
mand). It even works with OCR text in a scanned image. 

The steps to perform a Search and Redact operation are similar to 
those for a Search and Replace: 

1.	 Choose Edit > Find > Find and Redact (⌘-Shift-F). 

The Redact window shows its Find field and includes a menu with 
redaction options (Figure 75). 
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Figure 75: The Redaction Style menu gives you the option of
 
blocking out or erasing search results.
 

2.	 In the Find field, enter text that you’d like to redact. 

PDFpen displays any matches in the lower portion of the window. 

3.	 From the Redaction Style pop-up menu, choose a redaction style. 
You have the same two choices as for manual redactions: Erase 
or Block (described in Redact Text, a few pages earlier). 

4.	 Do one of the following: 

‣	 Next to the Redaction Style pop-up menu, click Redact to redact 
matching results one by one. 

‣	 Click Redact All to redact every occurrence of the search term 
in the text. 

Keep these points in mind when you search and redact: 

•	 Redaction searches are also case and word-boundary insensitive, 
matching the search string no matter where it occurs in the PDF. 

•	 As with manual redaction operations, the redact operation only 
redacts text that is in a PDF text object embedded in the page; it 
does not redact any text that occurs within text imprints. Instead, 
you can perform a find-and-replace on those occurrences and 
remove the text from imprints that way (you will have to create the 
black redaction box by hand if you want to indicate a redaction). 

•	 Find and Redact doesn’t search a PDF’s metadata. (For instructions 
on modifying a PDF’s metadata, read the bullet item on “Document 
Information” in The Inspector.) 
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Insert Line Numbers 
In some documents, such as transcripts or legal documents, you may 
find it useful to number some lines of text for reference. You can select 
text with the Select Text tool or select a rectangular area containing 
text with the Select Rectangle tool and then choose Edit > Insert 
Line Numbers. PDFpen places numbers to the left of the selected text. 

Inserted line numbers have the following properties: 

• Inserted line numbers always begin with 1. 

•	 They use the default page number font as specified in PDFpen > 
Preferences > Editing. 

•	 Once added, they cannot be edited; to remove them, choose 
Arrange > Unlock All (⌘-Shift-L), click them with the Edit  tool, 
and then either choose Edit > Delete or press Delete. 

Add and Alter Pictures
 

PDFpen can import a number of image formats, including all the usual 
suspects: JPEG, TIFF, GIF, PNG, and Photoshop. When images are 
imported, PDFpen converts them silently to PDF image objects. 

You can import image files simply by dragging them from a Finder 
window or your desktop directly onto the page currently displayed in 
the PDFpen document window. 

You can also drag an image file to the Thumbnails sidebar, in which 
case PDFpen creates a new page and centers the document on that 
page. 

Or, if you prefer, you can follow these steps, which use the standard 
Open dialog and help you if you need to search for the file by name: 

1.	 Choose File > Insert (⌘-Shift-I). The standard Open dialog appears. 

2.	 In the dialog, optionally use the search field to locate the file, and 
then select the file and click Open. 
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The image appears centered on the page currently displayed in the 
document window. In a new, blank document, a page is created and 
the image placed on it. 

Once the image is in PDFpen, it can be moved from one page to anoth-
er by cutting or copying it from its current page and pasting it onto a 
different page. 

Pay Attention to the Selection 
When you paste an image, make sure that the document area of the 
PDFpen window is active rather than a thumbnail in the sidebar. If 
a thumbnail is selected and active (that is, it is highlighted in color), 
pasting creates a new page containing just the clipboard contents 
instead of putting those contents on the page shown in the document 
area of the window. 

Resize and Crop an Image 
It’s rare that an image you insert into a PDF is exactly the right size 
and shape. However, you can resize and crop it painlessly. 

To resize an image, do the following: 

1. With the Edit tool, click the image. 

2.	 Drag any corner of the image to resize it; hold down Shift as you 
drag to maintain the image’s proportions. 

Cropping an image is not much more difficult: 

1. With the Edit tool, click the image and then choose Edit > Crop 
Image. 

A cropping control panel appears at the bottom of the document 
window and the image is highlighted with its current dimensions 
indicated at the top left and bottom left (Figure 76). A cropping 
rectangle is superimposed on the image. 
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Figure 76: This image is on the verge of being cropped. 

2.	 Drag within the image boundaries to move the cropping rectangle; 
drag from any corner or edge to resize it. 

As you move the cropping rectangle, the area outside of the crop-
ping rectangle appears with reduced contrast to highlight the area 
to be cropped, and the size indicators change to reflect the current 
dimensions. 

3.	 Do one of the following: 

‣	 Click Crop to crop the image to the highlighted area. 

‣	 Click Crop and Scale to Fit to crop the image but have the 
cropped image scale to match either the original horizontal 
or vertical dimension. 

If the horizontal dimension of the cropped image is the largest dimen-
sion, the image scales to fit the original horizontal dimension; if the 
vertical dimension is largest, the cropped image scales to fit the origi-
nal vertical dimension. 
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Straighten and Adjust an Image 
When an inserted image is slightly skewed or is poorly exposed, you 
can compensate—within limits, of course: PDFpen can work minor 
wonders, but not miracles: 

1. With the Edit tool, click the image and then choose Edit >
 
Deskew and Adjust Image.
 

The Deskew and Adjust controls appear at the bottom of the docu-
ment window (Figure 77). 

Figure 77: The Deskew and Adjust controls can affect the selected 
image or all of the images in the document. 

2.	 Drag the Skew slider left or right to adjust the tilt of the image so it 
appears straight. The Skew slider is limited to about 20 degrees of 
adjustment. 

3.	 Drag the Exposure slider left or right to decrease or increase the 
exposure (brightness) of the image; drag the Contrast slider left or 
right to decrease or increase the image’s contrast. 

4.	 Click Apply. 

Tip: You can click Apply to Entire Document if all the images in your 
document suffer from the same shortcomings, which might happen if 
they all come from the same source, such as a misadjusted scanner. 
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You can make more complex image adjustments as well with PDFpen’s 
Image Edit panel: 

1. With the Edit tool, click the image and choose Edit > Adjust 
Image to open the Image Edit panel, which appears with its Adjust 
tab selected (see Figure 78). 

Figure 78: The Image Edit panel provides controls similar to those 
found in Photos and many other image-editing applications. 

2.	 Drag the various sliders to adjust the image’s appearance; if things 
get out of hand, click Reset All and try again. 

3.	 Close the Image Edit panel or click another tab in the panel to make 
your changes take effect. 

You can apply some preset effects with the Effects tab of the Image 
Edit panel as well, such as blurring the image, applying an “antique” 
effect, and inverting all of the colors to make a color negative of the 
image. The Effects tab displays thumbnails showing the various effects 
so you can preview before you try them. Unlike the controls on the 
Adjust tab, they don’t take effect when you switch tabs: to apply an 
effect, select it and then close the Image Edit window. 

The Image Edit panel’s Details tab displays statistics about the image. 
It has no controls that you can adjust. 
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Resample an Image 
When you know that your PDF is going to be reproduced on a black-
and-white printer, or if the size of your PDF file is too large because of 
all the color images in it, you can resample the images to change their 
color depth and resolution. 

To resample an image, click the image with the Edit tool and choose 
Edit > Resample Image. The Resample controls appear at the bottom 
of the document window (Figure 79). 

Figure 79: Reduce the resolution and color depth of an image 
with the Resample controls. 

Here are the resampling actions you can take: 

•	 Type a different DPI value: Lower values make the image 
appear blurrier but reduce how much storage the image requires. 
(Higher values have no visual effect but increase the storage re-
quirements.) 

•	 Change the compression type: Here’s what the choices on the 
pop-up menu mean: 

‣	 Color JPEG Compression: This is the standard format for color 
PDF image objects in PDFpen. 

‣	 Grayscale: Grayscale will make your image look like a black-
and-white photo. 

‣	 1-Bit Threshold: Every pixel in the image that is more than 50% 
gray is made white and all the others black, creating a silhouette 
effect. 
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‣	 1-Bit Dither: Black-and-white dot patterns simulate levels of 
gray; the resulting image has less detail and resembles a low-
resolution fax. 

Note: Grayscale uses less storage space than color, and 1-bit images 
use the least storage. 

•	 Choose a quality percentage: This pop-up menu is available 
only for Color JPEG and Grayscale compression. Generally, the 
higher the quality percentage, the more storage space the image 
requires. Reducing the percentage can make a color or grayscale 
image look dithered or banded, but saves storage space. 

Click Resample to have your settings take effect; click Resample Entire 
Document to apply the settings to every image in the document. 

Tip: Unfortunately, the Resample controls don’t give you a preview
 

of how they effect the image, but you can choose Edit > Undo Edit 

Image if the results are not to your liking.
 

Compression and Image Adjustments 
PDFpen and PDFpenPro, starting with version 12 incorporate new 
compression technologies that produce smaller PDFs and all the PDFs 
you make with PDFpen benefit from these technologies automatically. 
But what about existing PDFs? 

With PDFpen and PDFpenPro, when you use the Edit > Deskew and 

Adjust Image command on an image, or when you use the Edit >
 

Resample Image command, the new compression technologies are
 

applied. In most cases, you’ll end up with a smaller PDF as a result.
 

Make a Transparent Image 
PDFpen can select a color or color range in an image and “knock it out” 
so that any objects behind the image on the page can be seen through 
the knocked-out holes. This is exactly what you need when you make 
a signature to use on forms (see Add a Scanned Signature), and it is 
useful for decorative purposes, such as for creating a border on a page. 
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You can knock out a color range in an image to make it transparent in 
three quick steps: 

1. With the Edit tool, click the image and choose Edit > Make
 
Transparent Image.
 

2.	 In the dialog that appears, click the eyedropper on the color you 
want to knock out (Figure 80), and then slide the Tolerance slider 
until the image shows the desired transparency (Figure 81). 

Figure 80: This image is about to have the sky knocked out. 

Figure 81: Excuse me while I lose the sky... 

3.	 Click Make Transparent. 
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Colors that fall within the range you specified disappear, and anything 
on the page behind the image can be seen through the no-longer-
visible parts of the picture. 

Tip: When you select an image, shortcut buttons for deskewing,
 
cropping, adjusting, resampling, and making transparent images 

appear on the Editing Bar—if the window is wide enough to display
 

them.
 

Add a Watermark 
You may have some documents that are not in final form or are confi-
dential and need to have their pages marked accordingly, and others 
that need to display some sort of corporate or organization brand. 
PDFpen gives you watermarks to satisfy that need. Watermarks are 
non-editable images that appear behind the other elements on a page, 
such as the stamp shown in Figure 82. 

Figure 82: This page of a novel-in-progress has a purple watermark 
swimming under the text. 
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You can turn either a text imprint or an image into a watermark, and 
the watermark can appear on all of a PDF’s pages, or a range of pages, 
or just a selected page. 

To create a watermark, do the following: 

1.	 Go to any page where a watermark should appear. 

2.	 Place an image, draw something with PDFpen’s drawing tools, or 
create a text imprint on that page. 

3.	 Scale and format the item so it is the right size, but don’t worry 
about orienting it. 

4.	 Select the item you placed if it is not already selected, and then 
choose Edit > Watermark > Convert to Watermark. The Convert to 
Watermark dialog appears (Figure 83). 

Figure 83: This dialog turns the item you placed on a page into a 
watermark. 

5.	 In the dialog, specify the pages on which you want the watermark to 
appear. 

6.	 Optionally, use the “Apply to” pop-up menu to put the watermark 
on every page in the range, or only on odd or even pages. 
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7.	 Use the Opacity and the Rotation pop-up menus to choose the 
watermark’s opacity and the angle at which the selected item should 
be rotated when it is converted. 

8. Click Apply. The watermark appears on the pages you specified. 

You can remove a watermark from any page or range of pages: 

1.	 Select the thumbnails of the pages from which you want to remove 
the watermark in the sidebar (see Navigate with the Sidebar) 

2.	 Choose Edit > Watermark > Remove Watermark from Selected 
Pages. 

Note: Although adding watermarks is relatively speedy process, even 
over hundreds of pages, removing watermarks from many dozens of 
pages at once can take a lot of time—sometimes many minutes. Be 
patient. 

Rearrange, Rotate, and Crop Pages
 

When you create a PDF out of bits and pieces of other PDFs (see 
Combine Existing PDFs), you may want to adjust the pages that you’ve 
brought together. For example, a page may consist of a full-page 
graphic and need to be rotated from landscape to portrait orientation, 
or a range of pages may need to be reordered, or some legal-size pages 
may need to be cut down to letter size. 

PDFpen can help you with all those tasks. 

Rearrange Pages 
The Thumbnails sidebar and your preferred pointing device are the 
tools you need to rearrange pages in a PDF: 

1.	 Choose View > Thumbnails to show the Thumbnails sidebar if it 
isn’t already visible. 

2.	 Drag the thumbnail of the page you want to move to its new location 
in the sidebar. 
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As you drag the thumbnail, a black line appears to the right of each 
thumbnail you pass over, indicating, were you to drop the dragged 
thumbnail at that moment, that the page would be placed at that point. 

Note: To move a page to the very beginning of the PDF, drag to the
 

left of the very first thumbnail.
 

Tip: You can widen the Thumbnails sidebar to see more thumbnails 
at once, which is helpful when you need to do a lot of rearranging. 

But suppose you need to move a small group of pages to a new location 
in a very long PDF. Dragging could become tedious. The following 
steps explain how to do big moves over long distances in a PDF: 

1.	 In the Thumbnails sidebar, Shift-click or ⌘-click to select the pages 
you want to move. 

2.	 Choose Edit > Cut. 

3.	 Scroll to the thumbnail of the page after which you want place the 
pages you’ve cut, click it, and then choose Edit > Paste. 

The pages appear following the page you clicked. 

Note: If you need to move a selection containing multiple pages a
 

short distance, you can drag them just as you do a single page.
 

Rotate a Page 
When a page doesn’t match the orientation of the others in a PDF 
document, hilarity can ensue when the document is printed. Some 
programs, like PDFpen, can automatically rotate such pages, but not 
everyone (yet) uses PDFpen. A recipient of your PDF might have a 
program that crops the disorientated page to fit when it prints. 

145
 



       

            
            

  

     

         

           
 

          
  

          
           

        
    

      
        

          
      

To reorient a disorientated page, follow these steps: 

1.	 Navigate to the page that is oriented differently from the others. An 
easy way to find such pages is by viewing them in the Thumbnails 
sidebar (Figure 84). 

Figure 84: One of these thumbnails is not like the others. 

2.	 Click the page and then do one of the following: 

‣	 To rotate the page 90 degrees clockwise, choose View > Rotate 
Right (⌘-R). 

‣	 To rotate the page 90 degrees counterclockwise, choose View > 
Rotate Left (⌘-Shift-R). 

Which direction depends on your needs (and maybe the direction in 
which your head tilts best), but, in either case, the page is reoriented. 

Note: If you select multiple page thumbnails, PDFpen applies the
 

Rotate command to all of them.
 

Tip: If your document has pages where the text is rotated so that it’s 
vertical, and you need to edit that text, temporarily rotate the page 
to make the text horizontal before you edit. Although you can select 
and correct vertically oriented text on a page, it can be awkward. 
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Crop a Page 
As common as 8½-by-11 pages are in the United States, not everyone 
uses pages with those dimensions, and, when it comes to PDFs that are 
to be printed in a book or pamphlet, the page dimensions can differ 
significantly. 

When you have a PDF that must be cut down to size, PDFpen can help: 

1. Navigate to the page you want to crop. 

2. On the Editing Bar, click the Select Rectangle  tool. 

3. On the page, drag to select the proper dimensions. 

As you drag, the current dimensions of the selection rectangle
 
appear along its sides (Figure 85).
 

Figure 85: This page is getting a much-needed trim. 

Tip: You can change the units used to display dimensions—say, from 
typographer’s points to inches—in PDFpen > Preferences > Editing. 

4. Choose Edit > Crop Page to Selection. 

The page is cropped to the dimensions you chose. 

147 



          
       

      

     

            
           

            
           

        

    
       

         

Tip: Hold down the Option key to change the menu command to 
Crop Document to Selection. This crops every page to the same 
dimensions and is handy when you want to crop an entire document. 

Add Headers, Footers, and Page 
Numbers 

After you have changed and rearranged the pages in your PDF as 
described elsewhere in this chapter, you may want to put page num-
bers, headers, or footers (or all three) on its pages. PDFpen has a 
command for that: Edit > Headers, Footers, Page Numbers > Insert. 
This command opens the dialog shown in Figure 86. 

Figure 86: This dialog configures how PDFpen puts headers, footers, 
and numbers on pages. Use the Advanced Options to specify the 
range of pages to be affected and whether to include a page total. 

148
 



             

          
          

 

          
           

            

          
            
             

         
          
          

              
               
             

   

             
   

        
            

         
            

          
            

       

The dialog is divided into four parts. The function of each part is as 
follows: 

•	 Position: Use this two-item pop-up menu to specify whether the 
element you are inserting goes at the top (Header) or bottom (Foot-
er) of each page. 

•	 Page Numbering: This checkbox and its related settings let you 
specify whether PDFpen inserts a page number, where on the page 
top or bottom the page number appears, and the format of the 
number. 

•	 Header/Footer Text: You use this group of settings to specify the 
content of header or footer text, the typeface and size in which it 
appears, and where at the top or bottom of the page the text ap-
pears. 

•	 Advanced Options: Use this to create a more complex page 
number layout and more completely control the pages on which the 
inserted material appears. I explain these options in more detail 
below. 

Keep in mind that you can use this command several times for a given 
PDF, and there are times when you will want to do so: once to specify 
page header text, once to specify page footer text, and once again to 
specify the page numbering. 

Here are explanations of some of the less obvious items in the Page 
Numbering section of dialog: 

•	 Inside, Outside: These options appear on the Alignment pop-up 
menu and are useful when the PDF will be printed double-sided and 
bound. When you choose Outside, page numbers appear aligned 
with the right margin on recto pages (pages on the right in bound 
books) and with the left margin on verso pages (the left-hand pages 
in bound books). Inside places the number on the left for recto 
pages and on the right for verso pages. 
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Tip: Choose View > Facing Pages when using the Inside or Outside 
setting to see what it does; you can always choose Edit > Undo 
immediately after issuing the Insert Page Numbers command if its 
results are not what you want. 

•	 Bates Numbering: This option, found on the Format pop-up 
menu, is a numbering system often used for legal and business 
purposes. With this kind of numbering, each page of the document 
is given a unique page identifier, for example “Exhibit 5A00034”. 
You supply a prefix for the page number and the number of digits 
to be used for the page number in the two fields that appear. 

Following the Page Numbering section is where you specify page 
header or footer text. Whether you insert a header or footer depends 
on your choice in the Position pop-up menu. You can specify as many 
as three different texts to appear in a header or footer: one at the 
center of the header/footer area of the page, one at the left side of the 
area, and one at the right side. 

The text positions you can specify for the header or footer texts change, 
however, when you choose to insert a page number and also choose 
either Inside or Outside from the Alignment pop-up. In either case you 
can add center text, but you can then specify only one other text item: 
either at the inside edge of the page (if you have chosen Outside for the 
page number location) or at the outside edge (if you have chosen 
Inside for the page number location). 

The Advanced Options (shown in Figure 86, a page or so back) give 
you additional control over where and how the headers, footers, and 
page numbers appear: 

•	 Template: Use this option to add text to the page numbers and 
to show the total number of pages, such as “Page 3 of 70”. This 
option is dimmed if you have not chosen to insert page numbers. 
You can choose one of the supplied numbering templates as-is from 
the pop-up, modify one of the templates, or make your own from 
scratch. 
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Click # to insert &[Page] in the template, which resolves to the 
current page number; click ## to insert &[Pages], which resolves 
to the total number of pages in the PDF. You can also add your 
own text. For example, Page &[Page] of &[Pages] wonderful pages 
produces a page number like “Page 3 of 70 wonderful pages”. 

•	 Insert from Page/To Page: Enter the page number in the Insert 
from Page field on which you want your headers, footers, or page 
numbering to start, and enter the page number on which you want 
them to end in the To Page field. 

•	 Margin Positioning: Use these advanced settings to specify how 
far from the left and right edges of the page to place headers and 
footers. The Vertical setting controls how far from the top or bottom 
edge of the page headers and footers appear. The measurement 
units are in points. 

Note: When you use the default Vertical setting of 0 for Margin
 

Positioning, you can see the PDF’s headers and footers on screen;
 

however, it may be beyond the capability of some printers to print 

content that close to the edge of the page.
 

When you click Insert, PDFpen creates native text objects containing 
the texts and numbers you have specified on each page of the PDF 
starting from the page specified in the Insert from Page field in the 
Advanced Options and ending on the page entered in the To Page field; 
by default, all the pages in the PDF are included unless you specify 
otherwise. 

Tip: Because the command inserts native text objects, you can use
 

the Precision Edit 
 tool to remove these times from individual
 
pages, such as pages between chapters in a book that you want to
 

appear completely blank.
 

PDFpen remembers whether you have inserted headers, footers, and
 
page numbers and where you have placed them, so if you choose the
 
command again and make different settings in the dialog, any previ-
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ously placed headers, footers, or page numbers that conflict with your 
new settings are removed before the new items are placed in the PDF. 

You can also manually remove any headers, footers, or page numbers 
you have previously placed: use the Edit > Headers, Footers, Page 
Numbers > Remove Page Header (or Page Footer) command to strip 
them from your PDF. 

Note: The native text objects inserted by the Edit > Headers, Foot-
ers, Page Numbers > Insert command are not dynamic: they won’t 
automatically update if you later change the PDF’s pagination. 

Multiple Sections and Header/Footer Tip 
Sometimes a long document might have sections, each requiring 
custom page numbering, headers, and footers. Although PDFpen’s 
Headers, Footers, Page Numbers dialog doesn’t provide functionality 
for handling such documents, you can work around that relatively 
easily. Use the techniques described in Combine Existing PDFs to 
make each section into a separate PDF document and then use the 
Edit > Headers, Footers, Page Numbers > Insert command on each 
document. Then, simply combine those documents into a single 
document again. 

Create Links
 

Sometimes you want to direct your readers to a different page in a 
PDF, or to a webpage that has useful information; for yourself you 
might want to link to another PDF document on your Mac. In fact, if 
you are reading this book in PDF form (and many of you are), you have 
already seen, and probably used, some of the page and URL links that 
appear within it. 

Unlike HTML links, which are attached to text or objects on a web-
page, the links you create in PDFpen consist of transparent rectangular 
objects that you place on top of some text, an image, or, in fact, any 
area of the page that you want to link to another location. 
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As I described in The Markup Tools (←oh, look: a link!), there is a tool 
for creating links: the Link annotation tool. 

You can move and reshape link objects with the Edit  tool. You can 
also change their appearance: by default, PDFpen makes them com-
pletely transparent with no border stroke, but you can change that with 
the object property tools on the Editing Bar (see Draw Attention). You 
may, in fact, want to give link objects a stroke or a semi-transparent fill 
color because, otherwise, they are impossible to see once you have 
created them! 

Tip: To test a link object after you create it, click it with the Select 

Text 
 tool. 

To link to another page in the current PDF, do the following: 

1. Choose Tools > Link (⌘-9), or choose the Link annotation tool 
from the toolbar’s Annotation tools pop-up menu. 

2. With the Link annotation tool, drag a rectangle over the text, 
image, or page region that you want to link to another page in the 
document. 

3.	 In the Set Link dialog that appears (Figure 87), click Page, enter a 
page number in the Page Number field, and then click OK. 

Figure 87: With this handy dialog you can set Page, URL, or File 
links. 
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When you set a page link and then add pages to the document so that 
the page to which you linked moves, the page link still works. For 
example, if you set a link on page 1 to go to page 4, and then you add a 
page between pages 1 and 4 so that page 4 becomes page 5, the link on 
page 1 still works as intended, taking you to page 5. 

Warning! If you manually move a page after you place page links on 
it, its page links are deleted. 

Note: If you accidentally specify a page in the Set Link dialog that 
does not exist in the document, PDFpen assigns the link to the page 
number of the last page in the document. 

A URL link, when clicked, opens a web browser (usually the default 
browser on the device displaying the PDF), and loads the webpage 
pointed to by the link. 

You add a URL link that goes to a web address like this: 

1. Choose Tools > Link (⌘-9), or choose the Link annotation tool 
from the toolbar’s Annotation tools pop-up menu. 

2. With the Link annotation tool, drag a rectangle over the text, 
image, or page region that you want to link to a web address. 

3.	 In the Set Link dialog, click URL at the top of the dialog, enter a web 
address in the URL field that appears, and then click OK. (Partial 
URLs do not work. For example, if you enter smilesoftware.com in 
the Set Link dialog, the URL link does nothing when clicked. 
However, https://smilesoftware.com does open your browser and 
load the page at that address.) 

The process of creating a link to a PDF file on your Mac is quite similar 
to those for creating Page or URL links; in fact, first two steps are 
identical: choose the Link annotation tool and then drag out a rec-
tangle where you want the link to go. Only the last part of the process 
is different: 

1. In the Set Link dialog, click File. 
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2.	 Click the Browse button, and then, in the file dialog that appears, 
navigate to the PDF file you want the link to open and click Select. 

3.	 Optionally, in the dialog’s Page Number field, specify the page on 
which you want the linked PDF to open; page 1 is the default. 

4.	 Click OK. 

Note: A link to another PDF is specified in relation to the location on 
your Mac of the PDF you are currently editing. If you subsequently 
move either of these documents, the link will cease working. 

How to Edit Links 
All three kinds of links use the same Set Link dialog. You can change 
a link object from one kind to the other by clicking Page, URL, or File 
in the segmented button near the top of the dialog. 

To change the link destination of a link object, double-click it with the 
Edit tool and enter a new location in the Set Link dialog. 

Make Links Automatically (Pro Feature) 
If you have a PDF document that has URLs in its text (such as take‐
controlbooks.com or support@example.com), you can choose Edit > 
Create Links from URLs to place link objects over them. To edit a link 
object, double-click it with the Edit tool. 
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Make an Interactive PDF 
Form (Pro Feature) 

“You can talk all you want […] But you gotta know the territory!” 
chants a salesman in the first scene of The Music Man. But how do 
you get to know the territory? 

You ask questions, that’s how. 

One way to ask questions is with a form. PDFpenPro has tools for 
making interactive PDF forms. With these tools, you can ask questions 
to get the information you need. And, with the email and web submis-
sion capabilities that you can build into a form, you don’t have to go 
out to the territory to get that information—it comes to you. 

So, you can talk, you can talk, you can bicker, you can talk, but with 
an interactive form, you can get to know the territory. 

Build a Form
 

A form can be as simple as a single checkbox, or as complicated as 
an IRS Schedule C. But, as you saw in Fill Out PDF Forms, all forms 
consist of only a few simple elements—such as text fields and check-
boxes. You can use these elements repeatedly and in combination. 

Tip: If all you need are checkboxes and text fields in your form, you 
can create a form almost automatically; skip ahead to Let PDFpenPro 
Build Your Form. 

I’ve made a form that demonstrates each form element available in 
PDFpenPro (Figure 88). In the following pages, I use my example 
form, “Wizard_Tim.com User Survey,” to explain each form element. 
I started with a new blank one-page PDF (see Create a PDF), but you 
can add form elements to any PDF. 
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Figure 88: The Wizard Tim needs to know a few things, and he uses 
this form, which contains each form element available in PDFpenPro, 
to learn them. Heck, it’s less work than casting a spell. 

You access the tools that create specific form elements from the Form
 
tools pop-up menu (described in The Form Tools (Pro Feature)).
 

Each individual form element has a group of properties you can set in
 
the Inspector to name the element and describe how it operates. As we
 
proceed, I’ll explain the properties associated with each form element.
 

One Form per PDF 
Unlike webpages, which can have multiple forms on a single page, 
you can have only one interactive form in a PDF made by PDFpenPro. 
Another way to think about it is that the PDF is the form. 

Make a Text Field 
The Name field in Wizard Tim’s form represents that staple of the 
interactive form, the text field. Use a text field when you want free-
form information from your respondents that you can’t anticipate. 
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To make a text field, drag it out on the page with the Text field  form 
tool. 

Once you have the field in place, you set its properties in the Form 
Element Properties tab of the Inspector (Figure 89). 

Figure 89: The Inspector shows the properties of a text form field. 

To see a field’s properties, click it with the Edit tool (if you use the 
Select Text tool, PDFpenPro assumes you want to enter information 
into the field). 

Here is some advice for customizing the properties of a text field: 

•	 Name: Every text field should have a distinct name. PDFpenPro 
gives each new field a unique name, but you should change it to 
reflect the type of information in it. As you can see by the size of the 
Name field in the Inspector, names are expected to be short. 
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Note: Good element names are important. When you receive form
 

data from an interactive form, the name of the element labels the
 

data from that element. A short, descriptive name can help you
 

interpret the data you get back more easily.
 

•	 Default Value: This property can be empty. If you put text in it, 
that text appears in the form element as its default value, although 
the respondent can change it; if you leave the Default Value blank, 
the element is empty until the respondent fills it in. 

Tip: To check the default value of a form element as you are building 
the form, choose Edit > Reset Form. 

•	 Tool Tip: Text entered into this property appears as a tool tip when 
the user’s pointer hovers over the form element; in addition, screen-
reading assistive tools, such as VoiceOver, speak tool tips. Use this 
property to add a short description of the text element’s purpose. 

•	 Character Limit: You can enable this and then specify the maxi-
mum number of characters the respondent can put in the field. For 
example, you might limit a field for a telephone area code in the 
United States to three characters. When this property is disabled, 
respondents can type only as many characters as will fit in the field 
visibly unless Scroll Text or Size to Fit is enabled (see below). 

•	 Required: Select this checkbox if the field must be filled in before 
the form is submitted. Most programs that allow respondents to fill 
out PDF forms display an error dialog if a required field is empty 
when the respondent submits it. 

•	 Multi-line: When this property is enabled, text typed in the field 
can wrap when the text reaches the edge of the field. 

•	 Size to Fit or Scroll Text: If you select one of these boxes and the 
other is already selected, the other is automatically deselected: 

‣	 Select Size to Fit if you want text the user enters scaled in size so 
that it fills the field. The text that the respondent types becomes 
smaller once the field’s boundaries are reached. 
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‣ Select Scroll Text to allow text to scroll past the field’s borders. 

Note: Both Size to Fit and Scroll Text can be unchecked. In that 
case, the field can hold only as much text as can fit within its borders 
at the field’s default text size. 

Tip: Should you create a text field with specific customizations that 
you want to reuse, you can add that text field to The Library and drag 
out a copy any time you want to use it. 

Offer a Single Choice 
A choice element allows the respondent to choose one item from a 
set of items. In PDFpenPro a choice element resembles a drop-down 
menu, such as the Quest item shown in the survey (Figure 88, a few 
pages back), although other PDF programs may display a choice 
element quite differently. A choice element can optionally allow the 
respondent to type in an item that isn’t among those provided. 

To place a choice element on the page, drag with the Choice  tool. 

Note: You can drag a rectangle as tall and as wide as you like when 
placing a choice element, but the visual components of the element 
have a fixed height, so any extra space above or below it on the page 
is wasted space on the form. 

Use a choice element when you have several mutually exclusive choices 
to offer and a limited amount of room in which to present them. 
Figure 90 shows the properties associated with the choice element. 
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Figure 90: You can add and remove choice element properties. 

You can modify these choice element properties: 

•	 Name: Each choice element requires a unique name. As with the 
text-field element, enter a short descriptive name so you can identi-
fy the data when it is returned. 

•	 Tool Tip: This text appears when the user’s pointer hovers over the 
element, and is read aloud by screen-reading assistive software such 
as VoiceOver. 

•	 Required: Enable this property if the respondent must make a 
choice before submitting the form. 

•	 Custom Text: Select this to allow the respondent to type in a 
choice that doesn’t appear among those that you have provided. 
A choice element that allows custom text shows a text cursor when 
the respondent clicks the body of the element; the respondent must 
click the arrow controls at the right of the element to display the 
choices you have offered. 
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•	 Name-Value box: Recall that a choice element offers the user 
a list of choices. Name-Value pairs supply those choices. Click the 
Add button to add an empty Name-Value pair, and then click the 
selected pair in the list box to add a name and a value. The name is 
what the user sees and can choose in the choice element; the value 
is the data returned when the form is submitted. For example, in 
the choice element whose properties are shown in Figure 90, 
earlier, if the respondent chooses To Storm the Castle Anthrax, the 
form will return the value of Castle. 

If you don’t supply a value, the name is returned. In such cases, you 
may want to use short names. 

To remove a Name-Value pair, select it and then click the Remove
 button. 

Make Checkboxes 
The data from checkboxes is returned only when a respondent checks 
a box on the form; you never receive data from unchecked boxes. 

You use checkboxes to provide a respondent with what amounts to a 
true-false question. For example, in Wizard Tim’s survey (Figure 88, 
back a few pages), the Knights checkboxes allow the user to answer 
the implied question “Is this knight accompanying you?” for each listed 
knight (Brave Sir Robin must have turned his tail and bravely fled 
when the form was filled out). 

Click with the Checkbox form tool to create both a default-size 
checkbox and a label (a text imprint) for it. Or, you can instead drag 
with the Checkbox form tool to create a checkbox that has a custom 
size. To edit the label text, use the Select Text  tool. 

The properties of a checkbox element from the Wizard’s survey are 
shown in Figure 91. 
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Figure 91: Checkboxes return a value only when checked. 

You can customize the following checkbox properties: 

•	 Name: Each checkbox should have a unique name; if two or more 
checkboxes have the same name, they behave like radio buttons (see 
the section about radio buttons, just after this list), which violates 
normal user-interface conventions and can confuse the respondent. 
The best practice is to use the same name as the one in the checkbox 
label, or a shortened version of it. 

•	 Checked Value: By default, the value returned from a checked 
checkbox is TRUE, but you can use a different value if you have a 
special need. 

•	 Tool Tip: This field can contain a brief description of the check-
box’s purpose that appears when the user’s pointer hovers over the 
element, and is read aloud by screen-reading assistive software such 
as VoiceOver. 
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•	 Required: Enable this property if the respondent must check 
the checkbox before submitting the form. Unless you are using 
the checkbox like a radio button, you should leave this property 
disabled. 

•	 Check by Default: Enable this property to have the checkbox 
checked when the form is first opened or when it is reset. 

•	 Style: Your choice here determines what mark appears when the 
checkbox is selected. It is a good practice to use the same style for 
all the checkboxes in a group. 

Offer Radio Button Choices 
In Wizard Tim’s survey (Figure 88, shown near the start of this 
chapter), the Favorite Colors are presented as radio buttons. Radio 
buttons offer a small set of mutually exclusive choices. When the user 
clicks a radio button in a group, the other buttons in the group are 
deselected. It’s good user-interface practice to restrict the number of 
radio buttons in a group to five items or fewer. 

Click with the Radio Button form tool to create both a default-size 
radio button and a text imprint label. You can drag with the tool to 
create a radio button that has a custom size. 

When you add a radio-button group, you should add an additional text 
imprint with the Text annotation tool to label the entire group, as 
Wizard Tim does in his survey. You can use that label, or a shortened 
form of it, as the Name property for each of the radio buttons in the 
group. For example, the name of the three Favorite Color buttons in 
Wizard Tim’s survey is Color (Figure 92). 
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Figure 92: All radio buttons in a group share the same
 
Name property but have different Checked Value properties.
 

You need to set at least the first two of these radio-button properties: 

•	 Name: Each radio button in a button group should share the same 
name so that clicking one deselects the others that share that name. 

•	 Checked Value: The best practice is to use a short version of the 
text that labels the individual button. If the form is submitted with 
this radio button selected, the name assigned to the button group 
will return the value in this field. Although all buttons in a group 
must have the same Name property, they should each have a differ-
ent Checked Value property. 

•	 Tool Tip: Use this to add a brief description of the radio button 
that appears when the user’s pointer hovers over the element; it can 
also be read aloud by screen-reading assistive software such as 
VoiceOver. 

165
 



          
           
             

              

          
             
           

              

            
            
              

 
             
             
           

     

               
           

        
         

      

                
             

           
      

•	 Required: Enable this property if the respondent must select one 
of the buttons in the radio-button group before submitting the form. 
If you enable this property for one button in the group, you should 
enable it for all buttons in the group, since they are treated as a unit. 

•	 Check by Default: Enable this property to have the button appear 
selected when the form is first opened or reset. You should set this 
property for only one button in the group, because, by convention, 
no more than one radio button in a group can be selected at a time. 

•	 Style: Click a style to set the radio button element’s appearance. In 
most cases, the default appearance is best, but if you choose another 
style, make sure that all the radio buttons in the group use the same 
style. 

Make a List 
You use a list element to display a list of items from which the respon-
dent can choose. Wizard Tim uses a list element to list the supplies 
that the respondent possesses in the survey form shown near the 
beginning of this chapter (Figure 88). 

A list can allow the respondent to select only one item, or it can allow 
the respondent to select multiple items by Shift-clicking a range of 
adjacent items, or by ⌘-clicking non-contiguous items (Windows 
users can Control-click to choose non-contiguous items). Wizard Tim’s 
list allows multiple items to be selected. 

Use the List form tool to drag a rectangle out on the page. If the 
number of items is longer than can be displayed within the list’s area, 
the respondent can scroll through the list. Figure 93 shows the list 
element’s properties from the Wizard Tim’s survey. 
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Figure 93: List element properties resemble choice element proper-
ties, but you can select more than one choice. 

You can set the following properties for a list element: 

• Name: Each list element requires a unique name. 

•	 Tool Tip: Give a brief description of the list’s purpose that users 
can see when hovering their pointers over the element, or can be 
read aloud by screen-reading assistive software such as VoiceOver. 

•	 Required: Enable this property if the respondent must select at 
least one item before submitting the form. 

•	 Select Multiple: Enable this to allow the respondent to choose 
more than one item in the list. 

•	 Name-Value box: I explain this box in more detail a few pages 
earlier where I describe the choice element (see Offer a Single 
Choice). As with a choice element, you use Name-Value pairs to 
supply the list element with content. The Add button and the 
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Remove button work the same way as they do in a choice ele-
ment’s properties. And, like choice elements, if you don’t supply a 
value in a Name-Value pair, the name is returned as the value. 

Make an Interactive Signature 
An interactive signature allows respondents to sign an interactive form 
by hand. When respondents click the field, a dialog appears in which 
they can scribble their signatures using a trackpad, stylus, or similar 
pointing device (they can even use a mouse or a trackball if they are 
sufficiently dexterous)—or they can drag a signature graphic (see Add a 
Scanned Signature) directly into the interactive signature dialog, as in 
Figure 94. This form element also provides users with the capability 
of applying a digital signing certificate; see Apply a Signing Certificate. 

Figure 94: Sign an interactive signature field with your finger, 
or drag a graphic into the field’s dialog. 
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To create an interactive signature field, drag out a rectangular area 
on the form with the Signature form tool. The field has markers 
at each corner to indicate the field’s dimensions, and it includes a 
graphic “Sign Here” stamp. When the respondent signs the field, the 
stamp goes away and the signature appears within the field’s bound-
aries. The submitted form includes the signature graphic. 

The Inspector provides no properties that you can set for interactive 
signature fields. However, you can set the color of the signature and 
the thickness of the signature stroke with the Signature color and 
stroke  controls at the bottom-left of the signature field 
dialog. 

Make a Submit Button 
Respondents use a submit button to send the information on the form, 
and, optionally, the form itself back to the form’s originator; e.g., you. 
The Wizard Tim’s survey shown near the beginning of this chapter 
(Figure 88) has such a button at the bottom, but you can put it 
anywhere you like. 

Tip: In fact, you can have multiple submit buttons in the same PDF,
 
and each can be designed to send the form content to a unique
 

destination, which could be useful for allowing the user to choose
 

which of several people should receive the form content.
 

With the Button form tool, click the page to create a default-size 
submit button or drag to create a button with a custom size. 
PDFpenPro displays a dialog with submission options (Figure 95). 
Use the options to specify the destination for the form’s data. 
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Figure 95: Send the form’s data to either an email address or 
a web address. The web address should point to a script that 
can process the form’s data, as the built-in example implies. 

The form can be set up to submit data by email to a specific address or 
via the web to a specific URL: 

•	 In the case of email, you can choose whether the PDF is included; 
the XFDF form is always attached (XFDF is a forms data XML 
format, the full name of which is XML Forms Data Format). The 
message is sent with the respondent’s default email program. 

•	 When a form submits data to a URL, it is sent as XFDF data. 

Note: You can find out more about XFDF from ISO, which currently
 

curates the format.
 

If you later want to edit the submission options, double-click the 
submit button with the Edit tool, or access the submission options in 
the button’s form element properties in the Inspector (Figure 96). 
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Figure 96: The submit-button element’s properties include
 
a name, a label, and the submission options.
 

Aside from the submission options, the other properties you can set 
are minimal: 

•	 Name: Like any other form element, the submit button needs a 
name. It should be a unique name within the document. 

•	 Tool Tip: Supply text that explains what the button does; the text 
appears when the user hovers the pointer over the button, and is 
read aloud by screen-reading assistive software such as VoiceOver. 

•	 Label: Enter the text you want seen on the button. 
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About Forms Processing 
You can find scripts for processing form data, and get additional 
information, at Smile’s website. In addition, I suggest you consult the 
advanced topic in PDFpenPro’s Help, Backend Processing of PDF 
Forms. 

Also, you can use the Export Form Data script that comes with
 

PDFpen to see the values that are returned from a form (see The
 

Scripts).
 

Let PDFpenPro Build Your Form 
Very often, all you need on a form are text fields and checkboxes; this 
is especially true of forms that are designed to be printed and filled out 
by hand but that could also be filled out on screen. PDFpenPro’s Create 
Form Fields command is perfect for such forms. 

For example, consider the word processing document shown in 
Figure 97, a job application that contains only lines and checkboxes. 
It can be saved as a PDF (see Print to PDF) and brought into 
PDFpenPro, where the static form elements can be brought to life. 

Figure 97: To use the Create Form Fields command, you can start 
with a form created in a word processor (in this case, Apple’s Pages) 
and save it as a PDF. 
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To turn the static form elements on the current page into interactive 
elements, choose Edit > Create Form Fields for Page. 

Tip: To turn static form elements into interactive ones throughout 
a multipage document, hold down Option and choose Edit > Create 
Form Fields for Document. 

Figure 98 shows the result of running the Create Form Fields for 
Page command on the PDF created from the document in Figure 97. 

Figure 98: This is a portion of the “automagically” created 

form, along with the Inspector showing one element’s details.
 

PDFpenPro examines the PDF for line and box elements and uses 
those to generate interactive form elements that overlay the static 
ones found in the PDF. PDFpenPro proceeds from left to right and 
top to bottom so that in most cases the tab order for the created 
elements matches what most users will expect, but if it doesn’t produce 
the tab order you want, you can change it (see Set the Tab Order). 

In addition, PDFpenPro turns on highlighting of form fields when it 
creates a form automatically so that the newly created elements are 
immediately obvious. You can turn form highlighting on and off by 
choosing View > Highlight Form Fields; this command works with 
forms that you create by hand and with automatically generated forms. 
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Tip: You can mix things up, too: begin by using a word processor 
to give you a running start when creating a form, generate the initial 
form elements automatically with PDFpenPro, and then add any 
additional form elements you need with the PDFpenPro form tools. 

Polish the Layout
 

It’s not hard to slap a bunch of form elements on a page, but you’ll get 
more responses and better ones if you design the form so that it is easy 
to read and use. At the very least, you should align the elements neatly 
and label them so that the respondent can see which elements go 
together, and so that they can figure out what information is actually 
being requested. The controls on the Inspector’s Alignment tab can 
help you align form elements (see The Inspector). 

Use a Grid 
To further help you precisely line up form elements, labels, and any 
other explanatory text, you can turn on a grid overlay and specify that 
new items, and dragged items, should snap to that grid (Figure 99). 

Figure 99: The grid is visible behind this application form. 

To turn on the grid and have items snap to it, do the following: 

1. Choose Arrange > Show Grid. 

2. Choose Arrange > Snap to Grid. 
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Use Guides 
By default, PDFpen and PDFpenPro automatically present you with 
visible guidelines to help you align objects (Figure 100). 

Figure 100: Guidelines appear when the button object is dragged 
near the center and bottom of the signature field above it. 

How the guides appear depends on the type of object: 

•	 Text objects: As you drag a text object, it displays guidelines that 
align the baseline of the object’s text with the baseline of other text 
on the page. 

•	 Other objects: When you drag a non-text object, guidelines 
appear that help you align the center or edges of the object with the 
centers or edges of other objects on the page. 

You can choose Arrange > Snap to Guides to have a dragged object 
snap to a guideline as it appears. 

Tip: When Snap to Guides is turned on, hold down Command as you 
drag to temporarily disable the snapping action. 

Should you find the guides distracting, you can turn their automatic 
appearance off: go to PDFpen > Preferences > Editing and uncheck 
Show Guides. 

Set the Tab Order 
You should also consider that people with keyboards often prefer to 
navigate without having to resort to a pointing device. PDFpenPro 
creates a tabbing order for form elements automatically. The person 
filling out the form can press the Tab key to “tab” from one form 
element to the next without reaching for a pointing device. 
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The tab order by default follows the way you read English: left to right, 
top to bottom. 

You can see the tab order, change it, and, if necessary, reset it so it 
follows the left-to-right, top-to-bottom convention again, with the 
following commands on the Arrange menu: 

•	 Show Tab Order: Small number boxes are superimposed on each 
element (Figure 101) so you can see the order in which you can tab 
through them. 

Figure 101: Display the tab order to see where tabbing takes you. 

•	 Move Forward: Increase the selected element’s position in the 
tabbing order by one. 

•	 Move Backward: Decrease the selected element’s position in the 
tabbing order by one. 

•	 Move to Front: Make the selected element the final one in the 
tabbing order. 

•	 Move to Back: Make the selected element the first one in the tab-
bing order. 

•	 Reset Tab Order: Set the tab order to follow English reading 
convention. 

An even easier way to arrange your form elements is to use the sidebar. 
This method works best if you have given your form elements easily 
identifiable names. 

To arrange form elements with the sidebar, choose View > Form Fields 
or choose Form Fields from the Sidebar pop-up menu. The 
sidebar displays the form elements in your PDF in their current tab 
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order (Figure 102), and you can then drag them into the order you 
desire. 

Figure 102: You can drag form fields into a different tab order with 
PDFpenPro’s Form Fields sidebar. 

Note: Changing a form object’s position in the tab order does not 
change the object’s position on the page. 
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Publish Your PDFs 
A PDF that’s on your hard drive only is a lonely thing: it wants to go 
out into the world and meet people. It was born to go out into the 
world. If you love your PDFs, let them go. 

You can make your PDFs public (because that’s what “publish” means 
in the broadest sense) in many ways, including: 

• Emailing them
 

• Posting them on the web
 

• Printing them on your printer
 

• Sending them to a professional print service
 

• Sending them to your publisher as camera-ready copy
 

With the exception of printing them on your printer, all of these start
 
with saving or exporting your PDF in one way or another.
 

So let’s start there, too.
 

Save or Export Your PDFs
 

When you create or modify a PDF with PDFpen, sooner or later you 
are going to save it. You may not notice that you are saving it: by 
default, saving is automatic in PDFpen. That is, you can create a new 
PDF in PDFpen, edit it, quit PDFpen, and when you open PDFpen 
again, the untitled-but-edited document reappears even though you 
never explicitly saved it (unless you’ve enabled Ask to Keep Changes 
When Closing Documents in System Preferences > General). 

Nonetheless, just because PDFpen saves documents automatically 
doesn’t mean that the traditional command, File > Save, has gone 
missing. It’s still around, and it is key to some saving options. 
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Here’s a brief summary of how saving works in relation to auto-save: 

•	 Closing a new untitled document: When you attempt to close 
a new PDF you’ve made with PDFpen, you are asked to name the 
document, choose a location for it, and set some saving options 
(which I describe in just a little bit). 

•	 Saving a new document: When you choose File > Save (⌘-S), 
you get to name the document, specify where it gets saved, and set 
the options I describe below. 

•	 Saving a previously saved document: When you choose File > 
Save (⌘-S), PDFpen saves the document as a separate version to 
which you can later revert. No dialog or options are presented. To 
go back to a previous version of the document, use File > Revert To 
and choose the version you want. 

•	 Using Save As with a previously saved document: To save 
a copy of the document with a new name and in a location of your 
choice, use the File > Save As command (⌘-Option-Shift-S): to 
access the command, hold down the Option key as you open the File 
menu. You also get to set your saving options, described just below. 
When you complete this command, PDFpen saves and closes the 
current document and creates a copy, with its new name, for you to 
keep working on. 

•	 Using Duplicate with any document: Choose File > Duplicate 
(⌘-Shift-S) to create and open an untitled document with the same 
content as the one on which you were working; the original docu-
ment remains open. Closing the duplicate elicits the same Save 
dialog that you see when you close a new untitled document. 

No matter how you reach a Save dialog, the options it presents are 
these: 

•	 Encryption: You can secure your PDF at one of several levels 
of encryption so it can’t be casually opened. See Save Securely for 
more about this capability, as well as its limits. 

•	 Quartz Filters: You can apply a Quartz filter as you save (if you 
don’t know what a Quartz filter is, read Save with Quartz Filters). 
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Furthermore, you can save optimized copies of PDFs to conserve 
space, as described next in Save Optimized PDFs. 

In addition to saving, you can export your PDF to different formats, 
using the File > Export command in PDFpen and PDFpenPro: 

•	 Images: You can export the pages in the PDF to image documents 
(see Export as TIFF, JPEG, or PNG). 

•	 Microsoft Word: This export option converts your PDF into the 
Word document format (.docx). See Export to Microsoft Formats. 

•	 Plain Text and Rich Text: These options export only the textual 
contents of a PDF. Plain Text strips off all formatting; Rich Text 
retains characteristics like size, typeface, and typestyle. 

•	 Flattened PDF: This option turns any text imprints, highlights, 
and drawn objects you have added into native PDF objects so that 
they are no longer editable as separate objects. 

Users of PDFpenPro can export documents in these additional 
formats: 

•	 Microsoft Excel and Microsoft PowerPoint: These two 
export options require a fully licensed copy of PDFpenPro and the 
PowerPoint export requires an Internet connection. See Export to 
Microsoft Formats for details. 

•	 PDF/A: This PDF format is optimized for archival storage, and 
requires that PDF documents embed all the components, such as 
fonts, necessary to faithfully reproduce them. The Wikipedia article 
on PDF/A describes it more completely; PDFpenPro currently 
exports into the PDF/A-1b version of the archive format. Note that 
PDF/A export requires an Internet connection and a licensed 
version of PDFpenPro. 

Finally, you can save your PDFs from PDFpen by printing them; see 
Save with the Print Dialog. 
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Save to Evernote 
PDFpen has yet another alternative Save command, one that you
 

might not be familiar with: File > Save to Evernote. Evernote is 

a cloud-based service that stores notes, photos, and documents,
 
including PDFs. If you use this service, the Save to Evernote feature
 

is very convenient; log in at this URL to enable the capability and 

to find out more: https://www.evernote.com/Registration.action?
 

code=pdfpen.
 

Save Optimized PDFs 
Way back in A Peek at What Is Inside we learned that PDFs can con-
tain graphic images as well as text, and in Use a Scanner to Make a 
PDF we saw how to make scanned graphics into PDFs. However, 
pictures of text take up much more storage space than actual text, and, 
often, when we scan documents to make PDFs, we’re more interested 
in using OCR to turn the scanned text in those documents into search-
able, editable text (see Use OCR on Scans and Graphic Files) than we 
are in how pretty the scanned text looks on screen. 

A case in point: I scan the receipts I get when shopping, and add 
searchable PDFs made from those scans to my checking account 
register. I like a high-quality scan because it produces better results 
when I perform OCR on a receipt, but once the OCR is done, that high-
quality scan inside the PDF takes up a lot of storage space. It would be 
nice to get some of that space back. 

And that’s where the File > Create Optimized PDF command comes in. 
Choose it and PDFpen offers the dialog shown in Figure 103. 
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Figure 103: Your options when you choose to create an optimized 
PDF. 

As you see, most of what this command does is resample image objects 
within a PDF to produce more compact versions. It deals with color, 
monochrome, and grayscale image objects separately (see Resample an 
Image for more information on the differences between these types of 
objects). 

For each type of object, you can reduce the resolution to save space, 
which can produce a blurrier, if more compact, image. In addition, you 
can set these two options for grayscale and color images: 

•	 Format: You can choose between Leave as is, Lossy (JPEG), and 
Lossless (ZIP). Lossy works upon bitmapped image objects that 
support various levels of quality, such as embedded JPEG images. 
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•	 Quality: For image objects that support quality settings, you can 
choose from six quality settings, from Highest to Lowest. The lower 
the setting, the less faithful each image object will be to the original 
but the more compact it will be. Note that choosing Lossless as the 
Format disables the Quality settings. 

Note: Monochrome image objects, which include both 1-bit dithered 
images and 1-bit threshold images, have no Format nor Quality 
settings; only the resolution of those objects is affected by optimiza-
tion. 

When you run the command, you get a new, untitled PDF containing 
the newly optimized images—in most cases: if optimization doesn’t 
save any space, and if you have checked “Optimize images only if it 
saves space,” no new PDF is produced. Otherwise, PDFpen tells you 
how successful the optimization was (Figure 104). The original PDF 
is left intact. 

Figure 104: PDFpen tells you how much space was saved following 
an optimization pass. 

And what about the option “Remove third party metadata”? When that 
is checked, optimization removes other information stored within the 
PDF. Many PDF applications store additional information in the 
documents they create, such as image thumbnails or extra data to help 
those applications edit the documents. With this option enabled, 
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PDFpen removes such information. Don’t worry though: the metadata 
you want to include, visible and editable in the Document Information 
tab of The Inspector, is left intact—PDF optimization doesn’t touch the 
keywords, title, author, and subject metadata you intentionally pro-
vide. 

Export as TIFF, JPEG, or PNG 
PDFpen can save a PDF in several different image formats, which I 
describe below in About the Image Formats. When you export a PDF to 
an image format, usually each page of the PDF becomes a separate 
image document, and all of the image documents are saved in a folder 
with the name you specify. The exported image documents have names 
like Page 0001.jpg and Page 0027.png. 

Note: The TIFF format supports single multipage image documents,
 
which is an option you can choose when you export to that format.
 

Here are a few points you should keep in mind when you export a PDF 
to an image format: 

•	 Images are not text: When you save a PDF as an image, you can 
no longer select its text to copy or edit it. That’s because the text 
becomes just a picture of text. As with any image, you would need 
to perform OCR if you want to convert the picture of text into 
editable text again. Needless to say, PDF features like notes and 
tables of contents don’t survive the format conversion either. 

•	 Images can be bulky: Text, even text stored in a PDF along with 
its font information, is almost always much more compact than full-
page images. For example, a 27-page plain-text typescript I happen 
to have on hand makes a 74 KB PDF file, but a 170 MB uncom-
pressed TIFF file. Even a compressed TIFF file of that manuscript 
requires 7 MB: nearly 100 times the size of the PDF version. 

•	 Images may have size limits: The TIFF standard supports a 
maximum file size of 4 GB. While that might seem like a lot, re-
member what you just read above—TIFF files are bulky. It is quite 
possible to reach this limit when saving a book-length PDF as a 
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multipage TIFF file. Similarly, while the JPEG format supports a 
maximum image size of four gigapixels, which likely is more than 
most individual PDF pages may require, some applications that 
handle JPEGs can have lower limits than that. 

The image format exports have several options in common, and I 
describe those next. 

Choose the Color Mode and Resolution 
Each of the image export formats supports several color modes: 

•	 Color: This export mode preserves all the colors in the original 
PDF. 

•	 Grayscale: This choice removes the document’s color, converting 
the various hues of the original into shades of gray. This mode 
produces a smaller image document than Color mode. 

•	 1-bit: This mode removes color and brightness information, so that 
darker colors become completely black and lighter colors complete-
ly white. This mode is good for plain text documents that you intend 
to fax or photocopy and produces the smallest image document. 

Note: 1-bit color mode is not available for JPEG exports. 

You can also specify the resolution of the exported image documents. 
The higher the resolution you choose, the sharper the resulting images 
are, but also the larger the exported document file size. 

You can choose from these four resolutions: 

•	 600 dpi: Use this when you need to send a document to a print 
service, and the print service wants to deal only with plain un-
adorned image files and doesn’t want to hassle with fonts and all the 
other stuff that can make printing other people’s files so much 
excruciating fun. 

•	 300 dpi: This resolution is also an adequate choice if you need to 
print the image document. A resolution of 300 dpi isn’t all that 
high, of course—modern home laser printers snicker at it, and it’s 
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an even lower resolution than that of the iPhone Retina display— 
but it’s high enough that all but the most eagle-eyed will find it nice 
and sharp. 

•	 Fax, 200 dpi: Use this when fax quality is good enough. If you 
need to send a document via fax, this is the perfect resolution in 
which to store it. 

•	 Web, 72 dpi: This choice produces the most compact image files, 
and is quite good enough for viewing online. Just don’t expect to 
magnify a page beyond its normal size without seeing lots of fuzzy 
pixels. 

About the Image Formats 
The three image export formats that PDFpen supports each have their 
own particular strengths and weaknesses. The following descriptions 
can help you decide the best one to choose for your specific needs. 

JPEG 
This format is named after Joint Photographic Experts Group, which 
created the standard. It is a “lossy” image format, in that it compresses 
the image data by removing information, and the amount of compres-
sion used affects the amount of data lost. JPEG files compressed at the 
highest quality can look indistinguishable from the original image; 
lower quality compression settings can make the colors less sharp and 
the image details less clear. 

PDFpen exports PDF pages as very high quality JPEG files. 

PNG 
Portable Network Graphics format supports lossless images; compres-
sion is obtained by controlling the palette of colors used to render the 
image along with some advanced algorithms. PNG does not support 
the CMYK color space used for printing, but, instead, is optimized for 
being reproduced on digital screens. 

TIFF 
TIFF, the aged and venerable Tagged Image File Format, has been a 
standard for almost a century and a half—on the planet Mercury, that 
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is; on Earth it’s been around for about a third of a century. As you 
probably already know, TIFF is widely used as a standardized way of 
storing image files that almost any image application worthy of the 
name can open. 

As I mentioned above, TIFF can store multi-page documents, in which 
each “page” is a TIFF image. If you need to convert your document to 
an image, or set of images, but keep it all in a single file, this option is 
for you. 

TIFF does support the CMYK color space used for printing, and so is a 
good choice for images destined to be printed. 

Export to Microsoft Formats 
Yes, as Edit a PDF makes abundantly clear, PDFpen is fully capable 
of editing PDFs. However, you’ll never confuse PDFpen for a word 
processor, nor are PDFs, as you learned way back in Learn about PDF 
Files, designed with editing in mind. Nonetheless, sometimes a PDF 
needs more extensive editing than is feasible in PDFpen. Or maybe 
you need to extract the contents of a PDF to use in a word processing 
document, spreadsheet, or presentation. 

When you choose File > Export, the Export To menu in the dialog 
offers a Word file format choice. If you use PDFpenPro, you also see 
two other Microsoft format choices: one for Microsoft Excel, and one 
for PowerPoint. 

Here’s what the choices mean: 

•	 Word 2007 Document (DOCX): Choose this to export the PDF 
as an editable Microsoft Word document. This conversion is per-
formed locally and does not require an outside service or an Inter-
net connection. The option is available in both PDFpen and PDF-
penPro. 

•	 Excel 2007 Spreadsheet (XLSX)—Pro Feature: This export 
format is intended for documents that consist primarily of spread-
sheet-like data; that is, rows and columns of text and numbers. Like 
the Word export option, it doesn’t require an Internet connection or 
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an outside service. Unlike the Word option, however, it is only
 
available in PDFpenPro.
 

•	 PowerPoint 2007 Presentation (PPTX)—Pro Feature: This 
format works best for PDFs that consist of landscape-oriented pages 
each containing a few items in large type, and with a background 
image or color. The exported files can also be opened in Apple’s 
Keynote app. The PowerPoint export option requires an Internet 
connection and PDFpenPro: PDFpenPro securely transmits your 
PDF to the Nuance OmniPage Cloud Document Conversion Service 
for conversion. 

Note: Smile provides more details about PDFpen’s and PDFpenPro’s 

Microsoft format exports on its Word Export page, along with exam-
ples and tips for using the export options.
 

Depending on the size of the PDF to be converted, this can take only 
a few seconds or several minutes. The app presents a dialog showing 
how long it estimates the conversion will take. Although you can work 
on other PDFs while conversion is occurring, you cannot work on the 
document being converted until the process concludes. 

Note that the conversion process, while quite good, is not perfect: 
between the complex internal structure that PDFs can have, and the 
ways in which the Microsoft apps lay out their documents, you proba-
bly won’t end up with an exported document that looks exactly like the 
original PDF. Nonetheless, the results are usually remarkably good. 

Is Submitting PDFs to an Outside Service Safe? 
In this case, the answer is “pretty safe”—the conversion service uses 
a secure connection for transmitting and receiving files, deletes its 
copy of the PDF as soon as the conversion is complete, and retains 
the converted copy for only 12 hours. The service is also used by 
many legal firms, and you know how picky lawyers can be. 
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Save Securely 
The PDF standard supports file encryption that you unlock using a 
password as the decryption key. This user password, in theory, pre-
vents anyone without the password from opening the PDF. In practice, 
of course, PDF encryption can be cracked by those with the right tools 
and the determination. Nonetheless it’s still worthwhile to apply a user 
password to a PDF that you don’t want just anyone to be able to open. 

In PDFpen’s Save dialog, you can choose a level of encryption ranging 
from None to Strongest. This last, obviously, is the hardest to crack, 
but is also the least compatible with older PDF-viewing software. 

If you choose an encryption level higher than None, you then give the 
file a user password (twice, for verification purposes). From that point 
on, each time you try to open the file, you must provide the password— 
but more to the point, anyone else who tries to open the PDF file must 
enter it, too. (The topic of how best to share a password for gaining 
access to sensitive documents is beyond the scope of this book.) 

Warning! Choose a good password. A 2- or 3-character password 
is easy to crack; a 16-character password with upper- and lowercase 
letters, symbols, and numbers is much more difficult. Not that the 
NSA might not be able to crack it, given time, but it should be good 
enough for all but the most security-minded users. Just don’t forget 
it, or you are out of luck! (For much more about passwords, check 
out Joe Kissell’s Take Control of Your Passwords.) 
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Protect Your PDFs (Pro Feature) 
The PDF standard offers permission controls that can, for example, 
restrict users from printing or editing a PDF. The standard version 
of PDFpen respects the permission controls on PDFs that it opens, 
but it provides no capability to apply them to new PDFs. However, 
the Inspector’s Document Permissions tab in PDFpenPro (Figure 
105) does allow you to apply permission controls to a PDF; these 
permissions can be overridden only by supplying an owner password 
(as distinct from the encryption-related user password described just 
previously). 

Figure 105: You can set any combination of these permissions. 

For example, if you set a PDF’s permissions to prohibit printing, 
others can still open your PDF, but when they try to print it, they’ll 
first have to enter the owner password—without it, they can only 
view it onscreen. (And note that if you permit high-res printing, 
others can make an unprotected copy by choosing to Print to PDF.) 

Alas, just about every lock has a locksmith, and you can readily find 
programs for sale that can strip permission restrictions from a PDF 
blithely. However, just because someone can smash in a locked door 
is no reason to prop the door open: if you need to set ground rules 
for how a given PDF is to be used, the Document Permissions feature 
in PDFpenPro gives you that capability. 

190
 



   
             

          
       

         
      

          
             

             
            

        

           

        
           
             

             
            

      

          
           

         
            
            

      

            
    

         
             
            

             
  

Save with Quartz Filters 
Quartz is the name Apple uses for one of the key graphics services 
of macOS. Quartz has several separate components for different 
purposes—onscreen compositing of animation, for example—but the 
Quartz 2D component is tailor-made for dealing with PDFs. In fact, 
Apple originally based Quartz itself upon PDF. 

Because of the close relationship between PDF and Quartz, developers 
can create filters that modify the look or structure of a PDF document 
in various ways. I won’t detail all of the available Quartz filters as 
there’s no telling which ones you have on your Mac (anyone can make 
a Quartz filter with the ColorSync utility that comes with macOS). 

However, here are a few standard ones that you might find useful: 

•	 Black & White: This filter removes all color information, leaving 
you with a grayscale document in one simple step. You might use 
it if your document will be printed on a grayscale device. See Re-
sample an Image for more about grayscale. 

•	 Reduce File Size: This reduces the quality of all images in the file 
to medium-quality JPEG. If you need a smaller file more than you 
need highest quality images, use this filter. 

•	 Create Generic PDFX-3 Document: PDF/X is a subset of the 
PDF specification, designed to facilitate the use of PDFs in pre-print 
environments. Among other things, the format specifies that the 
document must embed all of the fonts that are used within the 
document. (If you want to know more about PDF/X and its reason 
for being, you can start with the summary by Laurens Leurs.) 

I encourage you to explore the Quartz filters—on copies of files, of 
course: never, ever experiment with originals! 

Warning! Although Quartz and PDF are closely related, saving a file 
with a Quartz filter can result in some data loss. In particular, if you 
have a table of contents in your PDF, a Quartz filter discards it. Also, 
you can’t save a file with a Quartz filter and secure the file with a 
password at the same time. 
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Save with the Print Dialog 
There’s one somewhat unusual way to save your PDF that doesn’t 
involve a Save command on the File menu: you can choose File > Print, 
and then click the PDF button at the lower left of the Print dialog. This 
button pops-up a menu of PDF-related choices (Figure 106). 

Figure 106: The Print dialog provides many choices under the 
PDF button. 

The menu shown in Figure 106, above, almost certainly doesn’t look 
like yours beyond the first three standard items. The other items are 
workflows, automated tasks you can create with Automator, a stan-
dard part of macOS. 

Tip: You don’t need to use the Send in Mail workflow in the Print 
dialog’s PDF menu to email a PDF from PDFpen. Instead, you can 
choose File > Mail Document to attach your PDF to an email message 
in your default email program. 

Warning! Saving a PDF with a workflow strips annotations and tables 
of contents from the PDF. 
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Workflows can end up in this menu in several ways. One way is when 
you run an application that installs its own workflows; another way is 
for you to run an installer that adds them. 

The Open with PDFpen workflow, for example, can be installed with 
the free Install PDFpen Workflow app that you can download from 
Smile. Once you’ve installed the workflow, it’s available on the 
Print dialog’s PDF menu in other programs on your Mac. Building 
a Numbers spreadsheet that you want to turn into a PDF and modify 
with PDFpen? Print the spreadsheet and choose Open in PDFpen from 
the PDF menu: in seconds your spreadsheet is in PDFpen, available 
for editing. 

Where Are Workflows Stored? 
The workflows that appear on the PDF menu are stored in one of two 
locations. One location is in your Home folder’s Library: ~/Library/ 
PDF Services. That’s where the Install PDFpen Workflow app puts its 
workflows. The other is /Library/PDF Services. 

As always when it comes to a Library folder—either your Home 
folder’s Library or the main Library for your Mac—don’t mess directly 
with the files in it unless you know what you’re doing. Really, I mean 
it. I’m watching you. 

Automator has a special template for creating PDF workflows that 
appear in the Print dialog: Print Plugin. This workflow receives PDF 
files from the print system and performs the Automator actions on it 
that you specify. Automator has a number of actions designed to act 
upon PDFs. 

To add workflows you’ve created with Automator to the Print dialog’s 
PDF menu, choose the Edit Menu command at the bottom of the 
PDF pop-up menu. Use the dialog that appears (Figure 107) to add 
Automator workflows or to remove any workflows you don’t want. 

193
 

https://pdfpen.com/PDFpen/workflow/
https://pdfpen.com/PDFpen/workflow/


        
        

            
        

              
         

       

Figure 107: Add or remove workflows from the PDF menu in the 
Print dialog here. Choose Edit Menu from the dialog’s PDF menu to 
bring it up. 

Print Your PDFs
 

Earlier in this book, in Print Notes and Comments, I described the 
note- and comment-related print options PDFpen offers. Figure 108 
shows all the PDFpen options in the Print dialog (you may have to click 
a Show Details button in the dialog to reveal them). 

Figure 108: In PDFpen, choose File > Print to access these options. 
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Most of these options require no explanation, or I’ve already described 
them elsewhere (for example, Automatically Adjust Printing 
Orientation for Best Fit comes up in Rotate a Page). But Print Imprints 
Only deserves a little discussion. 

In Fill Out a Non-Interactive Form I described how to place text and 
images (such as check marks and signatures) on a form in a PDF. The 
text and images you create to do that are imprints (recall that any text 
objects, graphic objects, or images you add to a PDF with PDFpen are 
imprints). If, for some reason, you need to print that information on 
a pre-printed form (for example, the form may include a watermark 
or other security features), you can load that pre-printed form in your 
printer and use the Print Imprints Only feature to have PDFpen print 
only the imprints contained in the PDF file. A specialized feature, I’ll 
grant you, but for those who need it, a very useful one. 

Tip: You might also find the Append Annotations Summary option 
useful. When it’s checked, PDFpen adds one or more pages to the 
printed output with a list of all the annotations and imprints you have 
added to the PDF, including each imprint PDFpen creates when you 
correct text in the PDF. You also have the option to print just the 
summary. 
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Use PDFpen in iOS and 
iPadOS 

If you’ve read the rest of this book, you should have a pretty good 
idea of what PDFpen can do on a Mac. You’ll be pleased to know 
that PDFpen for iPad & iPhone provides most of the same PDF-
manipulating capabilities as its Mac sibling. However, the first time 
you open PDFpen for iPad & iPhone, you’re likely to say, “Hmm… 
this looks…different!” 

Of course it does. Any app rebuilt for a mobile device you control 
with your fingertips—instead of with a traditional pointing device 
and keyboard combination—can’t help but undergo a sea change 
into something rich and strange. Nonetheless, the rich and strange 
app you see really is PDFpen. After a few minutes with it you’ll 
recognize your old friend in its new guise. 

Much of what I’ve said about PDFpen elsewhere also applies to PDF-
pen in iOS and iPadOS, and throughout this chapter I refer you to the 
relevant sections of this book for those details. This chapter addresses 
the two most common concerns that people have upon first diving into 
the strange richness of PDFpen for iPad & iPhone: where to find tools 
and commands (discussed just below) and the various ways you can 
Get PDFs in and out of PDFpen in iOS and iPadOS. 

Note: My descriptions of PDFpen for iPad & iPhone are based upon
 

version 6.0.2.
 

Find Tools and Commands
 

Because screen real estate is limited on iPads, and even more so on 
iPhones and iPod touches, you won’t see an ever-present toolbar or 

196 

https://smilesoftware.com/cgi-bin/redirect.pl?product=pdfpen-ios&cmd=itunes&version=3


           
         

          
           

             
              

    

        
       

   

            
             

      

          
         

  

           
           

          

             
             

          

          
                 

         

             
          

Editing Bar in PDFpen for iPad & iPhone. Instead, these both come 
and go depending on whether you need them or not. 

Take the toolbar: although PDFpen for iPad & iPhone displays its 
toolbar (Figure 109) when you open a PDF, just tap the screen and 
it goes away. It remains hidden as you page through the PDF so 
you can see as much of the document as possible. To bring the toolbar 
back, tap the screen again. 

Figure 109: The toolbar in PDFpen for iPad & iPhone hides when 
you don’t need it (top, the iPad toolbar; bottom, the more compact 
small-screen version for iPhone). 

Similarly, the Editing Bar, and, for that matter, all the other controls 
and options in PDFpen for iPad & iPhone, show up when you need 
them and go away when you don’t. 

In addition, the multi-touch interface in PDFpen for iPad & iPhone 
provides some gestures that affect the way you interact with docu-
ments and objects: 

•	 Zooming: Instead of a View menu, you use the standard pinch and 
reverse pinch gestures to zoom in and out. Also, a quick double-tap 
on a zoomed-in page zooms out to show the whole page. 

•	 Selecting: Instead of clicking an object to select it, you tap it. To 
select text, you touch and hold a word briefly until it is selected, and 
then drag the selection controls to extend or reduce the selection. 

•	 Scrolling: Rather than use scroll bars or page-up and page-down 
keys to go from page to page, you swipe left to go to the next page in 
a document and right to go to the previous page. 

With those general tips out of the way, read on to find out where 
PDFpen for iPad & iPhone has stashed its tools and commands. 
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Navigation Tools 
You can find the navigation tools on the left side of the toolbar (see 
Figure 110). 

Figure 110: The navigation tools live on the left side of the toolbar. 

Here’s a brief description of what these tools provide: 

• Back : Tap this icon to save the current document and return 
to the Documents screen. Read the next section, Get PDFs in and 
out of PDFpen in iOS and iPadOS, for more about accessing docu-
ments. 

• Undo : Use this icon to undo the most recently performed 
change. You can tap multiple times to undo a series of recent 
changes. Why is this classed as a navigation icon? It makes sense if 
you think of it as providing a way to travel back through time. 

• Show Sidebar and Hide Sidebar : These icons appear 
only on the iPad. Tap Show Sidebar to reveal The Sidebar, with 
its thumbnails that you can tap to move quickly through a docu-
ment. Tap Hide Sidebar to dismiss it. Though you don’t have 
these icons on the iPhone, you do have a sidebar—swipe right from 
just beyond the left edge of the screen to show it and drag the 
sidebar to the left to hide it (these gestures also work on the iPad). 

• Thumbnails : Tap this to see thumbnails, with page numbers, 
of the pages that comprise your entire document. The Thumbnail 
view is powerful; I describe it next. 
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Thumbnail View 
At its simplest, the Thumbnail view (Figure 111) is an easy way to get 
to any page in your PDF quickly: just tap the thumbnail of the page you 
want to view. 

Figure 111: Tap a thumbnail in Thumbnail view to go to that page. 

However, its power is revealed when you tap Edit to see its various 
editing options appear on the toolbar (Figure 112). 

Figure 112: The Thumbnail view editing options give you control 
over the pages in your PDF. 

With the editing options visible, you can select one or more thumbnails 
by tapping them, and then drag selected pages to move them in the 
document. You can also do the following with selected thumbnails: 

• Delete pages: Tap the Delete icon to remove the pages corre-
sponding to the selected thumbnails; then confirm the deletion. 
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•	 Rotate pages: By tapping the appropriate icon you can flip select-
ed pages 180 degrees ( ), 90 degrees clockwise ( ), or 90 degrees 
counterclockwise ( ). 

You can add a page to your document—either blank, lined, with a 
graph-paper grid, or from a photo in your device’s Photos collection— 
by tapping the Add icon and then tapping an option in the popover 
that appears. New pages are added to the end of the PDF. You also 
have the option of duplicating the selected pages in the Thumbnail 
view, or creating a new document from them. 

Note: The Add icon also appears in the main Thumbnail view, 
allowing you to add new pages to your PDF without first tapping Edit. 

Tap Done to dismiss the thumbnail-editing toolbar and return to the 
main Thumbnail view. Then, to return to viewing and working on 
individual pages in your document, tap the thumbnail for the page you 
want to view or work on next. 

The Sidebar 
The sidebar in PDFpen for iPad & iPhone provides four different ways 
of navigating your PDF (Figure 113). Tap an icon at the sidebar’s top 
to change what it displays. Tap an item in the sidebar to navigate to 
that item in the PDF. 

Figure 113: Tap an icon at the top of the sidebar to change what 
it displays. 
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Here are the four sidebar views: 

• Thumbnails: Tap the Thumbnails icon to see numbered page 
thumbnails. 

• Search: Tap the Search icon to see a search field at the top of 
the sidebar. Type in the search field to see a list of hits. 

• Table of Contents: A tap of the Table of Contents icon dis-
plays the top-level headings of the PDF’s table of contents (if it has 
one). Tap the information icon to the right of a heading to see 
its subheadings. 

• Annotations: Tap the Annotations icon to list the annotations 
you have made in the PDF. An icon to the left of each entry tells you 
what kind of annotation it is (Figure 114). 

Figure 114: The icon beside each annotation listed in the sidebar 
indicates the type of annotation; listed here is one highlighted 
phrase and one note. 

Editing Tools and Other Commands 
The editing tools—and many of the other commands you know from 
PDFpen on the Mac—can be found by tapping the buttons on the right 
side of the toolbar (Figure 115). 
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Figure 115: The right side of the toolbar is where many tools 
and commands live. 

The toolsets, in left-to-right order, are the Highlight tools, the Drawing 
tools, and the Text tools. These are followed by the Library (see The 
iOS/iPadOS Library Popover), and the Tools icon; this last produces a 
popover containing an assortment of commands (see The iOS/iPadOS 
Tools Popovers). 

Tap any of the first three icons to bring up the Editing Bar, which 
shows the tools in the currently selected toolset along with tool-specific 
options (see The iOS/iPadOS Tool Options). To close the Editing Bar, 
tap the Close icon that appears at its right. 

Note: To conserve screen space, the Editing Bar on the iPhone shows 
only the current tool icon; tap it to access a popover showing the 
other tools in the currently selected toolset. 

The iOS/iPadOS Highlight Tools 
The Highlight tools comprise a set of tools similar to the ones de-
scribed in Highlight Text: a Highlight Text tool, an Underline 
tool, a Strikethrough tool, and a Squiggle  tool. 

Tap the Highlight tools icon to see the Editing Bar with the most 
recently used Highlight tool selected (Figure 116). 

Figure 116: The Highlight tools appear on the Editing Bar with 
the most recently used tool selected (here, the Highlight Text 
tool is selected). 

The iOS/iPadOS Drawing Tools 
The Drawing  tools (Figure 117) are made up of tools that corre-
spond to those described in The Draw Tools along with the Scribble 
tool described in The Markup Tools. 
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Figure 117: The Drawing tools offer similar capabilities to those 
offered by their Mac counterparts. 

Like the Highlight tools, when you tap the Drawing tools icon, the 
Editing Bar shows the most recently used Drawing tool selected. 

The iOS/iPadOS Text Tools 
The Text  tools (Figure 118) correspond to four of the tools de-
scribed in The Markup Tools: a Text tool for creating imprints; a 
Comment tool for creating comment boxes; a Note  tool for 
placing note icons, with their associated pop-up note windows, on the 
page; and an Audio tool for creating and placing sound annotations. 

Figure 118: Use the Text tools to add text imprints, comments, 
notes, and sound annotations to your PDF. 

The iOS/iPadOS Tool Options 
Each tool you select provides one or more tool options that appear as 
icons in the center of the Editing Bar (Figure 119). They are used for 
setting colors, fonts, line styles, and so on. 

Figure 119: The tool options vary by tool. The first three sets of 
options shown above are provided by the Text tool and, starting 
from the left, allow you to choose a font, text color, and line spacing 
and text alignment. The rightmost popover shown above, provided 
by the Comment tool, sets border width and border line style. Not 
shown: the font size popover that appears when you tap the font 
size on the Editing Bar. 
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When you use highlighting tools or the Scribble tool, you may find 
yourself awkwardly trying to avoid accidental touches to the screen 
with your palm or wrist so they don’t leave marks. That’s what the 
Palm Guard is for: tap the left or right edge of the screen to have the 
Palm Guard overlay the screen (Figure 120). Only the open area 
between the top and bottom Palm Guard sections responds to touches. 

Figure 120: The Palm guard is active: only screen touches in the 
unguarded area between the two overlays affect the document. 

To move the protection overlays, drag their up  and down 
arrow icons. 

Note: Palm protection automatically ends after a few seconds of
 
inactivity.
 

A second tool option that appears when you use the Highlight and 
Scribble tools is a repositioning tool. Tap this to allow pinch zoom-
ing and dragging gestures to reposition the PDF on the screen when 
the Highlight and Scribble tools are active; tap it again to return to 
highlighting and scribbling. 

The iOS/iPadOS Library Popover 
Like its Mac siblings, PDFpen for iPad & iPhone offers a Library with 
collections of objects that you can add to a PDF (Figure 121). To see 
the popover, tap the Library icon on the toolbar. The Library’s con-
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tents are similar to those described in The Library, though there are 
some differences. 

Figure 121: The PDFpen Library popover in iOS/iPadOS offers 
features similar to those in the PDFpen Library on the Mac, but there 
are some differences, such as the Photos collection, shown here. 

Note: If you have signed in to iCloud on your Mac and have enabled 
iCloud Drive access for PDFpen or PDFpenPro on that Mac, your 
Library contents sync between your Mac and your iOS/iPadOS device. 

Here’s what you can find in the PDFpen for iPad & iPhone Library: 

• Custom : As on the Mac, this collection contains objects that you 
might want to place on a page in the future: text imprints, graphic 
objects made with the drawing tools, comments, and images. To add 
an object to the Custom collection, select the object in the PDF and 
then tap the Custom collection’s Add icon. Tap Edit to rearrange 
the items in the collection or to delete items from it. 

• Photos : Tap this to browse the Photos library on your iOS/ 
iPadOS device—select a photo to add it to a PDF. Tap the Camera 

icon to take a photo with your device’s camera and add that 
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photo to the PDF. Tap the information icon on the Editing Bar 
when you add a picture to a PDF to adjust its transparency and its 
layer order among any other drawn objects and imprints (annota-
tions like comments and notes always display above such objects). 

• Stamps : In this collection you’ll find the various types of
 
business stamps and stickers as in PDFpen on the Mac.
 

• Proofreading Marks : The proofreading marks in this 
collection mirror the ones available on the Mac; swipe left and right 
to view them all. 

The iOS/iPadOS Tools Popovers 
Yes, popovers, plural. There are two versions (Figure 122): one on 
the Documents screen’s toolbar, and the other on the document editing 
toolbar. Tap the Tools icon on each toolbar’s right side to see it. 

Figure 122: The Tools popover offers different options on the
 
Documents screen (left) and on the PDF editing screen (right).
 

The Tools popover on the Documents screen is where you go to config-
ure PDFpen’s settings (described in The iOS/iPadOS Settings), to 
contact Smile for support, and to view help. 
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Tip: Spend some time with the Help and Video Tutorial options 
available on the Documents screen’s Tools popover if you have 
the chance. 

The Tools popover on a PDF editing screen provides access to 
PDFpen’s settings as well, but the rest of the popover’s offerings 
pertain to the currently open document: 

•	 Share: Here, “share” means to share a copy—tap Share to open 
a copy of the document in other apps; to email a copy; to send a 
copy to a location in iCloud Drive, or to Dropbox, Evernote, the file-
sharing pane for your device in iTunes, and various other remote 
destinations. You can specify whether the copy has editable annota-
tions, which some PDF viewers may not display. 

•	 Print: If your device has access to one or more printers, tap this to 
print the document. You can specify the range of pages to print and 
the number of copies. 

•	 Insert Page Numbers: Although the layout of the dialog is 
different, it provides the same capabilities as the Add Headers, 
Footers, and Page Numbers command on the Mac. 

•	 Encryption: Use this to encrypt your PDF using one of several 
encryption standards, ranging from relatively weak to very strong. 
When you choose to encrypt a PDF, you must specify a password, 
and you must enter that password each time you open the docu-
ment. Keep in mind that some of the available encryption standards 
are incompatible with some PDF viewers; generally, the weaker the 
encryption used, the more compatible the document is with other 
PDF viewers. 

•	 Document Info: Tap this to see the same information provided 
by the Document Information tab described in The Inspector. 

The iOS/iPadOS Settings 
The Settings popover, accessed from either Tools popover described 
just above, provides configuration options for the PDFpen iOS/iPadOS 
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app (Figure 123). It’s also a quick way to find out which version of the 
app is currently installed. 

Figure 123: Use this to set app-wide configuration options. 

Note: The iOS/iPadOS Settings app also has an entry for PDFpen, 
which contains a few switches to permit PDFpen to access your 
device’s features, and, more importantly, where you want the app to 
store its documents, which is described just ahead in Get PDFs in and 
out of PDFpen in iOS and iPadOS. 

Here are the available Settings options: 

•	 Annotation Author: Tap this to enter the name with which your 
annotations are labeled. 

•	 Document Scrolling: This controls the direction in which you 
swipe to move from page to page in a multi-page PDF. 

•	 Scrolling Style: Change between continuous page display and 
paginated when you scroll. 
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•	 TextExpander: If you use Smile’s TextExpander + Keyboard app, 
enable this switch to use your TextExpander snippets with the 
standard iOS/iPadOS keyboard instead of having to switch to the 
custom TextExpander keyboard. 

•	 Update Snippets: If you use TextExpander and make changes to 
your snippets, tap this option to update the snippets available in 
PDFpen to include those changes. 

•	 Stylus: Use this option to set up a third-party pressure-sensitive 
stylus to use with PDFpen. The app supports several such styli (it 
automatically supports the Apple Pencil). 

The iOS/iPadOS Edit Menu 
When you select text or an object in your PDF, a contextual edit menu 
appears above or below the selection (Figure 124). 

Figure 124: The edit menu appears when you select something 
in the PDF. 

The commands available on the menu vary depending on the selected 
item. Typically, but not always, this is where you find commands like 
Copy and Paste. 

Here are some of the other items that might appear on the menu: 

•	 Correct Text: You find this item on the edit menu when text is 
selected. Tap it and you can enter corrections in a new imprint that 
PDFpen creates for you as described in Use the Correct Text Com-
mand. 

•	 Definition: When you select a single word of text, you also get a 
Definition item that, when tapped, looks the word up in your de-
vice’s built-in dictionary. 
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•	 Watermark: When you select a graphic that has been placed in 
the PDF, you get a Watermark item. Choose Watermark place a 
watermark on the pages of the PDF based on the selected graphic. 
You get a popover that provides various layout options for the 
watermark. 

•	 Delete: When you select any item placed in the PDF, you can 
choose this item to delete it. 

•	 Link: Use this to link the selection to another location in the PDF 
or to a URL. 

Tip: Want to remove a Highlight? You can press and hold a highlight 
to select it and then choose Delete from the edit menu to do away 
with it. 

Get PDFs in and out of PDFpen in iOS 
and iPadOS 
Pundits and press have often referred to Apple’s iOS (and iPadOS) as a 
“walled garden” and the metaphor is apt, especially when it comes to 
apps and their documents. The iOS/iPadOS file management system 
certainly does have more walls than the Finder on a Mac, in which 
apps can access documents stored in almost any user folder and where 
users can arrange their documents howsoever they like. But with the 
advent of the Files app and its features, which third-party apps like 
PDFpen can adopt, the walls are much lower than they used to be, with 
plenty of gates and openings in the hedges you can use. 

When you open PDFpen in iOS/iPadOS, if you are not looking at a PDF 
you’re looking PDFpen’s gateway into the iOS file management system 
(which I shall henceforth call the Documents screen), and if you are 
looking at a PDF, a tap of the Back button takes you to that gateway. 

The Documents screen looks and acts very much like the display that 
the Files app uses; if you’re familiar with Files, PDFpen’s Documents 
screen should look equally familiar. 
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Browse Documents in iOS/iPadOS 
From the Documents screen you can navigate among all the locations 
available to your iOS/iPadOS device in which you may have stored a 
document compatible with PDFpen (Figure 125). 

Figure 125: Use the Locations sidebar to navigate to all the loca-
tions on or connected to your device where you may have PDFs 
stored. 

The screen features a Locations sidebar that lists locations in which 
you can open and create documents, and a main pane that presents 
documents at the current location. 

That is, it looks this way in iPadOS: in iOS, a Browse pane occupies the 
whole screen in portrait mode, and you get to the Locations sidebar by 
tapping the Back button at the upper left of the screen until it 
appears, filling the screen; iOS devices also offer a button bar at the 
bottom of the screen with which you can quickly switch from Browse 
pane showing the current location to a Recents view. (I’ll keep calling 
the Locations screen on iOS devices the “Locations sidebar” through-
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out the rest of this section, even though it occupies the entire screen, 
and even though it shows more than just locations.) 

The main pane you see when browsing shows you the documents 
stored at the currently selected location; the location’s name is dis-
played at the top of the pane (in Figure 125 above, it displays my 
iCloud Drive’s PDFpen folder). The gestures you make in this pane are 
familiar: 

•	 To work on a document, tap it. 

•	 To open a folder to see the documents inside, tap it. 

•	 To rename, move, delete, share, or tag an item, touch and hold its 
thumbnail to see a contextual menu of useful commands (Figure 
126). (Note that you can simply drag an item to move it into a 
folder if the folder is visible on the same screen.) 

Figure 126: Touch and hold a document to see a menu of com-
mands that act upon the document. 

•	 To move, share, or delete multiple documents, first tap Select at the 
top right; the commands for handling selected items appear at the 
bottom of the pane. 
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Tip: When you select multiple PDFs, a Join button appears on the 
pane’s toolbar. Tap it to create a new PDF that contains all the 
selected documents. 

A Search field also appears at the top of the main pane. Type in it to 
see documents that match your search string, no matter where they’re 
located. 

To change the currently selected location and view its contents, tap a 
location in the Locations sidebar. Although the location you’ll probably 
use most often is iCloud Drive, you can use On My Device to keep 
documents in the app’s local storage instead of in the cloud. 

No matter what location you are viewing, the toolbar area at the top of 
the main Browse pane contains buttons you can tap to create a new 
document at that location, create a new folder for documents, and 
change the view to an ordered list (Figure 127). 

Figure 127: Use these buttons at the top of the Browse pane for 
creating new documents and folders, and for changing how the view 
is displayed. 

And speaking of locations, you aren’t limited to iCloud Drive and local 
storage on your device: you also have other storage locations available 
to you. These locations can be supplied, often along with apps that 
support them, by third-party vendors, such as Dropbox, Box, or 
Google, or when you connect a compatible USB storage device. Tap the 
More button at the top of the Locations sidebar and then tap Edit 
Sidebar to show or hide any of them and to change their order. 

There is one item in the Locations sidebar that you can’t move or hide: 
Recently Deleted. Tap it to see all the items you have deleted from the 
app over the last 30 days—that is, anything that Apple has a say about; 
third-party developers and server administrators may keep or discard 
items according to their own policies. 

213
 



     
          

        
        

            
           

       

        
        

      

   
               
         

         

            
               

          

       
     

              

A Few of Your Favorite Things 
When you press and release a folder thumbnail in the Browse view 
and then choose Favorite from the menu that appears, iOS/iPadOS 
adds the folder to the Favorites section of the Locations sidebar. Add 
favorite folders to make them easy to navigate to with a tap. (For 
example, I have favorited my PDFpen folder so I can get to it quickly 
no matter what location I happen to be browsing.) 

To remove a folder from the Location sidebar’s Favorites section, tap 
the list’s More button, choose Edit Sidebar, and then tap the
 

Delete
 button beside the folder. 

Tag Documents in iOS/iPadOS 
As on the Mac, you can apply tags to any document, and you can make 
up new tags. To add a tag, follow these steps: 

1. Touch and hold briefly on a document thumbnail, and then release. 

2.	 On the menu that appears, tap Tags (Figure 128). A popover that 
lists all of your available tags appears, as well as a button at the top 
of the list you can tap to create a new tag. 

Figure 128: Tap Tags on this menu to apply existing tags to a PDF 
or to create new tags to apply. 

3.	 Tap one or more tags in the popover’s list to assign them to your 
document. 
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Where Do New Documents Go? 
You may be wondering where newly created documents are stored. 
By default, they end up in PDFpen’s App Library folder in your iCloud 
Drive, just as they always did—that is, if you are using iCloud Drive. 
If not, your files end up in the app’s local storage area on your 
device, or in the currently browsed location. 

And what are App Library folders? They are folders that, in your 
iCloud drive, look just like normal folders, but they can hold only files 
compatible with the associated app—you can’t even drag in an 
incompatible file in iCloud Drive in the Finder. When you use iCloud 
Drive, PDFpen creates an App Library folder. Note, however, that 
since PDFpen allows you to add file attachments, the PDFpen App 
Library allows a wide variety of file types to be dragged into it. 

More Ways to Get at Files 
Even with the rich file management capabilities that iOS/iPadOS 
provides to PDFpen, you may still need to move files from other 
sources into PDFpen, and to send files from PDFpen, to other loca-
tions than those available on the Locations sidebar. 

For that I recommend you consult two short topics from the PDFpen 
online help: Import and How to Export Documents. 
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Appendix A: The PDFpen 
AppleScripts 

PDFpen and PDFpenPro come with a set of useful AppleScripts that 
appear on PDFpen’s AppleScript  menu when you run PDFpen or 
PDFpenPro. You can use and modify these scripts for your needs. They 
perform bulk repetitive actions on one or more PDFs: almost always 
stuff that you could do by hand but which would be tedious and prone 
to error. 

The Scripts
 

To use PDFpen’s scripts, you must first populate PDFpen’s AppleScript 
menu. This menu appears to the right of PDFpen’s Help menu, like 

so: . However, because of Apple security restrictions, it doesn’t 
contain any scripts when you first install PDFpen. 

To add the scripts, choose AppleScript > Populate Scripts Menu. 
You only need to use this command once: the Populate Scripts Menu 
command goes away once you have populated the menu with 
PDFpen’s scripts. The command requires you to specify a scripts folder 
in which to store the scripts, but helpfully shows you where to find it. 

Use the Appropriate Script Menu 
Apple provides a different, black Script menu that can appear
 

among the other systemwide menu icons on the right side of the
 

menu bar; this menu is present in every app if you’ve enabled it 

in Script Editor > Preferences > General.
 

Neither the PDFpen scripts nor the Populate Scripts Menu command 

appear on Apple’s Script
 menu. The AppleScript menu you want 
is next to PDFpen’s Help menu and only appears in the PDFpen app. 
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The following are the scripts that come with PDFpen and PDFpenPro, 
along with some brief notes about what they do and how to use them: 

•	 Combine PDFs: This script combines two or more PDFs into 
a single document. When you run it from the Scripts menu, the 
documents must be on the same volume because the script displays 
an Open dialog in which you ⌘-click to choose the files. 

•	 Cover Fax Header: This script covers up the unwanted header 
of a fax. You can choose the amount of space below the top of the 
page that needs to be covered; you specify how much space is to 
be covered in 1/72-inch increments. The fax header is not actually 
erased, but merely covered with an opaque white rectangle. 

•	 Export Form Data: When you receive an interactive PDF form 
back from someone to whom you sent it, you can use this script 
to get the data out of the filled form. The script exports the data to 
a .csv text file, which can be read by Excel or Numbers. If you know 
your way around AppleScript, you can change the script to export 
the data in a different format (see Where to Find the Scripts). 

•	 Imprint All Pages as First: This places copies of all the imprints 
on the first page of a document on every subsequent page. The 
imprints can be text imprints or graphic imprints; they are placed in 
the same location as the originals on all the other pages. You might 
use this to place a logo or a running header on every page. 

Tip: Although the next two scripts still have their uses, you may want 
to use PDFpen’s capability to Add a Watermark instead. 

•	 Imprint All Pages with Image: This script presents an Open 
dialog so you can select an image file to place on every page. The 
image is centered on each page (unless you modify the script). 

•	 Imprint All Pages with Text: When you run this script, it 
displays a dialog into which you can enter a short piece of text. The 
script creates a text imprint that contains the text you entered, and 
places that imprint, centered, on every page. 

217
 



         
            
            

            
          

      
          
          
        

      
          

            
           

          
            

          
           

           

        
           

             
         

      

         
            

          
           

       

            
              

             
         

              
            

•	 Merge Every Other: This script interleaves the pages from two 
PDFs into a single new PDF. For example, suppose you have two 
PDFs: one with a text in Latvian, and one with the same text in 
French. With the Latvian PDF open, run this script and, in the Open 
dialog that appears, select the French translation. The result is a 
PDF with Latvian-French facing-page translations. Or suppose you 
are scanning a bound book, first scanning the odd-numbered pages 
into a PDF, and then the even-numbered pages. With this script, 
you can put those pages into the proper order. 

•	 Number Pages Using Bates Numbering: Bates numbering is 
a convention used for legal and business purposes, in which each 
page of a collection of documents has a unique page identifier. You 
supply a page number prefix for a document (for example, “Exhibit 
15a”), and the script combines that prefix with a 5-digit page num-
ber, which it places at the bottom left of each page. This script is 
rarely needed for an individual PDF, given the Bates Numbering 
option in PDFpen’s Edit > Headers, Footers, Page Numbers > Insert 
command, but it be useful in workflows to process lots of PDFs. 

•	 Number Pages: Run this script to place consecutive page num-
bers at the bottom left of each page. As with the Bates Numbering 
script described just above, this script is more useful as part of a 
workflow; otherwise, use the Edit > Headers, Footers, Page Num-
bers > Insert command for more flexibility. 

•	 Remove All Imprints: This removes any imprints you’ve added. 
It’s useful if you’ve modified a PDF and saved over the original. 
Keep in mind, however, that any edited text objects become im-
prints, and this script removes them as well, along with any moved 
or resized image objects. Moral: always keep backups. 

•	 Reverse Pages: Run this script to reverse the order of the pages 
in a document. This could be helpful when printing to a printer that 
doesn’t collate properly, or for a document that is to be bound in 
right-to-left reading order (such as a Japanese or Hebrew text). 

•	 Split PDF: Use this script to break a PDF apart, page by page. This 
script creates a new folder with the same name as the current PDF 
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document, but with ƒ appended to the name, and places the folder 
in the directory you specify. The script then puts PDF files in that 
folder, each with a page from the current document. The files have 
the same name as the original document, but with a 5-digit number 
appended. The original document is left intact. 

Where to Find the Scripts
 

If you want direct access to PDFpen’s scripts—say, you want to copy 
them or to view them in the Script Editor when PDFpen isn’t open— 
you need to find them. The PDFpen family of applications stores its 
AppleScripts in a folder in your Home directory’s hidden Library 
folder. The scripts are placed there when you choose the Populate 
Scripts Menu command from the AppleScript  menu. 

Tip: To open your Home directory’s Library folder in the Finder, hold 
down Shift and choose Go > Library. To view the contents of a script 
or change how a script operates, you don’t need to open the hidden 
Library folder: hold down the Option key when you choose a script 
from PDFpen’s AppleScript menu to see the script in Script Editor. 

Where the scripts go in the Library folder depends on which version 
of PDFpen you purchased: 

•	 PDFpen from the Mac App Store: ~/Library/Application Scripts/ 
com.smileonmymac.PDFpen13.MacAppStore 

•	 PDFpenPro from the Mac App Store: ~/Library/Application 
Scripts/com.smileonmymac.PDFpenPro13.MacAppStore 

•	 PDFpen from Smile: ~/Library/Application Scripts/ 
com.smileonmymac.PDFpen 

•	 PDFpenPro from Smile: ~/Library/Application Scripts/ 
com.smileonmymac.PDFpenPro 

•	 PDFpen from Setapp: ~/Library/Application Scripts/ 
com.smileonmymac.pdfpen-setapp 
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Make Copies before Altering Scripts 
It is always a good practice to copy the original versions of scripts 
before you modify them so you can always get back to where you 
started. Sure, Time Machine is a dandy tool for helping you revert 
to previous versions of files, but making a backup of important files 
(and these are important) leaves you doubly protected. 
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Learn More 
Here’s a list of useful websites and ebooks for learning more about 
PDFs and PDFpen: 

•	 Smile’s PDFpen Support and FAQ page: You can find answers to 
common questions, and instructions on how to contact Smile for 
individual support questions. 

•	 Smile’s Help for PDFpen for iPad & iPhone: This PDF, also viewable 
from within the app, is good to have on hand. (Tip: save a copy that 
you can mark up with your own notes and additions.) 

•	 Prepressure.com: Customer support engineer Laurens Leurs main-
tains this site, which specializes in useful articles about prepress 
topics, including PDF. 

•	 The MacSparky Paperless Field Guide: This book contains lots of 
information about going paperless, and it provides even more ways 
to use PDFpen in that endeavor. 

•	 Take Control of Your Paperless Office: This book, by Joe Kissell, is 
the seminal work on paperless PDF workflows. 
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About This Book 
Thank you for purchasing this Take Control book. We hope you find 
it both useful and enjoyable to read. We welcome your comments. 

Sponsored by Smile 

This book was sponsored by Smile. Special thanks for an enjoyable 
project to Philip Goward, Greg Scown, Jacob Gorban, Angel Vu, 
Jonathan Cost, and Jeff Boerner. 

Ebook Extras
 

You can access extras related to this ebook on the web. Once you’re on 
the ebook’s Take Control Extras page, you can: 

•	 Download any available new version of the ebook for free, or buy 
a subsequent edition at a discount. 

•	 Download various formats, including PDF, EPUB, and Mobipocket. 
(Learn about reading on mobile devices on our Device Advice page.) 

•	 Read the ebook’s blog. You may find new tips or information, as 
well as a link to an author interview. 

•	 Find out if we have any update plans for the ebook. 

If you downloaded this ebook from the Take Control website, it has 
been automatically added to your account, where you can download it 
in other formats and access any future updates. 
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Copyright © 2021, Michael E. Cohen. All rights reserved.
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Why Take Control? We designed Take Control electronic books to help readers regain
 

a measure of control in an oftentimes out-of-control universe. With Take Control, we also
 

work to streamline the publication process so that information about quickly changing
 

technical topics can be published while it’s still relevant and accurate.
 

Our books are DRM-free: This ebook doesn’t use digital rights management in any
 

way because DRM makes life harder for everyone.
 

Remember the trees! You have our permission to make a single print copy of this
 

ebook for personal use, if you must. Please reference this page if a print service refuses
 

to print the ebook for copyright reasons.
 

Caveat lector: Although the author and alt concepts inc. have made a reasonable effort
 
to ensure the accuracy of the information herein, they assume no responsibility for errors
 

or omissions. The information in this book is distributed “As Is,” without warranty of any
 

kind. Neither alt concepts inc. nor the author shall be liable to any person or entity for any
 

special, indirect, incidental, or consequential damages, including without limitation lost
 
revenues or lost profits, that may result (or that are alleged to result) from the use of these
 

materials. In other words, use this information at your own risk.
 

It’s just a name: Many of the designations in this ebook used to distinguish products
 

and services are claimed as trademarks or service marks. Any trademarks, service marks,
 
product names, or named features that appear in this title are assumed to be the property 

of their respective owners. All product names and services are used in an editorial fashion
 

only, with no intention of infringement. No such use, or the use of any trade name, is
 

meant to convey endorsement or other affiliation with this title.
 

We aren’t Apple: This title is an independent publication and has not been authorized,
 
sponsored, or otherwise approved by Apple Inc. Because of the nature of this title, it uses
 

terms that are registered trademarks or service marks of Apple Inc. If you’re into that sort
 
of thing, you can view a complete list of Apple Inc.’s registered trademarks and service
 

marks.
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